question

Silvio Franceschini avatar image
Silvio Franceschini asked

Access to Red Node via ip adress:1880

Hello
I'm very new to Venus OS large, just installed it and try to connect to signal K and Node Red to have a look. Unfortunately I'm not able to connect to the Node Red server at all. Seams there is a mistake I do. May someone can help me out, as I could not find any further infos.
I tried:

- via venus.local:1880
- via IP:1880

but both does not work at all. I'm able to connect to signalK via both methods :3000

I tried with switched on both signalK and Node Red and just one.
I tried on different browsers, all the same "access denied" error.
As it works with SignalK :3000 I'm don't believe it has something to do with browser setting.

Thanks for your help

Venus OSNode-RED
22 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Silvio Franceschini,

did you reboot after activating node-red?

Anything in /var/log messages?
Is node-red running? Login to the console and type in

ps | grep node-red


0 Likes 0 ·

@Stefanie

Thanks for reply and help

I reboot and change OS back to original and back to large OS, switched on and off Node Red and reboot.


Now I can’t follow you anymore. Not to much into console etc. I know about them on a computer can use it a bit, tried to find something about venus OS commands etc. online but I guess it exceeds my knowledge.

looked trough some of the manuals but I’m probably more on the enduser side as development.

Looks I need to change to "super user" and create a password etc?

Not sure you want to guide me through all of this. but if you can advice which manual may can bring me forward, would be cool. Gracias

0 Likes 0 ·

It's not that difficult.

Yes, to get root access you need to set access level to superuse, create a root password and enable sshd.

Here is the guide how to do this: Venus OS Root Access

Once you have access vis the console, follow my questions from the other post to make sure node-red is running.

0 Likes 0 ·

Hello again

Have setup root pw and enter via terminal console, easy. but now :-)

root@einstein:~# ps | grep node-red

830 root 1604 S supervise node-red

1450 root 1748 S multilog t s25000 n4 /var/log/node-red

5175 root 102m R node /usr/lib/node_modules/node-red/red.js

5388 root 2684 S grep node-red

root@einstein:~#

To enter the var/log directory I fail. Got some lists with terminal commands, tried around with cd.. , cd/ , ls , etc was not working at all :-/

only thing worked was:

root@einstein:~# pwd

/home/root

Also tried again to reach :1880

Thanks -

0 Likes 0 ·

It's definitely looking different compared to what the output is on my Cerbo GX. And doesn't seem like it has started node-red. Here is how it looks like:

root@einstein:~# ps | grep node-red
  914 root      1604 S    supervise node-red
 1528 root      222m R    node-red
 1531 root      1616 S    multilog t s25000 n4 /var/log/node-red
22455 root      2684 S    grep node-red

Not sure what went wrong on your installation, but maybe you could try install the new firmware again. It should work basically out of the box.

In Cerbo go to firmware, install from SD/USB (supposed the swu file is on USB), check for firmware on /SD/USB and press to install.

bildschirmfoto-2021-02-01-um-082930.png

0 Likes 0 ·

Thanks, well I tried to install the version 10 no success and I installed the version 12 again and also there still the same:

SignalK is running but not so Node Red. I guess I wait for the next version. Even I can't really believe it has something to do with the system.

venus-swu-einstein-20210111143247-v2.70_3-large-10.swu:


root@einstein:~# ps | grep node-red

952 root 1604 S supervise node-red

1559 root 1616 S multilog t s25000 n4 /var/log/node-red

4025 root 3040 S {node-red} /bin/bash /usr/bin/node-red

4026 root 3040 S {node-red} /bin/bash /usr/bin/node-red

4172 root 2684 S grep node-red

root@einstein:~#



venus-swu-einstein-20210113205511-v2.70_3-large-12.swu


root@einstein:~# ps | grep node-red

962 root 1604 S supervise node-red

2794 root 1616 S multilog t s25000 n4 /var/log/node-red

3422 root 3040 S {node-red} /bin/bash /usr/bin/node-red

3423 root 3040 S {node-red} /bin/bash /usr/bin/node-red

3431 root 2684 S grep node-red

root@einstein:~#

0 Likes 0 ·

Please post an image from the Cerbo remote console "Venus OS Large features" settings. Be aware that you need installer access level (root access as explained) to make changes ie. Signalk enable/disable and Node-Red enable/disable.

I'm still not convinced that node-red is running. By default only Signalk is enabled.

More on that here: Venus OS Large image: Signal K and Node-RED

0 Likes 0 ·

Sorry to waste your time, may I do something really wrong :-/
I tried again, switch off, reboot, switch on again reboot. all the same:

same when using IP :1880
bildschirmfoto-2021-02-01-um-201623.jpgbildschirmfoto-2021-02-01-um-201913.jpg

0 Likes 0 ·

What is the local ip of your Cerbo GX? And what does it say when you click on details?

If it is for example: 192.168.1.60
use this as address in safari: 192.168.1.60:1880 instead of venus.local:1880

0 Likes 0 ·

:-) I did, back and forth: ip or not does not make a difference with remote console nighter with SignalK

bildschirmfoto-2021-02-01-um-204651.jpg

bildschirmfoto-2021-02-01-um-204609.jpg

0 Likes 0 ·

I see. What about your macOS firewall settings, is firewall off?

0 Likes 0 ·

Firewall was ON, but I now also tried with OFF, no difference.
Would it not also be the same with :3000? What you say from console its not running at all?


0 Likes 0 ·
Show more comments
2 Answers
Mark avatar image
Mark answered ·

Please confirm exactly which large image FW image you have installed (provide the file name) and what GX device you are using - there was an issue with a recent FW preventing NodeRED access on VenusGX devices, this issue was rectified in the very latest available large image FW.

PS. I have also moved this question into the 'Modification' section.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks for that, also to Stefanie.

Sadly can not post my answer in the comments. nothing happens after press publish ??

I run it on a cerbo GX and use the "venus-swu-einstein-20210113205511-v2.70_3-large-12.swu" which I guess is the latest version.

0 Likes 0 ·
janvd avatar image
janvd answered ·

I have the same problem accessing Node Red offline. Unfortunaly I have no internet connection on site. I suspect that the software want to acces https://registry... but can't. The device is a Multiplus GX with a nanopi, large image version 16 and later on version 17. I had no problem on my test setup with a raspberry pi 4 device, however this rpi4 has access to the internet.node-red-nanopi.png


node-red-nanopi.png (36.5 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.