alexander-uhde avatar image
alexander-uhde asked

Fixing "dead" Multiplus-II GX / Applying nanopi installer image

Hi guys,

maybe some of you can help me out here.

I am running a Multiplus-II GX and updated to v2.62 (online) recently.

I am also running the node-red-contrib-victron on a separate VM, so I had to change my dbus over tcp settings, as described on github.

With v2.58 and v2.60 this was running fine until now.

Long story short, this time it seems I have messed things up a bit. After changing the configuration in v2.62 I cannot reach my GX any longer over network. The Multiplus-II is reachable via MK3-USB, firmware updates for the Multiplus, changing configuration etc. is working fine this way.

But the GX won't show up. Is it possible to reinstall the GX "from scratch" via the ?

I put v2.62 of this via BalenaEtcher to a USB stick, as well to a microSDHC (using an USB microSD adaptor for this).

How can I start the reinstallation process? I tried pressing reset button when starting the device, as well as "Push button A", but this does not seem to work.

Is there any other button on the board itself, or some pins I have to shorten?

Right now, I did not detach the nanopi GX to have it on the table (this would mean to completely get the Multiplus off the wall and cables.

Many thanks for your help and have a nice weekend!


Multiplus-IIVenus OSfirmware update
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.


Is there a way to connect via serial console? I did not find a description for the nanopi GX, maybe someone of you has a schematic drawing of the board?

As I said before, at the moment I am still reluctant to detach it completely from the Multiplus to have it "on the table".


0 Likes 0 ·
4 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi, I would advise against rerunning the installer image: you'll also wipe out the serialnumber, wifi wpa-psk key as well as some other data installed in the factory. And, the tricks you tried via USB won't work anyway; you'll need to access the real sdcard slot which is on the invisible side of the nanopi.

Serial console cable, yes thats possible.

I made one the other day, and made a photo of it too: I've added a photo to the serial console section on the root access page:

I have no idea how accessible that is I'm afraid. Hope it is without dismantling the device.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks @mvader, I already had seen this photo, but was not aware that this also refers to the GX in Multiplus-II. So, I will give it a try with serial console. I think there is no way without dismantling it, there is no direct access from the front possible. Thanks again and have a nice one!

0 Likes 0 ·

you too! Seeing that photo would be rather impossible, I added it only a few minutes ago, and happened to have made it last week. Perhaps you saw another one?

Anyway success!

0 Likes 0 ·

ps make sure to scroll down at that page, it at the bottom

0 Likes 0 ·
alexander-uhde avatar image alexander-uhde mvader (Victron Energy) ♦♦ ·


Ok, scrolling to the bottom made the change!

Indeed, I was only looking at Cerbo GX, which I had seen before. So, I will put my screwdriver away for now - already started to get the Multiplus off the wall...

These pins sholud be accessible without dismantling.

I will give you an update (maybe tomorrow).

0 Likes 0 ·
alexander-uhde avatar image
alexander-uhde answered ·

Thank you once again, for now everything is up and running. (Including dbus over TCP for node-red :-) )

I messed up the listen command on dbus.

PINs for serial connection were accessible (after some fiddling) even for my fat fingers...

Thanks again for the photo @mvader, I would have gotten no other choice than detaching the whole unit from the wall without this one.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Glad to hear its fixed!

0 Likes 0 ·
alexander-uhde avatar image alexander-uhde mvader (Victron Energy) ♦♦ ·

Yip, if you make something idiot-proof, someone will make a better idiot.

Thanks to you and Victron for making these things really robust, my "blind tries" before attaching the serial cable could have really gone worse.

I made an improvement to the Multiplus manual:


Also, for those interested, a short overview of the dbus/ node-red dashboard


Main reason for this:

I was not quite satisfied with the behaviour of "battery life" in these dark winter days.

Of course, with snow on the rather flat solar panels, system would start charging batteries from grid.

Moreover, if a bit sun came out, system would use PV to charge batteries over the adjusted treshold, just to discharge them soon again.

Do not get me wrong, I am not complaining about this- this behaviour is fine if you have a change of "darker" and sunny phases. But in the long german winter, I wanted to adjust this behaviour more to my needs.

Now, if I switch on "Max inverter = PV power -80 watts", PV power will be used primary to power the household. Discharging of the batteries is prevented automatically by this switch.

So I have some sort of "battery life" even in longer phases without PV power without using the grid.

This is my schematics, if anybody is interested, fell free to ask me for sharing:


Have a nice sunday!

0 Likes 0 ·
alexander-uhde avatar image
alexander-uhde answered ·

To clarify: I just had to correct the "unluckily pasted" dbus configuration.

There was no need to reinstall the whole system from image.

Just did the update to v2.62 from USB once again (to make sure everything was corrected which I messed up previously), restored the last configuration for Multiplus via VEconfig and MK3-USB and corrected the dbus config for node-red.

Happy for now, let's see if everything still works tomorrow when sun comes up.

Sleep well!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Simon Fey avatar image
Simon Fey answered ·

This thread helped me a lot to understand how the multiplus-ii-gx is built. I guess I managed to run out of diskspace during flashing a swu-large file and am now stuck with a non-booting unit. The inverter itself however still is operating fine. Since this is a dev-unit I might give it a try to reach the nanopi's SD card slot. @mvader (Victron Energy) I assume is a bootable SD card image that copies your image to internal flash. Could I just boot an appropriate live system, extract the /data partition, reinstall and restore the /data partition - theoretically?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.