question

Bryan avatar image

Cerbo not booting - flashing orange light after failed firmware update

Good Morning,


This morning I started to install the Cerbo in my system. Booting the device with minimal connections went great, and we began to connect the Quattro, Solar via USB, and BMV via VE direct.

A firmware update was detected, and we chose to update to 2.60 - at some point after telling it to perform this update, the Cerbo will no longer boot. (I assume its not booting). We were using the wifi, and check for updates, under the system menu. When it found the 2.60 update, we told it to download and install. It didn't automatically install, but showed in the list of "alternative backup firmwares" to boot from. We chose to boot 2.60 instead of 2.57 and on the next restart, the Touch 50 GX remains blank, and the red / orange Wifi light will begin flashing after a few seconds, but nothing else appears to happen.


1.) Is there a hardware or backdoor way to force the Cerbo to reboot back to the 2.57 firmware?

2.) Is there a way to connect to the Cerbo via a computer and manually push a new firmware to it?


Unfortunately going back to the dealer is a VERY lengthy issue at this point. We're in the Caribbean, and floating in French Martinique at the moment. Anything we do would require weeks and weeks of shipping each way, so hopefully there's a technical way to solve this, as I believe it's just a bad firmware boot, and going back to the old one would be fine?

Thanks in advance for your help.


cerbo gxFirmware Update Issuecerbogx
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi Bryan,

being able to get into this situation was a bug in versions prior to v2.60.

Here is the change log entry from the v2.60 changelog:

  • Disallow accidentally booting into an incompletely installed firmware update (this was -sometimes-possible by using the backup firmware menu. Not any more)

Its impossible to field-fix this yourself (unless you’re a linux expert, know what to do, and have a special console cable), and also nobody will repair this, also not our repairs department in The Netherlands. Its simply to rare, the procedure to fix it is too uncommon and specialistic. The only solution is to get a replacement, which we’ll get you under warranty as per link of Guy.

I’m truly sorry this happened to you! Installing your new Victron system should be a good experience, not this.

All the best, Matthijs

4 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ps. As we won’t repair it, you’re welcome to ask (and maybe a link to this thread) that we provide you a new unit. That would save a lot of time going back & forth.

Ps2: if you know your dealer, then just contact him, instead of the form - either works the same.

I actually am a Linux expert, may have the console cable but would need to adapt it to your board most likely, and have worked extensively with embedded SOM products, and custom manufactured carrier boards I was the technology director and lead developer in just such a system just like yours.

I have sourced another unit at this point, so probably won’t invest that kind of time and energy in the dead unit, but I’m glad it’s fixed in the latest firmware.

Is there anything I need to do to specifically avoid this situation when I update this new unit? Obviously an interruption or reboot during the update is bad and would cause this, but that’s not the case previously, it restarted on its own...just don’t want to brick a second unit. Maybe SD card install vs internet delivery?

Thanks for all your help

:-) - thats quite the coincidence / slim change that you actually are a Linux expert.

Yes, if you install the firmware update through sdcard you won't have this issue. The other way to prevent it is to not use the backup firmware option in the menu in case it didn't already boot into the new firmware by itself.

So, in case you do find yourself with lots of time some day, see here for how to connect the Console:

https://www.victronenergy.com/live/ccgx:root_access#connecting_on_the_serial_console

And see here for here for some indication of what files will be missing in case you reflash the whole unit. There is another option btw, which is the update the u-boot env to boot the other partition rather than the half installed one. But now I'm getting into all sorts of things for which myself, nor any colleague at Victron can help you with in case you go along this route.

https://www.victronenergy.com/live/venus-os:extended#appendix_a_-_repartitioning_venus_gx_flash_memory


So same remains, also for anyone else coming along this thread in the future: replace it; don't try to do anything else, as nobody from Victron will be there to help - too specific knowledge. And my apologies, and success with the installation!


Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @Bryan,

Sorry to hear about the trouble.

I think I made the claim that all Victron firmware issues are recoverable - I was at the time only thinking of the power electronics (and updates via Bluetooth, VE.Direct, VE.Can and VE.Bus). So my previous bold claim may not apply to the GX range.

There may be things you could do to recover from the situation yourself, but the strongly recommended pathway here would be filling out this form, and requesting a replacement unit - http://professional.victronenergy.com/support/

Please don't take this as admonishment that you've done anything wrong here, I don't think you have, but there is a standing bit of advice - if something is working - do not update the firmware unless you are experiencing an issue that it fixes, require a feature that is added, or are told to by Victron. UPDATED TO ADD - the other time I forgot to mention was to always do a firmware update is on the initial installation - so that everything is current from the beginning.

We work really hard to make our firmware updates really safe and issues are very rare, but once the system is installed and stable, not updating will still be safer.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hello Guy,

Thank you for the response, I appreciate the feedback on my dilemma. This is a brand new install of the Cerbo GX and Touch 50, as a replacement for a CCGX.

I’ll go the support route with this unit. I was able to source another Cerbo here in Martinique that we can move forward with while I figure the details out on the dead unit.

Thanks,

Bryan

Paul B avatar image
Paul B answered ·

I dont like your chances here. However as the cerbo also has a wifi hot spot and Bluetooth access try these. and see if you can connect.

I would try bluetooth first and then try connecting via victron connect app and see if you get a connection. then update the firmware again

Or try this and it may help.


pressing push button a few seconds resets only the network settings. Pressing it thirty settings resets all to defaults.

1604816850197.png


1604816850197.png (27.2 KiB)
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks Paul, I was afraid of that - considering the circumstances. I remember reading somewhere though that ALL Victron hardware is recoverable. I suppose the question is, is it recoverable by me , or will it require special tools and connections only available to dealers or shops?


The Bluetooth isn’t active, and neither is the WiFi - I do however get lights at the Ethernet port when plugging into that. I attempted to use VE Bus connections and get it through Victron connect, with no luck.

I’ve worked on components like this before, we used to manufacture boards and modules very similar to the Cerbo - I would think there would be a spot inside I could jump to force boot to the SD card slot - or a tool that I could run while plugged into the Cerbo to force a firmware load.


Is there a way to get Victron tech support involved directly? My dealer is worthless, as they’re just an internet shop that I order through and don’t even speak the same language as I do, so conveying issues / problems is very difficult. Will any dealer assist me or just the one I purchased it from?


Thank in advance,

Bryan

Noisy Boysie avatar image
Noisy Boysie answered ·

oh balls, this has just happened to me. I was on 2.58 and restored a backup to 2.60 as I was testing 2.60 prior to moving to it perminatly, it booted fine but was still seeing issues with mqtt only showing the serial number as per https://community.victronenergy.com/questions/10149/mqtt-only-showing-serial.html

All I did was reboot in the remote console, it never came back up

Not so rare then. :(

Boysie

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

oh no! Super sorry about that, and the hassle that follows.

Ofcourse, you’ll be able to get a new one under warranty. (Contact your dealer for that)

Matthijs

hurrah...I fixed mine, I used a

FTDI232 USB to TTL Serial Converter Adapter

to connect to the console and I spotted I had added the setting to enable dbus over tcpip twice in the conf file /etc/dbus-1/system.conf this causes the network to not come up and everythign else beyound that...not very robust this...anyway hopfully this will help others if it doesnt boot.

btw the baud rate is 115200 and you can use putty to connect to the com port your usb adapter shows up on.

When you get to the consol you get the same root user so history works and you can see what you last did and undo it if its the casue of the failing to boot as far as wifi.

Boysie


Ah ok - good to hear. Then this is a totally different issue as the original one discussed