question

wildebus avatar image

Cerbo firmware 2.65 update won’t install

I tried to update my Cerbo firmware from 2.60 to 2.65 via the usual VRM procedure. However it seemed to get stuck on "updating ..." and nothing got updated.

Also something did happen as I have lost the previous OS version in the "Stored Backup Version" tab. Whereas before that gave me the option of reverting to 2.58 or sticking with 2.60, now it just says "backup firmware not available".

I download the enstien .swu file from Victron Professional and copied to an SD Card and tried that way and while the cerbo recognises there is a firmware file on the card it will not do anything with it.


Before I tried the 2.65 VRM style update on the Cerbo, I checked it on the RPi I have and that installed fine in the usual way and in the "Stored backup Version" tab I have 2.65 running and 2.57 as a backup, so that is all normal.

What do I need to do to get the Cerbo updated? it seems it will be stuck on 2.60 forever! and losing the ability to revert is a bit worrying as well.

cerbo gxFirmware Update Issue
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi Wildebus, its normal for the revert to not work anymore once the download of the new version has started. Thats because its being written to the same location where the previous version was installed first.

Now the question remains why the update doesn’t work. Have you already rebooted in between the attempts?

And I do I read correctly that the update failed both when using the offline method via sdcard/stick as well as from the internet?

5 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

I have tried multiple times.

I did a reboot via the Remote Control Panel; I did a power-cycle a couple of times by pulling the power plug into the Cerbo; Also tried the process on different devices (a PC and a tablet) just to see if that made a difference (nah).

Also tried copying the firmware file onto different SD cards.

At a loss to know what to do - is there a factory reset option to go back to the shipped version? I've done updates to the RPi, a Venus GX and the Cerbo before and never had a problem until this time (and was keen to get 2.65 for the MP firmware upgrade ability you introduced which would have been so cool! (I keep losing my MK3 Dongle :( ))

Hi again, is it ok if we login in to the system? That will be next week. Its Cheyenne I suppose?


no worries, we’ll get it sorted one way or another.


wildebus avatar image wildebus mvader (Victron Energy) ♦♦ ·

yup - go for it :)

wildebus avatar image wildebus mvader (Victron Energy) ♦♦ ·

Hi,

I thought I would just give this another go last night and kicked off the update and just left it and went to bed .....

In the morning I have 2.65 on the Cerbo! so problem solved but not sure why it wouldn't do before.

Ah well, happy days :)

ok thats good!

thanks for letting me know.