question

on2itmaclennan avatar image

Easysolar II GX - Grid parallel on AC-IN with ESS does it work?

Hi all,

Has anyone managed to do this with an Easysolar II GX and the CT with nothing connected to AC-OUT-1 or AC-OUT-2???

I have an Easysolar II GX set up in grid parallel mode on AC-IN (as pictured below). It is configured with ESS assistant and the Current sensor on my mains (I am using the AS/NZ grid setting). I have other Grid Tie inverters in parallel with AC-IN. Basically using the Easysolar as an AC coupled storage system (store energy in battery when excess solar and use energy from battery when no solar).. The system works perfectly except it keeps failing during the charge cycle typically around 90% SOC. I have also noticed that the GX part of the Easysolar keeps power cycling.

Has anyone experienced this failure? The symptoms are the Multiplus supplies loads perfectly and charges perfectly except when the "GX device" loses visibility of the built in Multiplus (sometimes it also loses the built in MPPT which I am not using and the internet connection). At this time the GX remote console can't see the Multiplus or any ESS configuration so it just turns off and never recovers until I reboot from the remote console OR switch off with 3 position switch on inverter. When rebooted it works again perfectly but rebooting every day once or twice is not practical.

I suspect a fault or firmware issue or memory leak or something wrong with the charging algorithm???

Any ideas or help would be awesome, things I have tried already:

Turned on DVCC, temporarily fixes the issue for 24hrs then goes back to failing on charge cycle

Connected by ethernet not wifi, didn't fix the issue

Set inverter up from scratch again, didn't fix the issue

Did all firmware updates again (with GX device disconnected), didn't fix the issue


This is what I have except nothing connected to the "No break loads". My battery is just AGM with no smart BMS etc.


Thanks in advance

Andrew



ESSEasySolar All-in-OneAC PV Coupling
1603844439522.png (64.1 KiB)
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
misullivan avatar image
misullivan answered ·

Thought AC coupled (especially with output feed limiting) was supposed to have the ac coupled grid tie inverter downstream from the Victron? (Iie on AC-Out)

9 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Misullivan,

According to the manual it is fine to do both. I understand that the Grid Tie inverters if connected to the AC-Out can participate in islanding but I am not using that feature (UPS). When the grid fails my Victron also disconnects, it does not create an island.

When you say output feed limiting do you mean set up as an ESS for self consumption?

One setting I have implemented but not mentioned above is a limit on the AC of 20Amps simply because the MCB in my distribution board was a 20 Amp and I was not intending to change it. If you think this could be an issue I can easily swap the MCB and remove the limiting setting. My issue is always with charging is always during the Absorption to Float end of charging so not close to 20 amps.

Thanks

Andrew

You can certainly get put a fronius inverter upstream (in parallel) with the Victron, however if you wish to use the zero feed in functionality I believe (and I am not an expert) the only way to do this is have the fro it’s downstream of the Victron, not in parallel.... this is because the Victron will adjust the output of the fro its by varying the voltage/frequency to cause the fronius to step down its output.


Now reading back on your post I realize I have made (mistakenly) and assumption based on the diagram... I’m assuming your other grid ties are Fronius. I’m making a second leap there as well... but that I think is correct... you’re trying to use the excess solar power generated to charge batteries rather than export so you can ten use the excess later when the solar is not great enough... as part of that I kept in the first instance you’re trying to do this with either zero feeding or limited feed in (eg here in Aus, I am not alllowed to feed in more than 5kw on a single phase... so if I generate 10kw either I have to back off or store it somewhere.. you want to do the latter.)


Now as to the other part of the issue is the GX going offline...


I have seen this (sorta) on my system... I have seen in my system the solar charger go missing, I have seen the BVM go missing and last time I rebooted it, the Multiplus went missing... 2 reboots and everything is back to normal... I have another open post looking at it.. I suspect it’s an I’d clash on the ve.direct bus.. but that’s me... if yours is going off completely losing everything including the console... is the display working on the front? If so the GX is working... this should mean you can remote console in.. if you cannot, check network. If you can it sounds similar to my issue.. first thing to check is the cabling.. particularly the ve.direct cables... also check the terminals on the solar charger... my last unit came with the connections inserted too deep and clamped on the insulation which gave an intermittent battery connection... result was the charger rebooted randomly and each time the negotiations with the GX ended up with something going missing.... fixed that and now the problem is only every couple of months..

Hi Misullivan,

Thanks for the update, you have the idea on what I am doing but you have not understood how I am doing it. I'm not using any Fronius inverters, my grid tie inverters are not communicating with the Victron, they do not need to. The CT that plugs into the Victron is around the mains cable so the Victron knows what is being imported and what is being exported and it is configured to maximize self consumption. It works well and is done extensively in Western Europe (according to the Victron documentation). The issue I have is specifically with the Easysolar II GX package and the components failing? regularly and consistently.

I believe I have multiple issues with the Easysolar II GX I purchased and some sound similar to yours!

  • The issue I really want fixed first is the issue where the GX part of the Easysolar II GX (namely the display) loses connection to the Multiplus part of the Easysolar II GX. This is repeatable and happens 1-3 times a day specifically during the later part of the charge cycle.
  • Another issue is the GX part sometimes loses connection to the MPPT like yours but I am not using the MPPT at present.
  • Another issue is the GX part sometimes loses connection to the internet but I think I have solved that with the ethernet connection (next)
  • Another issue is the wifi card seems to have very poor performance (pretty sure it is faulty) so I am using ethernet now.
  • Another issue is I have seen the GX part (display) can re-boot without reason (I have only seen it happen during heavy charging where the cooling fan was working). It rebooted about every minute for the majority of the bulk charging phase (I took a video).

I have checked the cables that are easy to check and do not believe it is a cabling issue otherwise my issues would not happen at exactly the same stage of charging every day.

I will try to search your other posts to see what is resolved but if you discover something that is relevant to my issues I would appreciate if you can let me know.

Thanks again

Andrew

ok so you noted heavy charging can be a reason... is the unit getting cooled properly? (there should be at least 10cm clean around the unit) and it should not be in direct sunlight (especially not outdoors)...?


What version of the GX are you using (firmware)?


Note: the GX device is effectively the display (if it's not working the GX isn't)


When I referred to the MPPT, whilst I am using it, and you are not, unless you have actually disconnected it, it is on. If there is a loose connection on it (or like mine, crimped on insulation connection) then it will randomly reboot.. if this happens you will see issues like I had (even though you are not putting any solar into it). What version of firmware is on it?


The cables to check are under the front cover of the GX, if you are not an electrician or electronics engineer or Victron agent, I would get someone to do it for you, there are dangerous voltages there and you can do a lot of damage if you don't know what you are doing. Whoever does it will power down the unit completely ac-out (ie turn switch of off), ac-in (breaker), solar (which you don't have) and finally battery. then remove the bottom cover, then the blue cover being careful with the ribbon cable to the display. The person will then check all the cables individually looking for any signs of damage in either the plugs or the cable insulation, the solar charger is on the front at the top, 4 cables in it, they should not move if they do they are incorrectly tightened.


You mentioned WiFi card... as far as I know there is no way to put a 'WiFi card' in it, it will be a dongle in one of the USB ports under the bottom cover. If you're not using it (even if you want to), remove it... it could be part of the issue (especially if it's a cheap chinese one)... it does sound like the GX is rebooting a lot.. which could indicate a kernel crash, there are only a few reasons it would do this...


  • Overheating
  • bad bus connections (CAN or ve.direct - again intermittent connections)
  • Bad power (from the battery) - an intermittent fault on something else (eg the MPPT) could be causing the issue.
  • bad wifi dongle or other USB device
  • running development code on the GX
  • bad network data (something attacking it) - I assume you have taken standard security precautions and either firewalled or not put it on a public IP (static or otherwise)
  • a fault in the hardware (I have left this until last because it's unlikely - there are a few things that could be happening, but the fact it's basically working and not blowing breakers/fuses etc would suggest it is unlikely.)


That's all I can think of off the top of my head at the moment. hopefully someone like @Daniël Boekel (Victron Energy Staff) may have more ideas?


Regards,


Michelle

Hi Michelle,

Thanks for the ideas, I will check the cables again but can't believe it is the issue. My system is installed indoors out of the sun and cooling does not appear to be an issue as I have not felt any heat come from the easysolar that would concern me. I didn't notice any dongle for the wifi under the bottom cover but I will check under the front cover again and pull it out if there is one (pic below of under bottom cover from the manual).

The GX (display) works, it sometimes reboots when it shouldn't and it often loses connection to the other devices.

Gateway firmware is v2.60

VE.Bus System firmware is 477

Solar Charger firmware is V1.50

1604014711930.png (285.1 KiB)
ok 2.60 is the latest - this is the version I am running, and I do see this loss of device after reboots of the GX... this I have spoken about here:


https://community.victronenergy.com/questions/65845/odd-behavior-of-easysolar-ii-gx-when-sun-is-strong.html


Not sure if the Solar charger is v1.50 on mine (not sure if that's the latest)..

IIRC 477 is the latest for the Ve.Bus.


I don't know if you can, but if you can you might want to downgrade the 2.60 to 2.59 unless you have a good reason not to. I didn't see the loss of device issue on 2.59 after reboots.


Looks all in all like the problem is not necessarily a problem with the device itself but with the reboots happening so often (at least to me) as you're describing behaviour I have witnessed myself - with the exception of constant reboots.


Reboots can be for a number of reasons as I mentioned before - bad network traffic can cause them, though this is rare now.. The GX device is build on a linux kernel so anything that can crash linux will most probably also crash the GX device. I, personally, have for that reason put my Victron on it's own dedicated network which has no devices like phones, tablets, laptops or computers on it. It also has no incoming traffic allowed, only outgoing traffic for the VRM portal. I also put it wired only.


The connections you are showing in the picture are the under panel connections, unless there is something very bad (and most likely noticeable) that is not where I would expect the problems to be if there are any loose connections.. the ve.direct and solar charger connections are under the blue panel above... note my warning... If you are not an Electrician, Electronics Engineer, Victron Agent.. don't touch, get one of the three to check it for you as there are dangerous voltages under there and it's easy to destroy the whole unit if you don't know what you are doing!


You can see in that photo 2 ports, one white and marked ve.direct and the other with the USB symbol (ve.direct - top row first from the right and USB - third from the right.) From your description of the setup I expect nothing to be plugged in either... If the USB does have something in it (might look like a little black blanking plate) that'll be the wireless dongle. If the ve.direct has something plugged in, please post what it is and firmware version.

Are you setting the IP on the Victron Dynamically? Are you using the same network for it as other devices? (IoT devices, phones/tablets/computers etc) Can you isolate it from those devices to see if the system becomes more stable?


The next steps I would do personally is isolate it from every thing (network wise) and see if it still reboots... I wouldn't be as concerned at the moment with the loss of devices after a reboot... if the reboots are solved, the problem with the devices disappearing becomes less of a problem that a future firmware might resolve.


Regards,


Michelle



Show more comments
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @on2itmaclennan

does it give any errors on VRM error log?

what is the VRM-id? (or url)

11 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Daniel,

There are no errors on the VRM error log. It all just stops working until a reboot (already rebooted once today, normally needs twice).


VRM portal ID 0281d80298c2

I am not familiar with sharing but assume you can access with the above info? Otherwise I can add you as a user?


Thanks

Andrew

Not sure why but the share is missing from the post

See if it sticks this time. I think things are pretty limited looking through this share though?

Hi Daniel,

Do you have any further update for me? I purchased 2 of these Easysolar II GX units and am thinking to get rid of both as they just don't work! The second (still new in box) was for an off grid install with no connectivity but there is no point installing a product that keeps turning off!

Can you please let me know if you are working on an update or a bug fix? My system below still fails 1-3 times a day and I have to log in and re-boot through the remote console.

I see others are having similar issues, it really can't be hard to fix given that at least in my system the issues happen consistently.


Thanks in advance

Andrew

Hi @on2itmaclennan

I'm sorry I totally missed your updates (I wasn't @mentioned)

do you still have issues with the error 14 vebus error?

https://www.victronenergy.com/live/ve.bus:ve.bus_error_codes#error_14_-_device_cannot_transmit_data

if so: please contact your vendor for repair of the unit.

Hi Daniel, @Daniël Boekel (Victron Energy Staff)

I do not get any error code when my issues occur, I do not believe there is a cable issue and I have contacted my supplier.

I believe there is a bug in the firmware or code, I have been asked to test when not configured as ESS but have not had time yet.

I have also been told that EasysolarII GX is not certified for grid interaction in NZ and that I need to buy a MultiplusII GX. This is not advertised or widely known but given the EasysolarII GX is a multiplusIIGX I don’t know if this is true.

Basically the GX loses connection with the multiplus and mppt when charging, it is always during the last phase of charging AND I have recently discovered it doesn’t happen if the battery doesn’t reach my set minimum charge (I have set the SOC to 70% to prevent over discharge and I have also set minimum battery voltages to prevent over discharge).

I have changed so many settings trying to figure out the issue so need to double check the minimum SOC theory but for the past few days the system has behaved perfectly and the last few days are the only few days I didn’t discharge to 70% and get the low voltage alarm etc.

I have been meaning to check the cables as your link suggests will be the issue but given the repeatability of the issue I don’t believe that can possibly be the problem).

I will keep messing around, can you please confirm how I can tell if I am getting error 14? Surely the device would report 14 if that was the case?


thanks very much for the help.

Andrew

Hi @on2itmaclennan

the error code can be seen in your VRM page, when clicking 'alarm logs'

Yes the Easysolar II GX has the same hardware and firmware as the normal Multiplus II and Multiplus II GX

the cable mentioned is the ve.bus cable, but in your unit that is inside the casing, so shouldn't be something wrong with it.

I've asked some experts if they have ideas about it.


Hi @on2itmaclennan

Can you please try to update to Venus 2.62~2 to see if this solves it?

https://community.victronenergy.com/questions/67901/venus-os-v2622-available-for-testing.html

It fixed a VE.Bus Error 14 issue.

on2itmaclennan avatar image on2itmaclennan Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hi @Daniël Boekel (Victron Energy Staff)

I can confirm the issue is not resolved with v2.62-2. The GX device still loses connection with the Multiplus during the charge cycle with no errors reported.

I loaded test firmware on Friday 20/11/2020 at 9:19am. There have been no errors logged since the 10/11/2020 in VRM. The alarm logs do not correlate with the multiplus losing connection to the GX device at all (basically there are no logs when this happens)

This is what I see after failure:

1605995063493.png

1605995116706.png

1605995153893.png

This is the log but you can see nothing for today or yesterday and the failure occurred both days.
1605995360636.png

Any other ideas?

Thanks

Andrew

1605995063493.png (51.0 KiB)
1605995116706.png (29.3 KiB)
1605995153893.png (34.9 KiB)
1605995347477.png (122.7 KiB)
1605995360636.png (122.7 KiB)

hi @on2itmaclennan


Then it's probably best to replace the GX card (after checking the connections inside)

Normally this should be done by a repair centre, but maybe they can send you one if you can do it yourself.

on2itmaclennan avatar image on2itmaclennan Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hi @Daniël Boekel (Victron Energy Staff),

Thanks for the advice, I'll try and get a replacement GX device and do some more testing. The problem I have is the local Victron support tell me the Multiplus II is not designed for this application and that it will never work and that is why I am having the issue! So I need to configure the system differently (although not getting guidance on exactly how).

My first step is getting confirmation that it is OK to use the Easysolar II GX or Multiplus II GX for a grid interactive ESS with plugged CT (not power meter) connecting loads on AC-IN and the grid tie inverters on AC-IN as described above. Can you confirm that please?

The local support have advised:

Victron MPII does not utilise a High Frequency typography of program control that would work seamlessly with AC in only method used. The typography programmed with Victron MPII must see energy through the H bridge. Thus external CT (outside of the bridge in ESS) or Carlo Gazzi ET112 meter is required in ESS along with AC1 out utilised with load.

For me as an electrical engineer AC-IN and AC1-OUT are electrically the same point and I am using the external CT so it should work. I would like the actual schematic for the MPII if you can provide something better than below so I can verify my understanding of H Bridge inverter chargers. Either way my understanding doesn't line up with the comments above or what actually happens with what I have installed (it works perfectly 99% of the time).

1606008737598.png

Thanks again

Andrew

1606008737598.png (28.8 KiB)

Hi Andew @on2itmaclennan

your intended use (parallel connection) is a normal use case and should make no difference to use with loads on the output.

The external CT technically replaces the internal CT, only thing to make sure: don't extend the cable length of it, that leads to problems.