question

cbaelectrical avatar image

Energy meter not recognised/displayed on color controller GX

Hi

Wondering if any one has had issues or can help with energy meter not recognised on CCGX.

I have a Carlo Gavazzi em 24 energy meter. It is over 65 amps so using CTs and 3 phase installation. There is a direct connection to the CCGX from the energy meter using victron RS485 to USB interface cable. Meter works fine.

Connected terminal 41 yellow, Terminal 42 orange and terminal 43 Black.

When connected there is only a solid red led light at the USB connection to the back of the CCGX, and will not find/recognise the energy meter.

I have since taken the meter to my distributor and we have experienced the same issues when connected at their work shop. Tried new RS485 to USB interface cable.

Would appreciate any feed back if others have come across this issue or have a solution. I understand this is the only meter compatible over 65 amps for the CCGX?

Thankyou

Ben

CCGX Color ControlEnergy Meter
3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Cbaelectrical (and others in a similar situation),

So far, the issues Victron has seen with meters that are not detected are caused by a bad/non-Victron RS485 to USB cable. But in this case, you have mentioned already trying a different cable, so there is the potential that this is different.

Normally there is a red LED towards the back of the USB connector (there is also another kind of cable we sold at one point that does not have this), and a green and red pair closer to the front. The red LED flashes when there is a write event, and the green one when data returns from the meter.

We expect at least that the red one would flash periodically as the CCGX tries to probe for the meter. If there is no red LED flashing periodically, then there is no comms and I'd have to log into that CCGX to see why not. Perhaps the cable itself is not properly detected. If there is a periodic red flash, but the meter is not detected, then I would also like to log in and poke around in the meter's registers.

Can you please confirm you have tried a second new model Victron RS485 cable?

Also what is your observation of the second red LED behaviour? Is there a periodic write flash?

And lastly, what is the VRM id?

robert1508 avatar image robert1508 Guy Stewart (Victron Community Manager) ♦♦ ·

I have 2 RS485 cables. one work second not. can you confirm the working one is a new one.

On photo good one is bottom one. on both photos

tabrocky avatar image tabrocky Guy Stewart (Victron Community Manager) ♦♦ ·

Hi Guy,

Are you able to recall what the issue ended up being for cbaelectrical's issue? My issue is very similar and I believe the issue is with the CCGX not recognizing the victron supplied USB-RS485.

Appreciate if your able to provide some assistance? The system is on-line and able to be remotely accessed.


Kind regards,

Tristan

8 Answers
tabrocky avatar image
tabrocky answered ·

Hi All,

Just an update on my issue with the Color Control not recognising my Energy Meter.

As i suspected the Color Control was indeed Faulty and is being replaced under Warranty by Victron.

With thanks to my local Victron dealer for preparing a side-by-side bench test with a new CCGX, EM24 and USB-RS485 converter which enabled us to swap out components to identify the fault.

I'm not sure if there was a hardware issue with the USB ports in the CCGX however strangely enough my USB to VEDirect cable for my BMV still worked without issue... very weird. What we did notice however was that the faulty CCGX failed to recognise a USB Memory Stick with firmware loaded onto it.

Hence my advice for those experiencing the same issue that I have and have confirmed the Energy Meter and USB-RS485 are working fine when connected up to a computer with UCS 7 software...

Try putting firmware on a spare USB Memory stick and plugging it into the USB port on the CCGX. If it fails to recognise the USB memory stick you may too have a Faulty Color Control.


Cheers Tristan.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

tabrocky avatar image
tabrocky answered ·

Hi all,

I'm currently experiencing a very similar issue to cbaelectrical. My CCGX fails to recognize the EM24 energy meter via the RS485 to USB converter. All equipment has been supplied via Victron (EM24, USB-RS485 converter) and the USB-RS485 converter is the type which has a 3 LED's (power, RX, TX). When the Converter is plugged into the back of the CCGX the TX/RX flash a couple of times and then nothing. The Red power light remains illuminated only. There is no continual TX led polling which would indicate the CCGX is trying to talk to the EM24. Both USB ports on the CCGX have been tested with no resolve.

I've also gone one step further and unplugged the USB-RS485 convertor from the CCGX and plugged into my laptop then using Carlo Galvazzi's UCS 7 Software I'm able to go on-line with the EM24 and view real-time energy usage data. TX/RX led's on the USB-RS485 converter blink rapidly which demonstrates the RS485 link is sound and the converter is working.

Hence I believe the issue lies with the CCGX not recognizing the Victron supplied USB-RS485 convertor.

Given there doesn't seem to be a solution posted above I'm wondering if anyone else has experienced this same issue and how they resolved it?

Would be nice to get my ESS system working however without this key device in the feedback loop I can't get the system on-line.

Also all equipment is running the latest firmware as of the 8th Jan 2021.

Appreciate any help.


Cheers Tristan.

10 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Tristan

My problem was the same. We discovered, by process of elimination, that the problem was with an extension cable from the RS485 of the Victron cable to the Carlo Gavazzi. We used a twisted pair of shielded UTP Cat 6 cable as recommended. When we switched to a different twisted pair, it worked!

We spoke later with the supplier and they had just been informed that using twisted pairs of UTP cable as extensions for RS485 are now known to give problems. They recommended using cables that werent twisted pairs, which seems a little illogical, but that's what they said. In our case simply switching to another twisted pair did the trick (despite the fact that the original twisted pair had continuity.... mystery!)

Of course, if you're not using an extension cable, then it must be something else

Cheers

Lazza


ps check out https://community.victronenergy.com/comments/43736/view.html

Hi Lazza.

Thanks for the response. I'm confident the RS485 link between the energy meter and the RS485-USB converter is working correctly via the twisted pair cable I have installed. As I mentioned in my post if the USB is disconnected from the color control and then plugged into a laptop running Carlo Galvazzi's UCS 7 software the comms link establishes fine and real-time consumption data can be read from the energy meter via the RS485 link and UCS software.

I've also used an Arduino with RS485 transceiver in place of the CCGX and USB-RS485 converter and I'm able to read modbus register values in the energy meter over the comms link (twisted pair cable).

I initially blamed the RS485 comms link and twisted pair cable however I ruled this out as being a fault by removing my CCGX from the system and physically relocating it to where the energy meter is located. I connected the USB-RS485 converter directly into the RS485 connections of the energy meter and powered up the CCGX off a small lead-acid battery with nothing else connected to it other then the USB-RS485 converter - This did not resolve the issue and the energy meter still failed to recognize the energy meter.

Hence I feel the issue is with the color control failing to recognize the USB to RS485 converter.

Hi Tristan, you have probably some parasite troubling your connection between the EM24 and the CCGX. I had such kind of stupid situation, and by moving the UTP cable path a few centimeters from its original path it started working fine.

Remember, we are in an area where several kind of electrical inductions, parasites, etc are created, so they may affect the RS-485 transmission.

Try moving the UTP cable.

Michel

Hi michelg,

Thanks for your response. Unfortunately moving the twisted pair cable is not possible as it's buried underground in conduit and runs ~50m from the main switchboard (energy meter location) to my shed (location of the Victron system and CCGX). It runs in a separate conduit to the power cables and is spaced away from the power cable conduit.

As per my response above to Lazza I have tried removing this twisted pair cable from the system by physically removing the CCGX from my system located in the shed and taking the CCGX to the location of the Main Switchboard and directly connecting the USB-RS485 converter tails (~20cm long as per the Victron EM24 online manual) to the EM24.

This does not resolve the issue. The CCGX still does not recognize the energy meter nor does it look like it's even trying to talk to the Energy Meter (no polling TX light on the USB-RS485 converter).

Hence I don't believe the twisted pair cable is the issue and I believe the issue is with the CCGX not recognizing the USB converter correctly.

Hopefully Guy may be able to provide some guidance? Unfortunately my local distributor is unable to provide any support at the moment.

Hi Tristan, I spent sometime searching RS-485 options / solutions. It should work up to a distance of 1200m... But here, it is not the case. So, a workaround would be replacing the UTP with an optical fiber, and 2x converters RS485-Fiber / Fiber - RS485. This way no parasites, interference will create problems in your setup.

And prices are cheap in my opinion.

I hope it will help you fixing the issue.

Michel

Hi Michel,

Thanks for the suggestion. However as I mentioned the cable is underground in conduit so replacing it with a Fibre would not be possible without digging it up (conduit has bends so not possible to pull a new cable through). In any case with the testing I've done - as described previously - I'm comfortable the cable and the RS485 communcication is not the issue.

Given the symptoms and troubleshooting I've conducted I believe the issue is with the CCGX not recognising the USB-RS485 converter.

I'm receiving little support from my local distributor which is starting to make me regret my decision of going with Victron.

Well, the issue is now clear. The bends are the problem, I remember of my old times installing networks, bending wires was not recommended at all.

So tech details about RS-485 cabling : https://www.felser.ch/profibus-manual/buskabel.html

Also, if you attach the fiber to the actual cable and pull it out, you should be able to replace it easily in my opinion, this is how electrician usually proceed, hooking wires together, and / or adding tape.

The problem is not coming from Victron, but from the installation. you might ask Victron if there is an option to reduce the transmission speed on your RS-485 line, so it may still communicate, instead of 57,6kbps, 2,4kbps.

It is a path to explore.

Michel

Hi Michel,

Thanks again for your response. If the bends are an issue why does the underground cabling work fine when I unplug the USB-RS485 converter from the back of of the CCGX and plug it into my Laptop USB port?

I'm able to communicate with the EM24 without issue via the RS485 link using Carlo Galvazzi's UCS 7 software installed on my laptop.

Hi Tabrocky, probably the software & windows are able to change the communication speed, probably by reducing it, and this is what you should ask to Victron : is there any way to reduce the communication speed between on the USB RS-485 / CCGX ?

At least, we know the cable is not "badly" damaged, as a link is possible. If Victron can tell you how to reduce the com. speed, or add the option in a future firmware, it could fixed your current issue.

Michel.

Hi Michel,

The EM24 only supports two different Baud rates from factory (9600 and 4800bps) I'm able to successfully and reliably communicate with the EM24 via the laptop and UCS 7 software at 9600bps. The CCGX has no option to view or set the baud rate used so I've assumed the default 9600bps setting in the EM24. However I've also tried setting the EM24 to 4800bps and this made no difference. Incidentally Modbus address has been set to 1 as per Victron requirements.

As per my previous comments above when the USB-RS485 converter is plugged into the CCGX the TX light on the converter isn't blinking which indicates the Color control isn't even attempting to request data from the energy meter. When plugged into the laptop each TX LED pulse (request for data from the EM24) is Immediately followed with an RX LED pulse (response from the EM24). This is normal expected behaviour where the Laptop/CCGX is taking the role of a Modbus Master.


Kind regards,

Tristan

sutho avatar image
sutho answered ·

Was there a solution to this one yet, as I am also having the same issue with a Carlo Gavazzi ET340 not showing up on the CCGX. Have triple checked wiring, rebooted CCGX and it still not being listed under Energy Meters.

Further info: when the USB is first plugged into the back of the CCGX, the red and green comms LEDs blink twice and then the red continues to blink periodically with no green response.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

HI Sutho

Have a look at my last comment here: https://community.victronenergy.com/questions/42550/ccgx-not-recognising-carlo-gavazzi-meter-em24dinav.html

I resolved the problem discovering that the issue was actually due to the UTP extension cable. Apparently it appears there are issues with using twisted pairs in some UTP cables. So, firstly see if meter and RS485 to USB cable are ok, by testing on PC software. Then try using a different Twisted Pair, or maybe not even twisted pairs but single wires from different TPs.

Good luck

Lazza


lazza avatar image
lazza answered ·

HI

I'm just having the same problem with a Carlo Gavazzi EM24DINAV53DISX- CCGX not recognising meter. All connected up correctly, and have checked continuity of the data cables-. all fine. yellow in 41, orange in 42 and black in 43.

The cable I have is like the top one in the photos from Robert1508.

On the USB at the back of the CCGX, green light is periodically flashing, but red light is fixed solid


Can anyone help?

Thanks

Laz

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wkirby avatar image
wkirby answered ·

I can't see anything wrong with the wiring.
What is the Modbus ID of the meter set to? I seem to remember someone else having difficulties until they set their Modbus ID to 1.

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

correct, it was me with the ET340 which obviously must be set to "1", noot sure if this applies to the EM24 too

I have just had a look and my EM24 is working on Modbus ID 1 (Address 1).

Thanks WKirby

Yes it is set to Modbus1 this was the default setting, we tried 2 also just to see if it would make a difference.

The LED indicator on the USB plug of the RS485 to USB cable that connects to the CCGX was a solid red on site. At the work shop when tested it was slow flashing. I’m told it should flash rapidly? Not sure if this gives any indication of the issue?

Assuming we have done installation correctly the only thing we haven’t tried is a new meter (maybe faulty?)

Another suggestion was if the CCGX possibly had any downloadable updates that may fix this issue?

Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Forgive the obvious question, but are you providing a power supply to the meter?

Is it possible to post a photo of the installation, which shows all the components and the configuration.

I am scheduled to work on improving the diagrams and documentation for the energy meters this week. I may start with the EM24. This will involve a step by step physical installation, so I will be better equipped to assist shortly.

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Guy

Please find attached some photos of the installation and energy meter terminations.

1 3 5 are grid reference, 8 9 10 11 12 13 CT connections

41 42 43 CCGX , 55 57 240v power supply.

The job is in a remote location so I have brought the meter back to have it tested at my victron distributors work shop with same results. Have checked the default settings on meter as per a victron manual and also had Carlo Gavazzi tech on line to check installation from their end.

Step by step installation would be good.

@Guy Stewart (Victron Energy Staff) did you get round to the manual? I'm experiencing similar issues at the moment on site.

Sorry, I have not, please post some more details of your issue as well and I will pass this thread along to someone at Victron to try and help.

The proper test would involve disconnecting power to my house, and I haven't found an agreeable time for that with my wife yet :)

vicky avatar image
vicky answered ·
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wkirby avatar image
wkirby answered ·

What is the exact model number of your EM24 meter? Are you sure it has the RS485 option?

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The model of the meter is EM24DIN AV5 3D IS X.

On the side of the meter it reads output: RS485 + 3 digital inputs.

I have been told this is the only meter option for over 65 amps which is compatible with the victron CCGX ?