question

ray-mont avatar image
ray-mont asked

VRM data partially not updated after loss of internet connection


dear all

Some VRM data is not updated after lost of internet connection, update interval is set to 1 minute.

Portal Id “38954”

it happened on a RPI version 2.60~30 connection lost for more then 12 hours

Tested it again on my RPI 2.54 Same result(30 min test)


Not update are

BMV SOC

BMV Voltage &Current

MPPT pv-volt & Current

MPPT PV yield

Inverter Volt & Current

system Battery Power

system Battery current


updated are

system AC consumption

system Battery Voltage

inverter state




VRM
1594633567137.png (176.1 KiB)
1594633633400.png (85.6 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

harold avatar image harold commented ·

Currently I miss some data too in the VRM, however via Remote Consol all seems Ok!

0 Likes 0 ·
3 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi @Ray_mont, dank!


I think I see whats wrong here, your devices have shifted:


The enumeration on VRM relates to USB enumeration: plugging / replugging can change it. A bit of a pi issue, since it doesn't have fixed VE.Direct ports.

Normally, once plugged in, and then rebooted once, everything is stable.


To get those graphs, either change the USB / VE.Direct wiring to get back on the old instances; or change the widgets configuration in the Advanced page on VRM.


success!


1594724034124.png (47.5 KiB)
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ray-mont avatar image ray-mont commented ·

@mvader (Victron Energy)

just recheck if I was able to recreate the same issue but I could not.

Rpi with firmware 2.60~31 did send the data correctly to the VRM portal

thanks for all your support

ray

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ ray-mont commented ·

Ok good! Z

0 Likes 0 ·
harold avatar image
harold answered ·
4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

harold avatar image harold commented ·

This one is solved, your too?

0 Likes 0 ·
ray-mont avatar image ray-mont harold commented ·

@Harold

morge

no it has not been solved

Ray

0 Likes 0 ·
ray-mont avatar image ray-mont commented ·

@mvader is it correct that this issue is pending

i just saw your other comment that there was a “visualization issue” and no data was lost

but my missing data did not show up(yet)

groetjes Ray

you and your company are doing a perfect job.

0 Likes 0 ·
ray-mont avatar image ray-mont commented ·

@mvader (Victron Energy) is it correct that this issue is pending

i just saw your other comment that there was a “visualization issue” and no data was lost

but my missing data did not show up(yet)

groetjes Ray

you and your company are doing a perfect job.

0 Likes 0 ·
ray-mont avatar image
ray-mont answered ·

Thanks @mvader (Victron Energy)

this Shifting in the device list happened when tried to recreate this issue on Monday morning
But the data from Sunday 5 o’clock til Monday 7 o’clock is still gone

today after 3 o'clock I will try to recreate the same problem

with the new beta firmware 2.60 ~31


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.