question

chriskelley avatar image

Phoenix Multi plus 12/3000/120 - not charging

Hi, I have a multi plus installation in a narrow boat charging 4 sealed lead acid domestic batteries, I’ve noticed that the unit is not displaying any charging indicator leds when connected to the shore line in both ‘on’ and ‘charger only’ modes. It has worked in the past at this marina. I’ve followed the trouble shooting in the manual, reset the thermal trip, mega fuse is ok, swapped my shoreline supply to a different source. Next step would seem to be changing the dynamic and weak Ac settings using a laptop. Before I try this, is there something obvious I’ve missed / not thought of as it’s worked in the past. There’s no error lights present and when the unit is selected to ‘charge only’ it appears to self test, all lights flash once, then the green ‘mains on’ light flashes 11 times. On the 11th flash the ‘float’ light illuminates as well for a split second before both then extinguish. The inverter light then illuminates for a second and then extinguishes as the ‘mains on’ led illuminates steady - with no charging indication leds.

Thanks in advance for any help.

Phoenix Inverternot charging
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

0 Answers