question

Mark avatar image
Mark asked

V2.40~46 relays only two out of four functional?

Hi All

I’ve just updated my pi3 with this release and all was going well until I tried to add relay 3 and 4. I got the second relay active and working but as soon as I added the 3rd and 4th relays into the gpio list the relay setting page disappears from the main settings page? If I put // infront of the lines the relay setting page comes back. so at the moment the file Looks like-

21 out relay_1
17 out relay_2
//27 out relay_3
//22 out relay_4

with it like this the relay setting page with the two switches is visible and usable.

In my old version 2.30 they all worked?

Any ideas or help would be greatly appreciated

Thanks

Mark

Venus OSRaspberry PiRelay
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
jeroen avatar image
jeroen answered ·

# lines in this file are comments. The leading // is malformed.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Mark avatar image
Mark answered ·

Hi thanks for your answer. My bad explanation sorry I had to malform the lines so the relay settings page came back. If they are not malformed the relay settings page disappears?

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The script /etc/init.d/gpio_pins.sh should create the /dev/gpio/relay links, so with the additional relays and after a reboot check `find /dev/gpio -name "relay*"`. It should report all of them.

If that is not the case and you know how to restore a symlink you can remove /etc/rcS.d/S90gpio_pins.sh, reboot and run the script manually and see what it reports.

If the devices are there, you can check with dbus -y if the relays are present on the dbus, see https://community.victronenergy.com/questions/34195/make-more-than-two-relays-visible-on-rpi-rpi.html?childToView=35913#comment-35913.

Only after that works, you can add them to the gui. Relays are optional so the gui won't show them when not properly configured.

0 Likes 0 ·

Thanks Jerome

I’ll try that

0 Likes 0 ·