question

garethcurtis avatar image

Multiplus II ESS Pylontech batteries - charger won't stop charging!

Hi all,

Finally thought I had my system sorted only to find it won't stop charging! Currently I have no PV so just charging off peak on the grid. I have followed the instructions for the Plyontech setup here:

https://www.victronenergy.com/live/battery_compatibility:pylontech_phantom

And all seemed to be ok until I found the batteries are being charged all the time, right up to 100% and then beyond, setting off high voltage alarms. I just don't understand why it is doing this. I've gone through the ESS assistant, set the various voltage levels etc.

Absorption voltage 53.2 V

Float voltage 53.0 V

Double checked the communication cables, the BMS -> Inverter cable is the correct one and the right way around. I've told it to use the Pylontech BMS. Then I've set a schedule to charge from the grid between midnight and 4am. But actually, the charger just sits in bulk mode most of the time, pushing a small amount of current to the battery. Later switching to absorption. This is all outside of my midnight - 4am window. When that comes around, it ramps up the current to something like 2000W and also continues beyond the SOC limit of 95%?!

Pictures below. As you can see, it goes to 100% and up to 54v despite being told not to. I initially had Optimised with batterylife but thought that might be it, so am now on Optimised without batterylife, but no change.

I have to turn off the AC in connection manually to get it to stop!

Any ideas please? Thanks.

No grid meter, AC input = grid, Pylontech BMS. Cable is set to 500 CAN. DVCC set to on.

Midnight - 4AM charging only

Voltage above 53.2 and still going...

Charges right up to 100% and continues until the Pylontech BMS shuts off at 54v after trigging high voltage alarms.

Charge limit set to 53.2v. Completely ignored.

Ran down the battery. Then switched AC IN on and it starts charging immediately from the grid, albeit slowly, outside of the scheduled charging window.

Why would it always be in bulk or absorption mode, all the time? Why not idle, or off?


Multiplus-IIPylontech
img-5187.jpg (69.2 KiB)
img-5190.jpg (72.0 KiB)
img-5188.jpg (63.2 KiB)
img-5189.jpg (65.1 KiB)
img-5191.jpg (70.9 KiB)
img-5192.jpg (62.7 KiB)
img-5193.jpg (67.1 KiB)
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Daniël Boekel (Victron Energy Staff) avatar image

With ESS (and CANbus Lithium batteries), charge state doesn't really matter.

But...I've found the cause: Guy Stewart was more awake then me:

-Your 'grid setpoint' is set to 50W. so the system is trying to keep the input from the grid to 50W, and when the loads are less than 50W, the rest is diverted to the battery.

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thank you both! That has done the trick. Kind of makes sense now, in hindsight. Sorry for being a bit slow there too : )

Thank you again.

Best,

Gareth.

Daniël Boekel (Victron Energy Staff) avatar image

Hi @garethcurtis

Try checking 'feed-in excess solar power' in the ESS menu. This can help with systems that 'creep up' in voltage.

7 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks @Daniël Boekel (Victron Energy Staff) I'll try it, but I don't want to feed back into the grid though... And as I say, I have no PV currently so it would seem a little odd...

Currently I have set the grid to UK. Am I better off selecting some other option, if I don't want to feedback - something like non compliant grid?


P.S. On the Pylon instructions, in the FAQ/known issues it talks about 53.2 being too high, and overriding the Pylontech BMS - "For this reason we opted to override the BMS and cap the voltage at 52V. This sacrifices almost none of the capacity and greatly improves the stability of the system". Yet the earlier instructions, higher in the page don't talk about this, and set it at 53.2 still. I was a bit confused by that...

@Guy Stewart (Victron Community Manager) are you able to comment on my documentation question please? I wouldn't mind trying this to see if it solves my ever charging problem.

Well spotted, in other DVCC battery manuals I have begun to remove that charge setting section entirely. As it should be overridden when working correctly by the DVCC.

Though, in some cases (like yours) this maybe good to have the correct settings just in case.

I have updated them now.

It won't really feed-in to the grid if you don't have MPPT's installed.

garethcurtis avatar image garethcurtis Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hi @Daniël Boekel (Victron Energy Staff) unfortunately changing that setting didn't seem to make a difference. The multi has charged the batteries 2% in the last 3 hours : (

Any other ideas please? Appreciate your help!

Thanks.

Hi @garethcurtis

What is the name / VRM id of the site? I can take a look if you want.

garethcurtis avatar image

@Daniël Boekel (Victron Energy Staff) yes please. 45089 - is that what you need?

5 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes indeed :)

The battery is not fully charged now, so the setting does nothing, only when the battery voltage reaches the 'charged' voltage.

SOC is being generated by the battery, Pylontech's SOC is known to not always be very accurate.

garethcurtis avatar image garethcurtis Daniël Boekel (Victron Energy Staff) ♦♦ ·

OK @Daniël Boekel (Victron Energy Staff). But you can see the battery is charging yes - outside of my configured window - actually I disabled the charging window altogether and it still goes to bulk mode and charges. The whole purpose of the system is that I want to charge only on my off peak tariff window.

Re 95% - I hope that it does stop at some point, which is one issue, the secondary issue is that it is charging all the time.

Going back to my original question; "Why would it always be in bulk or absorption mode, all the time? Why not idle, or off?".

Hi @garethcurtis

the 'bulk' phase is not meaning it is actually charging in ESS mode.

But I agree: it seems about 0,5 - 0,6A is trickling into the battery, and while this is not much, I'll look into it further.

garethcurtis avatar image garethcurtis Daniël Boekel (Victron Energy Staff) ♦♦ ·

Thanks. Oh, I assumed bulk was the first state of charging. As soon as I turn it in, it goes into 'bulk' immediately regardless of SOC. I wonder, perhaps the 95% is respected by the scheduled charge window, but that it's the 'trickle' charge which pushes it above that. Tonight I'll try lowering the values to 52 as per @Guy Stewart (Victron Community Manager) doc change too.