question

kwagga avatar image

[MultiPlus] Assistants driving relay won't switch off

Good Day gents (and ladies)

I have an interesting issue, that's driving me nuts! - Nuts I tell you!

What I want to achieve, is drive an extractor fan, when the Multiplus is in a charging state (any), and turn off the relay, when it's done charging after some time, quite simple, or so I thought.

I have done a ton of reading on this forum from priorities, up's and down', AND/OR's and vaguely explained logic when it comes to the Assistants, but I still cannot get the Assistants to work correctly.


Summary:

Step 1: Turn the relay on when the device starts charging (incl. Equalisation/Absorption charge) - why? - Because the batteries are in an enclosure, and I want to vent the box of gasses.



Step 2: While charging the relay should remain on, for at least 30 minutes.

IDEALLY: I want to relay to be on for at least 30 minutes, after charging is completed, but that seems too advanced.


Step 3: When aforementioned conditions have been met (aka completed), the relay should turn off.

I have tried different variants, spelling out the off condition, i.e: When not charging for 10 seconds, set relay off - but that didn't work.


So for some reason, the relay comes on, but never, NEVER switches off... what am I missing?


Any support will be greatly appreciated!


Kwagga

Multiplus-IIRelayAssistants
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
kwagga avatar image
kwagga answered ·

Anyone able to advise on this?

4 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kwagga avatar image kwagga Matthias Lange - DE ·

Thanks M,


I'll try it out when I get home this evening, and provide feedback.

I just tested this at our test bench and it works.

But the relay locker must be the last assistant in the list:

To change the order of the assistants, select one and use the arrows on the right to move it up or down.

chargefanorder.png (4.5 KiB)
kwagga avatar image kwagga Matthias Lange - DE ·

Hi M. Lange,


Thank you Thank you!! It works, and works perfectly!!


You were right the locker needs to be the last entry in the assistant menu - which is strange.

Thanks again for the help!

Justin Cook - Bay Marine Supply USA avatar image
Justin Cook - Bay Marine Supply USA answered ·

@kwagga, the one thing that immediately jumps out at me is that your terms for turning off the relay aren't set; in "Programmable Relay (1)", you have the terms set "set relay on" "when charging for 10 seconds", but in "Programmable Relay" you have "set relay off" but no terms of when to set the relay off... I would think that you'd want a term like "when not charging for 1800 seconds" or something of that nature.

If I have some time today, I'll go back to my test bench Multi setup and see if I can replicate your problem and come up with a solution... if I do, I'll let you know.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Justin Cook - Bay Marine Supply USA avatar image
Justin Cook - Bay Marine Supply USA answered ·

@kwagga, just as a side question that's not necessarily related but often is: have you fully updated your Multi's firmware and updated your VE.Config program? I know last time I loaded VE.Config there were Assistants updates... obviously I have no idea if this is related to your problem, but it's definitely something to check.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kwagga avatar image
kwagga answered ·

Thanks Justin,


So I did try explicitly defining the off-rule or term, but it had no effect on actually turning off the relay.


I wish there was some kind of logging, since that would make things a whole lot easier.


Let me know if you can replicate this, it'll be interesting.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.