mattfs avatar image
mattfs asked

Cerbo GX generator communication error possibly since firmware update to 3.31 large

My setup is as follows.

Bluesolar MPPT 100/30 and a vintage generating set charging my 24V lead acid battery bank all loads are DC, with monitoring via a smartshunt.

Smartshunt and MPPT are Ve-direct to usb (proper cables) into the cerbo gx.

Generator auto start settings are by battery SOC. This has been working fine for quite a while then I think after the last firmware update ( I tried the beta for a day first then system has been on float as I was away) all I can get in the console is.

Generator running by communication loss.

I have tried all three options to see if it made a difference, but so long as it was set to start or run the generator was running regardless of the SOC once the run was initiated. If I killed off autostart and stopped the genset then re enabled autostart the genset only started up when the low SOC limit was reached.

In VRM the options panel with the relay switch toggles shows %%KEY_NOT_FOUND%% where the running status normally shows.

When I switch to autostart by battery voltage it works but I have found that to unreliable due to the loads in my workshop pulling the battery voltage down for periods then the voltage bounce back shutting the vintage genset down again which I prefer not to happen to often.

I have been digging around now for over a week online, looking for logs in the venus OS, trying different options such as changing SOC requirements, quiet hours etc, including loading old firmware, talking nicely to it, threatening it, and offering up a silicon sacrifice of my old PWM controller to the god 'whatthefeckiswrongwithit'

I am at a complete loss for where to look next, so any assistance will be greatly appreciated, to get this working under the SOC conditions again.

cerbo gxgenerator auto startfault
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

0 Answers