run-the-race avatar image
run-the-race asked

Multiplus compact not connecting to laptop via MK3-USB

I have a MuliPlus Compact 24/2000/50-30 230V.

I wish to have it charge up batteries, then when the power goes out (happens daily where I live), then it runs off the batteries. However testing it with a multimeter shows that it drains the batteries when the power is there, then charges them up, then switches back to running off the batteries. The net effect when the power does go off, the batteries may be full, or they may be almost empty.

I bought a MK-3 USB to connect to it to see what's going on.

Unfortunately I could not connect to it. I followed all the troubleshooting guides I could find.

Could anyone tell me if this MultiPlus supports VE connect? I read in the manual that I need to check the firmware number, but from what I can tell you need to be able to connect to it to get the firmware version, chick and egg scenario.

I tried both ethernet ports, it does not connect with either. Tried multiple cables. Looked into installing extra FTDI drivers. The MK3 seems to be picked up fine by the operating system fine. The inverter is on, and the UTP cable is a normal unshielded RJ45 plugged into the MK3, I started with a longer ethernet cable, but ended up trying with a 1m long cable. I have rebooted multiple times, scanned multiple times, tried difference sequences of running the search and then powering up the inverter. I spent two hours on this last night while the kids were sleeping and got nowhere.

First step I would guess is to figure out if my inverter supports MK3/VE Connect (or is the firmware too old?). You can see photos below of what I think would help one figure out if it does.



battery chargingmonitoring
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
nickdb avatar image
nickdb answered ·

You would need to use VE Configure, not Victron Connect.

VC has minimum firmware requirements which can be flashed via the MK3 using veflash, assuming the inverter supports the version.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

run-the-race avatar image
run-the-race answered ·

Thanks for the reply, you are right, I could connect to it via VE configure. So I need to update its firmware. I read I need a Victron progressional account to download the firmware so I signed up for that. Which file do I download? I imagine if I upload the wrong firmware I could break it, so I don't want to take a "good guess" and get it wrong.

Can anyone provide some guidance for chosing from: ?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦♦ commented ·
2618506 would be the latest for that system under the assistants (400) firmware.

Technically it should be renamed 500 firmware as we have move beyond v4.

1 Like 1 ·
run-the-race avatar image
run-the-race answered ·


I see on a microcontroller is printer 2618, do I get the 100 or 200 or 400 file?

VE configure says it is currently running software 2618401, but on the microcontroller the sticker says 2618154. Reading this: it seems like to me it should not be running 401 because its an old microcontroller, and instead I should put 159? Is that correct? Maybe thats why its been acting so weird.

1691128139721.png (17.5 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wkirby avatar image wkirby ♦♦ commented ·
2618154 as on the sticker is the version of firmware originally flashed in the factory when the unit was new.

Since then 2618401 has been flashed onto it. This known as "400 Assistant Firmware"
Your unit has the new (and latest) microcontroller, 26xxyyy.
As nickdb mentioned before, the latest firmware version that you can use for your unit is 2618506 which is found under "400 Assistant Firmware".

0 Likes 0 ·

Related Resources

VictronConnect VE.Bus charging manual  

Additional resources still need to be added for this topic