thatguy avatar image
thatguy asked

Pheonix Smart 12/3000 Showing False Current and Overloading

I noticed that the fan was running on the inverter so I went to have a look at it. On the app it was saying that it was pulling around 2300 watts. I checked my monitor and it was only showing 6A. I removed all the load from the inverter and the fan kept going and the reading stayed the same. I turned it off then back on and the reading went up to 2400 without any load. I connected the load back to the inverter and it instantly went into overload and shut down. It has been running perfectly set-up like this for about 9 months until now so I can't see it being a set up issue. Any help will appreciated.

Phoenix InverterHelp
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Alexandra avatar image
Alexandra answered ·


Sometomes rats or lizards or ants get into places.... It can still be a set up issue. Wiring can be compromised during install (knicks in insulation) and the issue only shows up later.

You test if it is wiring by removing (physically) from the terminals everything. Then test the unit again.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

thatguy avatar image thatguy commented ·
Thank you for your response. I removed everything from the inverter for about a day and a half to put on my backup inverter. I just reconnected it, and it has got a little better but still not right. It is showing 690w being drawn with no load attached. Would dust inside the inverter cause this sort of thing maybe?
0 Likes 0 ·
Alexandra avatar image Alexandra ♦ thatguy commented ·

Yes definitely clean it out.

Dust and worse humidity and dust.

0 Likes 0 ·
thatguy avatar image thatguy Alexandra ♦ commented ·
After connecting the inverter back up again last time, after a few hours the false draw crept upfront the initial 690 watts to 1800 wats so i disconnected it all again.

So after being disconnected for 2 more days, I replaced all the cables in and out to just be sure. I took the front cover off and it is clean inside with no dust or evidence of any pests, so I decided not to touch anything in there. I have now hooked it all back up again and the false draw is now reading 350 watts, which is better but still not right. I am going to leave it connected and see if it creeps up again.

Do you think it may be just a dud inverter and see if it is a warranty issue?

0 Likes 0 ·

Related Resources

Additional resources still need to be added for this topic

Phoenix Inverter product page

Phoenix Inverter Smart product page