junior avatar image
junior asked

Cannot connect to my Bluesolar MPPT 150/60 tr (bluetooth VE direct smart dongle + Mac OSX High Sierra)


Looks like I cannot pair by bluetooth with my MPPT Bluesolar charge controller 150/60 TR.

Configuration : Macbook Pro 15' mid-2012 with Mac OS 10.13.6 (High Sierra) + Bluetooth 6.0
VE-direct bluetooth smart dongle.
I'm in an isolate site (no internet).

Troubleshooting : I checked the troubleshooting section for the last 3 days. I read a lot of threads and questions concerning differents issues the community encountered. But I got no real solution. I unpaired and deleted the VE-direct device on my bluetooth system configuration window before every attempt to connect with VictronConnect, I also cleared the pin code. I ONLY connect bluetooth with VictronConnect which release is up-to-date. No other bluetooth device can cause the issue. I always attempt to connect bluetooth within 30 seconds after pluging the dongle to the MPPT. I also reseted the bluetooth parameters on my computer. Nothing changes.

Issue : The firmware passes correctly. The dongle leds blink like they should. The MPPT led bulk is blinking correctly.
But when I try to pair the VictronConnect app with the dongle, it asks me the usual pin code at 20%, then gets stuck to 80%, then goes back to 20%. And, after what it looks like 4 or 5 attempts, I have an error message (see the pics).
Can you tell me what I did wrong ?

Thank you !

Then :

And then :

("Impossible connection, delete the device from the paired devices list, and connect again...")

MPPT ControllersVictronConnectBluetoothVE.Direct Bluetooth Smart Dongle
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
junior avatar image
junior answered ·

Since my previous post, I continued the troubleshooting :
During the next bluetooth connections via VictronConnect, I had the 3 MPPT leds blinking quickly (blue, red, green) after it stucks at 80%. When I end the bluetooth connection process, the MPPT blue led (bulk) blinks back correctly.
The manual does not report this faulty situation (except when rotary switch is is at 0 - mine is at 2).
Internal error ?

I also tried this with my computer system :
... without success. (I never use bluetooth except for the dongle.)

Then I tried to connect with a friend’s tablet. It connects correctly from the first try. I managed to configure my MPPT with her tablet, but it cannot remain like that indefinitely.
It looks like there’s a compatibility problem with my Mac OSX High Sierra 10.13.6 during authentication (PIN code). My bluetooth LMP version is 4.0 (0x6). Everything seems all right regarding the Victron products compatibility section.
Any helping hand ? ;)

I wish you all the best !

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

junior avatar image
junior answered ·

Hum… please ?!?!?
It’s been 18 days and too many hours lost… Could you (please) send a sign of life ?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

MPPT Product Page

MPPT Error codes

MPPT 150/60 up to 250/70 Manual

Additional resources still need to be added for this topic

VictronConnect Manual

Download for iOS / Android / Mac / Windows