patrickc avatar image
patrickc asked

Short circuit on VE.CAN bus?

i'm attempting to setup venus os on a raspberry pi and to connect it with a waveshare can hat to my RS smart solar.

A loopback from CAN0 to CAN1 on the raspberry worked excellent, communication worked and no errors are logged. Connecting to the inverter didn't work though.

I realized I didn't have a termination resistor on the inverter end (the raspberry board has one included on the board so thats why the loopback worked out of the box), so I made a canbus terminator .. and it burned up once I put it in the inverter. Literally sparked and melted away. I checked the power requirements out a bit and it should have been able to handle it, so I figured I messed up the terminator. I made a new one, that seemed to remain intact, but communication still didn't work.

Finally, I figured if the terminator is really no good I can use the raspberry at both sides, so raspberry can0 -> inverter -> raspberry can1. That would have 120 ohm termination resistors at both ends, and the loopback already was proven to work; this is just an extra node in between .. and as soon as I plugged it the second rj45 plug on the inverter end (same port that burned of the terminator before) it burned the raspberry CAN board.

I'm really confused, from what I read the CAN bus itself should be current limited and unable to damage itself even if you connect L to H, or even H to VCC. So even if I messed up the wiring (which I measured out before, 120 ohm termination confirmed on all parts), I wouldn't expect such catastrophic failure.

I'm ready to throw in the towel and get a cerbo gx with victron cables and what not just to get rid of the headache here, but I'm afraid the exact same thing will happen, if the inverter is actually the culprit and somehow the VE.CAN port is defective somehow.

Does anyone have an idea what went wrong and how I could check the correct functionality of the inverter VE.CAN port(s)?

VE.Caninverter rs
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Alexandra avatar image
Alexandra answered ·


What port were you using for CAN on the Pi?

Also what inverter do you have that has a can connection?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

patrickc avatar image patrickc commented ·
The first (front) ve.can port on the inverter ( multi rs solar) to the raspberry can0 and the second (rear) ve.can port on the inverter to raspberry can1.

ground on pin 3, can high from pin 7 and can low from pin 8 on the rj45 connector from the rs solar to the same terminals on the raspberry

at the point I connected both rj45 connectors I just heard the raspberry can board crackle and pop, I pulled the rear rj45 out of the rs solar and now the raspberry smells fried .. just like what happened to the 120 ohm terminator

granted, the rs solar documentation doesn’t have the can pin numbering listed as far as I can see, but I assume what is tue for the other inverters and gx devices is valid for this device too

I’m really wondering if that second ve.can port on the rs solar is defective somehow, and wonder how I could measure that. At this point I’m afraid to connect anything else to it.

0 Likes 0 ·

Related Resources

Additional resources still need to be added for this topic