question

allure1932 avatar image
allure1932 asked

CCGX Wi-Fi unreliable since 2.84?

Hi,

I have a CCGX with USB wifi dongle (BPP900100200).

It has been working pretty well, allowing me to view my system on vrm.

When i updated the firmware to 2.87 I noted that wifi only works/connects for a short while after reboot, then says that there are no access points. Works briefly after each reboot.

I reverted to 2.84 but it is showing the same problem. I did not use 2.84 after I installed it since the system was switched off for a period of time, so I did not notice the problem.

Anyone seen this problem?

The wifi dongle may be broken/flakey. The new firmware may have an issue.

I would like to read out some system log and see if there is some error report from the device driver.

Any help appriciated!

Per

CCGX Color Controlwifi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
JohnC avatar image
JohnC answered ·

Hi @Allure1932

I have the same kit and haven't seen any issue with 2.87. There are no logs I'm aware of, but the CCGX can show your signal strength. Mine's 75% (at ~7m and a wall), and I don't have wifi channel conflicts. Networking issues are far more likely than Victron hardware/firmware problems.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

allure1932 avatar image
allure1932 answered ·

Good to know. Thanks.

When I lose wifi, I can’t see the signal strength, and no AP will be found even if I am standing with my phone hotspot right next to it.


So if the USB dongle is misbehaving then it is doing so without the firmware understanding it.


I may need to get another dongle and try.

Thanks,

Per

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

no AP will be found even if I am standing with my phone hotspot right next to it

For testing or that's the only AP available?

0 Likes 0 ·
allure1932 avatar image
allure1932 answered ·

Greetings!

I updated to the Netgear AC1200 option and now things work again. The previous wifi dongle must have become unreliable at the same time as the upgrade.

Take care,

Per

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.