question

sarah-smith avatar image
sarah-smith asked

Unable to connect IP22 12/30 Charger by Bluetooth

Hi all, I am running into a problem while trying to connect via bluetooth to my smart ip22 12/30charger. I have gone through the app promps as well as the trouble shooting guide with no success. I'm not sure what to do at this point.

So, this is what's going on..

After I click on device in the app list, it loads to 60 and drops down to 1, then 40, then 1, then 40, then 1 and then a screen prompt appears " unable to connect". Its not the same sequence of numbers every time, but always to either 40% or 60%.

One day I unplugged it (as I have done before) and when I plugged it in later that evening this connection problem started.

There were no changes to the device, my phone, the app, or anything that I can think that could contribute to the issue.

However, I also have a victron smart orion dc to dc changer and it connects without any issues whatsoever.

Here's some info and what I've tried:

The product is in range and reads 4 bars.
I have reset/restared my phone 3 times.
I have updated my phone (android version 9).
I have updated the victron app (ver 5.59).
There are no other phones connected to this device (I am the only person who has ever connected to it.)
I am trying to connect via bluetooth through the victron app, not through my phone.
As recommended in the guide I unpaired the charger with my phone via my phone bluetooth menu.
Both bluetooth and location is turned on. I have also turned them off and turned them back on.
I checked victron app permissions, it has permission to use location.
I tried to reset my pin on the victron app and get and error code that says "An error occured during pin reset. Remove the pairing information before trying again." As mentioned above, I have already done this.
I have unplugged and plugged the unit back in a few times already as well.
I uninstalled and reinstalled the victron app. It prompted me to allow location. I agreed (it is turned on on my phone). The again a window popped up that said it needed bluetooth to function, I clicked okay. My orion dc to dc charger connected without issue. Then I plugged in the IP charger and waited, it appeared on the list of my devices. I clicked on it, it loaded to 40 & went back to 0, loaded to 60 went back to 0, again to 40, back to 0 and same screen "unable to connect."
Out of curiosity I have tried to connect to the device from my phone menu and receive a pop up from my phone that says " couldn't pair, make sure device is ready to pair."
Lastly, I installed the victron app on someone elses phone and had the same result. Unable to connect to IP charger, but connect to orion just fine...

Also, I've only had the device a couple months and bought it brand new.

I'm stumped. Hoping someone can help. Thank you.


Edit: I was asked to upload a service log. For some reason it will not let me upload it. I saved it from the app the google drive, (I dont see an option to save it to my phone) then i download it to my phone and try to upload it here, it gets to 100 then says error, try again later... there is no option for me to share with victron or victron community as listed in the guide to creating a service report.. Here's a google drive link, although I dont see how anyone could read it lol.

https://drive.google.com/file/d/132rlrkgDfUdn3UhksPQw0W5kKn6aF4-G/view?usp=drivesdk



chargerVictronConnectbluesmart ip22connection issue
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

(...) although I dont see how anyone could read it lol.

The developers can do ;-)

Edit: It seems like uploading files is broken, I've reported it.

0 Likes 0 ·
sarah-smith avatar image sarah-smith Matthias Lange - DE ♦ ·
Thank you
0 Likes 0 ·
2 Answers
Paul B avatar image
Paul B answered ·

is the phones internet data turned on and is the internet working on the phone -as it maybe trying to do a fw update - what brand of phones have you tried.

otherwise all I can suggest is that you return it to the dealer you purchased it from for testing

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You don't need an internet connection for an update. All FW files needed are already included with VictronConnect.
0 Likes 0 ·
Data is on. I have a samsung a10e, but have been using the app fine with this phone since feb until the connectivity issue started, and I can connect to my orion dc to dc charger just fine..
0 Likes 0 ·
kevgermany avatar image
kevgermany answered ·

@Sarah Smith

Manual section 5.3.2 gives a couple of ways of resetting the pin. Did you try both?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I tried to rest the PUK code and got and error saying "unable to reset & try unpairing the device with your phone." But, I've already done that. I also tried holding the mode button down for 10 seconds and all the lights starting blinking like crazy then went back to all four mode lights blinking together slowly and nothing changed. I wrote the company I bought it from, they got back to me saying it sounds like the bluetooth module went bad. Just after 2 months isn't comforting, but i just have to send it back and they will replace it... Unfortunately I use the charger to run my diesel heater in my camper, it's going to be a cold week or two before the new one arrives!
0 Likes 0 ·