question

Sarah avatar image

VE.Can - who’s the Boss when the Multiplus II is off.

914deb86-4310-4dc9-845c-ef9863f08764.pngdear brains trust,

I have two MPPT controllers connected to my VE.CAN bus along with a Cerbo GX and Lynx Shunt. My batteries are AGM and unmanaged. I also have a Multiplus II interfacing with the CerboGX. My understanding is that when the Multiplus is inverting/charging it takes control of the charge algorithm as indicated by ‘External Control’ display on the MPPT controllers. This continues even when the Multiplus II has been turned off for several days. I have tried to configure Bluetooth VE.Smart to no avail. So what I want to know is when the Multipluss II is out of town who is wearing the pants (and where do I change the maximum absorption time - as the devices do not revert to float mode - I have also changed the maximum absorption time settings in both MPPT controller with no impact. Devices are configured for Victron AGM batteries with a maximum 6 hour absorption and adaptive charging). I have an 1180 AGM 12 v bank and after a day of absorption battery charge is minimal yet no float. All software is up to date including Venus 8.89.36.
kind regards

Sarah

MPPT ControllersMultiplus-IIcerbo gxVE.Can
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
bathnm avatar image
bathnm answered ·

I am surprised to see the MPPTs in external control. You say you have AGM batteries and therefore there is nothing to be driving that external control. Take a look at the DVCC portion of the GX Manual (here). Section 8.3, has a great table that would imply the MPPTs are controlling teh charge algorithm.

You also mention that the Venus version is 8.89.36, that is not a standard Venus OS version number.

Maybe turn DVCC off on the CerboGX, as it is really not doing much for you.

Using DVCC and VE.Smart is not a valid configuration, it is one or the other.

7 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Bathnm, you are correct re Venus OS version we are running 2.80.36 (the latest beta release). Thanks for the link to the DVCC documentation - the scenario that I am describing seem to match the ESS Assistant config described in section 8.3. Which is great except I don’t have any ESS Assistants configured. I’ll try dialing back DVCC see what effect that has. Thanks for your input.
@Sarah it might also be worth reverting back to released code and understanding what is happening. You may have uncovered a bug/problem with the beta release. If everything works as expected with DVCC on, in the last released code (2.73 I think). Then I would report the problem in the beta thread here so Victron can investigate.
I think the EXT control designation for Ve.Can MPPT's is actually a bug, I have two and one is currently showing EXT. Control the other just says Bulk, I'm pretty sure the MPPT's are still in control.
This is one for Victron to look at @mvader (Victron Energy)

@bathnm - Thanks for this. I think further investigation of 'undocumented features' is definitely warranted. After your post I turned off 'Limit Charge Current' and 'SCS Shared Current Sense' and the MPPTs have returned to internal control as expected (DVCC is still enabled with 'SVS Shared Voltage Sense' and 'STS Shared Temperature Sense' enabled). I also have two Smart Shunts in the network which are configured as a DC Energy Meter / DC System and DC Energy Meter / Alternator which may also be coming into play. It is also interesting that when I look at the history for the MPPT controllers it appears that they never get out of bulk charge. But as you say back to a known config and step up from there. Will keep you posted.

You should be able to turn SCS on, that will allow the MPPTs to sense current into the battery and ensure that tail current measurement is OK for ending bulk charge is improved.


I suspect the problem was the Limit Charge Current. However even with that in the past I am sure it did not push MPPTs into external mode. I can not confirm, but suspect you may have hit some corner case trigger to put the MPPTs into external mode.

Glad you are at least back working.

Alternatively turn off DVCC altogether and enable VE.Smart.

@Bathnm I enabled SCS last night and all is looking good this morning so I think you are right the problem looks to be isolated to the Limit Charge Function.

I'll be on the boat today and will see how everything goes and then enable the Limit Charge Function tonight and see if that breaks it.

In the meantime the MPPTs have been playing nicely together and it looks like they are syncing over VE.Connect as they should without having to enable VE.Smart.


bathnm avatar image
bathnm answered ·

@Sarah glad it has all worked out

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.