question

zac imhoof avatar image
zac imhoof asked

Pwm light 20a no longer in taking solar

I have a 200w solar panel connected to my pwm light 12v 20a and it was working fine. The light was flashing indicating power coming from the solar panel and into the battery but now the solar input light is showing nothing even though I know there is 19v coming from the solar panel. At one point the battery did run flat and I thought maybe it turned itself off so I disconnected it and reconnected the cables and still nothing. When change the setting I get an 'ff' flash after the setting has been selected. Not sure what this means as it is not in my one page instruction sheet I got with the controller.

battery chargingchargerSolar Panelvictron products
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

So i changed the battery and tried again and still nothing. do you know what the ff means that flashes after a setting has been selected?

before there was a flashing green light when ther was sun on the panel. now nothing..

0 Likes 0 ·
3 Answers
JohnC avatar image
JohnC answered ·

Hi Zac. Just some ideas you could try:

If your batt is *really* flat, it may think it's in short-circuit and has shut down. Try a batt with at least some charge.

Disconnect the solar before connecting the batt so it can pick up '12V' itself. Then connect the solar. It may select '24V' otherwise.

Just a couple of things to try before despairing..


2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hey John. Thanks for your quick reply. I have a dc-dc charging the aux matter so it is full again but still no response.

0 Likes 0 ·

The green batt led means it knows it's fully charged. The sun led should start flashing when it gets some (looks dark there?). Just make sure it's set for 12V, not 24V.

0 Likes 0 ·
daxy avatar image
daxy answered ·

Hi mate - did you mange to get this fixed??

I'm having the same issues!

Cheers


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Same problem for me guys. Any fix to this problem?

No more green lift flashing and I’m pretty sure it does not charge the battery...

However, surprisingly when I disconnect the battery + cable the green light is flashing normally. As soon as I reconnect it the array green light stops flashing...

I have no clue friends. If someone has a fix i’m really interested !

Cheers

0 Likes 0 ·
rscottf1 avatar image
rscottf1 answered ·

Same problem. Bought coachmen apex ultralight rv with this controller in Oct 2021. My solar panel is 100W system. Observed flashing LED indicating charging. Periodically checked through the winter. Then, sometime in Jan-Feb, it stopped charging, and I was presented with a dead battery and no charging indicator flashing. Took it on a camping weekend first weekend in April with electric hookup, and battery recharged. When we disconnected and just before leaving, I checked the Blue solar pwm light, and still no blinking LED indicating solar charging, even though sun was out, but battery showed green LED, meaning fully charged,. Went back to check a week later, and still no charging indicated by flashing led, and battery down to 'red' level - meaning low, but will still operate 12v systems .

I realize I may have something drawing power that i haven't discovered yet, but why no charging?


Did anyone try the proposed solution above with success? If so, would I need to do this every year? There is no nice, easy way to disconnect the solar panel that I can see, other than unscrewing the wires connected at the blue solar pwm light.

Thanks.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.