question

anrich avatar image
anrich asked

MultiPlus-II sudden low battery alarm while battery is full (BSL stubby)

Update 25/11

The battery once again gave a low voltage alarm while about 80% SoC, causing the inverter to restart. There is clearly something wrong. My best guess (based on many informed opinions) is a serious BMS firmware bug or design flaw. It could also be severely unbalanced cells, or a faulty cell. BSL is apparently working on improving the firmware (they're aware something is wrong).

I'm working with the installer to have the battery exchanged for something that actually works reliably. I would not recommend buying a BSL stubby for the time being, at least not until they sort the BMS issues out.

---

Hi,

Hardware details:

Setup details:

  • Grid connected to AC-IN
    • Grid feed-in is disabled.
  • AC-OUT-1 is feeding essential loads (no more than 2000W, average about 300W-700W)
  • AC-OUT-2 is feeding geyser (on timer 10:00-15:00) and stove.
  • ESS mode: Optimised (with BatteryLife)
  • The system is less than a week old and has been running perfectly up until a few hours ago.

Issue description:

The inverter suddenly shut down and started up on its own after a minute or two. The battery was about 99% SOC when this happened.

The following alarms occurred:

screenshot-from-2021-11-17-18-56-29.png

On VRM I can also see there was a "High DC ripple" warning at the same time.

The system ran fine after that for a while after which the same thing occurred again, but this time it coincided with a grid failure (load shedding). The same alarms occurred:

screenshot-from-2021-11-17-19-42-57.png


During both occurrences, the load on the inverter was at most 500W (nothing was switched on additionally when it happened).

Does anyone have an idea what the cause could be? I'd appreciate any input.


VRM images (please let me know if other log data could be useful):vebus-warnings-and-alarms.png

screenshot-from-2021-11-17-19-50-18.pngscreenshot-from-2021-11-17-19-50-57.pngscreenshot-from-2021-11-17-19-51-38.png

I did also notice on the MPPT daily history, the minimum voltage for the battery today was 44.72V, which seems very wrong:

screenshot-from-2021-11-17-20-00-56.png

Usually it discharges to about 45% throughout the evening, and then the minimum voltage hasn't fallen below 51V before today:

screenshot-from-2021-11-17-20-03-25.png


Multiplus-IILithium Batteryvoltagelow battery warning
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
nickdb avatar image
nickdb answered ·

I have two of these batteries and they are having some teething problems.

Check the bms firmware. On the current release (1.07) they are reporting an incorrect SOC during charging so it could be that you hit that issue.

Check the install and have a chat to your supplier.

An easy way to identify this issue is to look at the bms soc chart on vrm. If it is making big jumps in charge, then that could be contributing.

If the reported SOC is wrong it will break all ESS protections and eventually trigger a low voltage condition.

It sounds like you hit the low voltage cutoff and the inverter restarted once it reached the minimum start criteria.

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nedee avatar image nedee commented ·
Any news on new firmware from BSL Battery to solve the SoC reporting bug in 1.07?
0 Likes 0 ·
nickdb avatar image nickdb ♦ nedee commented ·

No. Are you seeing it also?

I actually changed to a different BSL model and it has the same issue so we're having to dig into what the BMS is up to, which is taking time.


0 Likes 0 ·
nedee avatar image nedee nickdb ♦ commented ·
Yes, same issue. As soon as solar charging picks up steam in the morning it goes to 98-100% in an instant despite high power charging. Discharge SoC profile seems fine
0 Likes 0 ·
nickdb avatar image nickdb ♦ nedee commented ·
Exactly the same as mine, on rare occasions where it doesn't happen the SOC tracks up to 30% early to 100%. BSL first tried to blame the installation until others had the issues. We're now waiting for a reader to log BMS activity.

SOC is a read-only metric from the BMS so you can't blame anything other than the BMS.

0 Likes 0 ·
anrich avatar image
anrich answered ·

Thank you, it's very helpful to get feedback from someone with the same battery. I did not consider the BMS firmware.

The SOC chart looks quite normal (to me at least, I'm very new to this. It does look similar to the past few days though).

screenshot-from-2021-11-17-20-24-40.png


It does however seem like the battery firmware is on 1.0. It's obviously old if there's already a 1.07, but it is quite strange that this starting occurring so suddenly (but yeah I guess software can do strange things very suddenly).

screenshot-from-2021-11-17-20-25-37.png


27 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦ commented ·
There could be a sticker on the battery with firmware.

Unfortunately the gx only reports 2 digit firmware versions and we need 3.

That soc curve looks fine to me, so it could be something else - the issue only appears in later code.

Look for the the bsl configuration guide here - will get the link, you need to follow the setup criteria properly.

They are good batteries but this is a brand new model and it has a few quirks.

0 Likes 0 ·
anrich avatar image anrich nickdb ♦ commented ·

I can't seem to find a sticker with the firmware version, but the manufacturing date seems to be 2021/08/18. It's wall mounted and the sticker could be behind a part of the bracket. The installer is coming to inspect the system tomorrow, will provide feedback.

I found a QR code on it that links to the configuration guide. Will have a look in there, maybe I can spot something.

Here's the guide for anyone that might be having similar issues: https://drive.google.com/file/d/149FGH_WIZzeraO-xgy9EuU3p62gPE9Mi/view?usp=drivesdk

0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·
You will need someone qualified with the battery software to check what version you have and take it from there.

There have been a few revisions of bms code since these units shipped.

1 Like 1 ·
anrich avatar image anrich nickdb ♦ commented ·
Noted, thank you. I'm hoping this is something the installer van figure out tomorrow.
0 Likes 0 ·
anrich avatar image anrich anrich commented ·
NB: the linked guide seems to be for a 100Ah BSL battery, not the 160Ah I have. Rather use the link @nickdb posted below.
0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·
Correct but the settings are common apart from AH. Something I also have pointed out.
0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·

still an old doc. Your battery has 6 dip switches not 4.

0 Likes 0 ·
anrich avatar image anrich anrich commented ·
Update: I found the firmware version sticker and it is on 1.07.
0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·

Your voltages are extremely low when it cuts out, so that does not seem like the SOC is reporting right.

Here is the issue I have with 1.07 which has been escalated.

screenshot-2021-11-18-at-104950.png

You can see the SOC leaps up, and it does this under load when charging. The net result is that the SOC can be falsely reporting full charge but could be up to 40% lower.

You can tell the issue exists if you see this in your charts and there is sufficient PV as the battery will keep charging until it gets to the 54.5V setpoint.

If it isn't getting anywhere near the 3.4V per cell by end of charge then something is off.

Have you checked your full setup against the config docs sent?

Your chart has the battery at 53V which is way lower than it should be when charged, as mentioned above.

I would send screenshots of the veconfigure inverter setup (or post the config file here) as well as what is set on the mppt's.

Would also be worth checking the battery wiring for loose connections etc.

1 Like 1 ·
anrich avatar image anrich nickdb ♦ commented ·

The installer did an inspection, and the following was done:

  • Update firmware of Multiplus-II from v481 to v490
  • Ensure other devices are up to date (MPPT, Cerbo GX)
  • Went over all battery config and ensured it matches the manual.
    • Shared Current Sense (SCS) was enabled in DVCC, where the manual shows it shouldn't be so it was disabled. I'm doubtful this is related.

My battery SOC doesn't seem as sporadic as in your screenshot.

Below you can see the Battery Current and Voltage in comparison with SOC over the last two days:

screenshot-from-2021-11-18-12-32-21-crop.png


At 100% SOC voltage hovers around 54.5V, and at 53% SOC you can see it sits at about 52.49V. Note that there was a bit of current flowing.

Something else I noticed is that the Minimum and Maximum cell voltage does become quite disjoint when the it's being charged. Is this normal? Isn't the battery supposed to be doing some form of balancing?

screenshot-from-2021-11-18-12-38-07.png

VE Configure screenshots and MPPT settings will be sent after this.

0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·
That all sounds about right then. These batteries don’t seem to balance well or at least take a long time. Mine has a near 0.3V difference between min/max at the end of charging. It has narrowed a little over the last 3 weeks but nowhere near what my pylontechs did in a similar period.
0 Likes 0 ·
anrich avatar image anrich nickdb ♦ commented ·
Interesting. How many cycles to you estimate your batteries have been through? I wonder if there's something wrong with the cell balancing.
0 Likes 0 ·
klim8skeptic avatar image klim8skeptic ♦ anrich commented ·
Given that the battery is 16 series, and the recommended charge voltage is 55 - 56v, it is unlikely that your battery is near 100% Soc at charge voltage of 54.5v.
0 Likes 0 ·
anrich avatar image anrich klim8skeptic ♦ commented ·

If that's the case it seems likely that the battery isn't actually reaching 100% Soc. What would you expect the 100% Soc voltage to be? I can't find in indication of this in the data sheet.

0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·

Absorption charge is 55V, the ESS set point from the BMS is 54.5V.

It is a series combination of parallel cells in the stubby.

BSL's run lower than other manufacturers at 3.4V per cell, and the BMS reports the SOC so at 54.5V you are 100% charged.

Because the internals are a little different, balancing will be affected a bit but this is a brand new model battery and the BMS code clearly needs some work.

Here is my min/max. If you check your BMS details tab you will find (like mine) it is the very same 2 cells with the min/max delta at the end of charging. That should be changing, especially after weeks of actual use and drawing it down to 25-35% overnight.

screenshot-2021-11-18-at-130920.png


0 Likes 0 ·
anrich avatar image anrich anrich commented ·

One thing I just realised is that the Soc LEDs on the battery itself does correspond with the Soc % as on VRM - all lights are on when VRM reports 100% Soc. If that is wrong then the battery itself is reading it's own Soc wrong (probably the same data that is sent to the Cerbo).

0 Likes 0 ·
anrich avatar image anrich anrich commented ·

Here are my VE Configure settings.

screenshot-from-2021-11-18-12-52-51.pngscreenshot-from-2021-11-18-12-53-25.pngscreenshot-from-2021-11-18-12-54-09.pngscreenshot-from-2021-11-18-12-54-26.png

0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·
Comparing differences, only thing that leaps out is no grid code set. That won't affect the charging.


0 Likes 0 ·
anrich avatar image anrich nickdb ♦ commented ·
Thanks for comparing, I appreciate your time. It seems I have the same (or similar) Soc issue as you described (see my previous reply).
0 Likes 0 ·
anrich avatar image anrich nickdb ♦ commented ·

Hi,

My battery just started showing erratic Soc, so I think I might have the same issue that you are describing with firmware 1.07. This is the first time it's happened, and I'm thinking it might be related to the Multiplus-II firmware upgrade from 481 to 490.

You mentioned that the issue has been escalated. Has it been escalated to BSL? Has there been any feedback?

Thank you!

screenshot-from-2021-11-19-08-59-23.png

screenshot-from-2021-11-19-08-59-48.png


0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·

It's not the multi, I am still on 4.87 and the issue started with the battery update.

SOC is reported by the battery BMS, multi just reports what it is told.

Some of your Inverter settings need a minor tweak based on the latest doc.

BSL - User Manual - 51.2v 160Ah CANBUS.pdf

0 Likes 0 ·
anrich avatar image anrich nickdb ♦ commented ·
Thank you for the new document! I'll have a look and ask the installer to remotely adjust (I'd rather not do any config myself, don't want to void installer warranty).
0 Likes 0 ·
nickdb avatar image nickdb ♦ anrich commented ·
Just to add, who did you get your battery from?

Ask them to let the distributor know what you are seeing, I am working with mine and the manufacturer to try resolve the issue.

0 Likes 0 ·
anrich avatar image anrich nickdb ♦ commented ·
I bought the battery via an installer. The installer is aware of the issue and thread, I believe they will follow up the supplier and/or manufacturer to look into the issue.
0 Likes 0 ·
anrich avatar image anrich anrich commented ·

The installer has contacted the BSL supplier and they indicated that they are aware of the erratic SoC bug on 1.07, and that a fix is currently being worked on. They however didn't indicate that the low battery voltage alarm is related.

The installer opted to not make any changes to config for the time being - there are some questionable values in the latest BSL user manual.

They set the "Battery capacity" to 200Ah in the battery monitor config, but then to 160Ah (the actual capacity) in the ESS assistant. I don't know if this is a mistake, or whether it's some kind of workaround for the SoC bug.

battery-monitor-config.png

ess-config.png


The plan for now is monitor the system carefully and wait for new BMS firmware. So far no additional "Low battery voltage" alarms have occurred, and I have let the battery run to 30% SoC.

0 Likes 0 ·
ess-config.png (110.4 KiB)
nickdb avatar image nickdb ♦ anrich commented ·
I suspect that is a typo in the manual.

Changes are minor so no need to rush.

0 Likes 0 ·
nickdb avatar image
nickdb answered ·

Follow this guide and the embedded pdf document

https://www.victronenergy.com/live/battery_compatibility:bsl

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alexis Kalogerakis avatar image
Alexis Kalogerakis answered ·

Hello.

Seems that the battery is not fully charge because hit 100% and bms give order for 0amps.

What is the maximum voltage that this battery can go before over voltage alarm 56.5v?

You can find CVL inside parameters in gx device.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

pedaaa avatar image
pedaaa answered ·

@nickdb:

i now also got my System with BSLBatt B-LFP51.2V 100Ah running. My BSL´s run on Firmware v1.0.

I asked BSL what the latest Firmware is, and how i can install it.

The answer was:

Don´t not touch Firmware, if you haven´t permission from BSL.


Think this is kind of strange.

Ususally i always update all devices to latest Firmware, at initial startup/setup of applications...


Anyhow.

Do you know whats latest Firmware version would be?

And how to install it, if needed?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦ commented ·

Hey @Pedaaa, They should arrive with current firmware (usually a little sticker stuck on the front with the version). The GX only reports the first two digits which is pointless since the most relevant part is the third digit. I returned mine for another brand but at the time is was 1.07, it has probably moved by now.

I understand some batteries got worked on, sounds like BMS replacement or changes to address issues, but it didn't seem to resolve SOC wander.

Only authorised people may update the batteries, the importer required you to attend a battery course in order to be enabled, so you will need to have a chat to them, check if you qualify to attend.

(not that it is a complicated process)

Most battery suppliers don't want them updated unless there is a specific issue to resolve.

-1 Like -1 ·