question

velociraptor avatar image

Multiplus II missing UPS feature?!

I've purchased a MultiPlus II GX because I've read about the UPS feature everywhere and it sounded like the ideal part for my application.

I've the standard setup with AC coupled PV and critical loads on the AC OUT 1 side, no dedicated meter on the input, Pylontech battery. The critical loads right now only draw about 4W in case that matters.


mp-setup.png

Out of the box, I can activate "UPS Feature" in the VEConfigure. Once mains is lost, critical loads are supplied from battery and even solar charging works. So far so good.

Problem 1: As soon as I enter a grid code (e.g. for Germany), the UPS feature disappears as a checkbox.

Question: Does that mean that the UPS feature only works when operating in non-compliant mode? If so, why is nobody talking about this anywhere? Why does the documentation seem to be completely silent about this? I understand that grid code is only needed for feeding back but the ESS assistant requires to set a grid code.


Problem 2: As soon as I activate the ESS assistant (with grid code set to "other non-compliant" and "UPS feature" checked), it simply does not perform any UPS function. It seems ESS deactivates UPS.

This seems to contradict what I've read in many postings but simply, things do not seem to work as described. What's going on? See last answer!


How can I set up a MultiPlus II with ESS and UPS feature for critical loads?

It feels like I've followed all the steps but it simply does not work.


Problem 3: How do I activate ESS mode 2 or 3?

Problem 4: I can read lots of values via Modbus TCP. When I try to write register 22 (active input current limit), the write is acknowledged with SUCCESS but the value simply discarded and it jumps back to the 25A set via the VEConfigure. Why?

Problem 5: Via VEConfigure, I can enable/disable the charger. How can this be done via Modbus/TCP or any other network?

Multiplus-IIgridups
mp-setup.png (13.0 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
velociraptor avatar image
velociraptor answered ·

So, I've completely wiped the MultiPlus to factory settings, configured everything all over again (in the same way as I think) and for whatever reason, it now works as advertised.

Grid code set to Germany, ESS assistant installed and UPS function is implicitly enabled.

I have no clue why it did not want to start inverting in the first attempt.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

shaneyake avatar image
shaneyake answered ·

1: I haven't used the german grid code but the check box only speeds up the transition from grid to inverter. Even without it most appliances won't notice the drop. I would think that germany has a tight tolerance for LOMs timing and you are actually not allowed to turn off the UPS function which is why it disappears but hopefully someone else can confirm this?

2: Basically as above, ESS requires LOMs, LOMs has tight timings meaning UPS can not be turned off. I use ESS, works perfectly. No light flicker anything during disconnect.

3. If ESS is running it is in Mode 1/Mode 2 already. Mode 1 and 2 are the same thing you just change setpoint externally in Mode 2. Modbus Register 2700 is the setpoint.
Mode 3, you need to set ESS to manual mode on the gx in the ESS menu. And then control the inverter directly via Modbus Register 37

4: Why are you trying to change register 22? This should always be set to the incoming supply limit when using ESS, other people have tried changing this and then strange stuff happens. This is not meant to be used when ESS is active. EG. Value should be the incoming supply breaker rating.

5. Can be done via modbus in ESS mode 3 only. Modbus Register 38

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

velociraptor avatar image
velociraptor answered ·

Thank you for your answer.

2. How can that possibly be? With ESS enabled, as soon as I switch off mains, everything goes dark. How can I make it start inverting? It says "off" or "sustain" on the small display and when I cut mains, the transfer relais opens and the inverter does NOTHING. Just says "battery 99%". In config, AES is disabled. Do you need a minimum load for the inverter to activate? (It works, however, with ESS disabled).

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

What version of multi firmware are you running?

No,it should just invert. Even with no load.
Can you post a screenshot of VRM advanced tab, showing the inverter mode and VE.Bus state when the inverter shuts down?

Thank you see last answer.