question

Paul B avatar image
Paul B asked

How to Remotely update/configure Multiplus and Quattro's via VRM remotely - UPDATED

This post has been Updated with Latest Changes. 30th May 2021

NOTE to other users, who feel they can improve on this post please feel FREE to edit it and add changes that can help others.

This post has been wikified, any user with enough reputation can edit it. -----------------------------------------------------------------------

Hi just some info for everyone in-case you did not know about these options/features,

If you enable two way comm's on the Venus or the CCGX or Cerbo GX units. (Fw2.60 or higher.) The GX device must be connected to the Internet and you do need a VRM site login, ( the GX device must also be registered on the VRM)

you can then remotely configure all the Multiplus/Quattro settings and now also firmware upgrade the units via the VRM as well

Of note I have also been able to reconfigure remote systems and add and remove inverters from the setups, thus saving trips to site.

Basic procedures,

Log onto the Victron VRM system and select your site, then from the Device list (Fig 1) the select Remote VE configure (Fig-1) then select download, (this will download the remote systems configuration files, MAKE SURE YOU SAVE the file do not open then edit the file.) the file usually ends up in your downloads folder, then using Victron's Ve Configure program you can then change all the settings including assistants etc. when finished then save the file. Then back to the VRM and select UPLOAD, select the changed file and this will then be uploaded to the remote system.

Multi Phase and Paralleled systems, can be updated and inverters added or removed to and from the system setup, AS WELL

OR

if you wish the upgrade the firmware of the devices inc the Multiplus and Quattro units. then select Firmware update. (Fig-3)


Nice Feature, please use the below link for further details

https://www.victronenergy.com/live/vrm_portal:remote-veconfigure

(Fig-1)

1622343887789.png

(FIG-2)

1622344058861.png

FIG-3
1622344672166.png

MultiPlus Quattro Inverter ChargerVRMVenus GX - VGX
1622343887789.png (40.7 KiB)
1622344058861.png (17.6 KiB)
1622344672166.png (34.7 KiB)
1551587577219.png (30.2 KiB)
6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Useful feature and very handy.

A lot of times I'll download the configuration, remotely, do what I need in veconfig, save the settings as a .vsc (vs .rvsc) to have for local upload later if needed.

One thing to keep in mind, if the configured unit needs a reboot, and if in doing so, the CCGX loses power during the config update (an assistant update in particular) then the configuration install will fail and the unit will halt.

Probably not an issue most run into, as they're likely powering the GX units independently of the inverter, but FYI.

0 Likes 0 ·

this saved my life, there is hardy any mention on the internet using this method, handy when you dont have the usb cable.

0 Likes 0 ·

Seems to work for single phase installations, but i´d like to change a few details on a threephase system remotely and all i can do with the downloaded file is opening it in the VE Bus System Configurator where i basically can´t change a thing...

Is there any workaround for threephase systems..?
Thanks!

0 Likes 0 ·
In the VE.Bus system configurator you need to right click on one of the MultiPlus/Quattro and click on VE.config.

It will then open VE.config to change the settings of that unit. Just like you would do it if you are connected to the system directly via a MK3 Interface.

0 Likes 0 ·
offroadflow avatar image offroadflow Matthias Lange - DE ♦ ·
First make it changable, then i can configure.

Got it, thanks!


0 Likes 0 ·
alan avatar image alan Matthias Lange - DE ♦ ·

How do you remove an inverter from the system in VE.Bus system configurator?

I have made the config changeable, dragged a failed inverter to unconfigured, then the system won't save as its an invalid config.

0 Likes 0 ·
4 Answers
Michael Riley avatar image
Michael Riley answered ·

Great feature. Our new system was wired up in the workshop with a CCGX via Ethernet (available from Supplier) as being in the workshop was an 'easy' way to get downloads and to use VE Configure (Windows machine required) for initial Multi setup (add assistants).

The CCGX allowed a quick way to see the settings and configurations etc and to have a 'live' hardware component for system testing/wiring interface etc. Once the configuration was all working and the battery(s) individually charged we disconnected the CCGX and introduced the VenusGX (my component) by using the VRM feature to firstly set up the VenusGX, at that point of course my 'VRM installation' was still based on the CCGX, and then to 'migrate' from the CCGX to the VenusGX together with the small amount of data already collected. Renamed the 'installation' and deleted the old one (CCGX); all working as advertised. The VRM loop was not on a very fast Ethernet connection and from Australia-Holland-Australia but other than a little delay on some inputs it worked extremely well.

Well done Victron.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Nice find @Paul B, I’m writing something here just to get this one off the unanswered questions list; which btw you’ve been working hard on I’ve heard, :thumbs up:

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

WOW the list is now down to 5 items, I am impressed.


Good work there

Yes when I get some spare time a try to pop a few off the list. I see Guy removed one of my INCORRECT advise posts, please Thank him for doing that for me.

and please feel free to do that in the future as well correct were needed and replace if needed, but please advise when you do this so we learn from our errors.

I am not always correct or fully correct there can always be missing knowledge here and there. hopefully we learn. :):):):)

0 Likes 0 ·

haha yes; thanks for being clear on that. Its a great place to learn this forum; also for me.

0 Likes 0 ·
Michael Riley avatar image
Michael Riley answered ·

See also this link below where I printed out the 'txt' file from the remote MultiPlus for your records. Used iPhone hotspot to connect VenusGX to internet; same hotspot to log my MacBook Pro into VRM and then downloaded the file to local followed by CrossOver to run VE.Configure3 on Mac and print pdf for records.

https://community.victronenergy.com/questions/11202/venusgx-and-vrm-on-a-sailing-boat.html?childToView=11425#answer-11425

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jonasenglund avatar image
jonasenglund answered ·

Hi there,

I have previously used this feature, but when I was trying to change a setting I can't upload the file again. Latest version of the VE Configure, I have also tried to save the file as a .rvsc instead and a manual upload, but then I get the error that the file can't be found.

Anyone have any ideas on where to start troubleshooting? The system is installed remotely about 700km away from here, so to check it locally is a bit tricky for the moment...

System info:
Quattro 48/8000/110-2x100 rev2 Firmware 413
CCGX Firmware v2.23, two way communication enabled, and enabled on VRM portal.

Best regards,

Jonas

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Jonas. The last time I 'needed' to use this was way back in Mar '18. But I've fooled with it since. Something's changed down the track, the files are still .rvsc, but they're named differently and get stored in a different place. And maybe they work differently.

So if you're trying with an old file it mightn't work. Try downloading a fresh one, it might go to 'Downloads' as mine now do, but just type .rvsc into file search and you'll find it.

I tried it just now, and the procedure seems a lot 'tidier' than I remember. Still works though..

0 Likes 0 ·

Hi, thanks for your reply!

I have solved my problem, it was some struggle with the Firefox web browser, previously I had used Chrome, and when I tried it now it works like a charm :)

Best Regards,
Jonas

0 Likes 0 ·