question

michael-delage avatar image

GX Touch 50 stopped working (blank) after Tank 140 is connected

I have a Cerbo GX, GX Touch 50 and Tank 140 with 4-20 mA sensors connected to ports 3 and 4 on the Tank 140. My understanding is this should work using the USB connection to the Tank 140 as the power source.

I set it all up in May and the system worked for a few days, displaying tank information correctly and the GX Touch 50 provided the expected interface. Then the GX Touch 50 stopped working (blank screen, doesn't seem powered).

I returned the Cerbo on RMA and just received a new one. I commissioned it plugging in one device at a time (starting with the GX Touch 50, which worked when initially connected). After connecting the BMV-712 and Multiplus Compact (all okay), I then plugged in the Tank 140 and the Touch 50 screen immediately shut off and won't work now, despite reboots and regardless of whether the Tank 140 is connected or not.

From the web interface, the Cerbo otherwise seems to be working fine, and when the Tank 140 is connected I can see the tank data as expected. But the Touch 50 won't come back. Any ideas?

tank monitortouch gx 50
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

0 Answers