question

midsummerenergy avatar image

CCGX not showing USB-VE.Direct Devices anymore.

A customer has a CCGX system with 7 x MPPT BlueSolar and a BMV-700. MPPTs are connected through a 10-way externally powered USB hub. BMV is straight to the VE.Direct port. This has worked without any issues for the past year, showing all devices correctly. Recently the customer installed a set of 10 x Victron 300Ah LIFePO4 batteries with 2 x VE.Bus BMS (suggested by Victron) and 2 x Quattro in parallel.

Since the battery swap, the VE.Direct MPPT controllers have not appeared on the CCGX. My first thought was the USB hub - checked and this is still powered. Bypassing the hub (USB-VE.Direct straight to the CCGX) also does not show up the VE.Direct devices either. The BMV does show up correctly. This suggests a software issue to me.

Have tried updating all the MPPTs to the latest firmware using the bluetooth dongle and set them to the correct charge profile for lithium. Tried rolling CCGX firmware back to 2.16 (now 2.23) to no avail.

I'm aware the Octo GX is a more suitable product for multiple VE.Direct devices, however this was not available at the time and does not include the display that the customer wants. The CCGX has worked without issue with 8 VE.Direct devices for a year so shouldn't be a case of it no longer working and need replacing with an Octo.

Chargers are still charging but no communication. Any suggestions would be welcome.

MPPT - Solar Charge ControllerCCGX Color ControlVE.Direct
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi @midsummerenergy, to add to Mihai, first thing to check if there are no components broken:

Connect just one of the mppts to the ccgx, and don’t use the usb hub. Then if that works add the usb hub.

Make sure the vedirect cable & mppt are mot broken by connecting it to a laptop.


Note that 10 mppts is well over the official limit for the ccgx. The issue you might get by installing that many is a 100% cpu load: sluggish and eventually not performing system. So, in case above test shows that no hardware is broken, try connecting 5 rather than 10.

Adding (?) the Quattros could be what tipped it over the limit.


2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks Guys, I will try the CLI and get back to you.

There are 7 VE.Direct devices through a USB hub. One VE.Direct device through the VE.Direct port. Tried several MPPTs directly to both of the CCGX USB ports (bypassing the hub) with different USB-VE.Direct cables. BMV on the VE.Direct port still shows up no problem.

Considering the timing, good chance the addition of the Quattros has tipped the balance. If we temporarily remove the Quattros, would this allow the system to show the MPPTs again? Do the Quattros need to be manually 'forgotten' from the CCGX?

Hi, power cycling the ccgx after remkving the Quattros will make it forget them.


Success!

MihaiR avatar image
MihaiR answered ·

Hi @midsummerenergy


Are you able to connect to any MPPT charger with the actual USB dongle using a laptop and VE Connect app?

Using root password, please logon to CCGX CLI and issue the following command:

lsusb -v

then post the output here.

Also, please issue the same command when the usv to ve dongle is directly connected to Venus device and post the result here.


Thanks,

Mihai

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.