5teve avatar image
5teve asked

Home Made VE Direct to USB cable - Story

I posted this on the Victron Facebook group but as Facebook is such a useless tool for searching and finding info.. i'm posting it on here too.. This should make mvader smile..

OK I'm going to tell you a small story about discovery.. Feel free to smirk, giggle, have a huge belly laugh or roll around on the floor laughing your head off.. its ok.. I kinda deserve it.
I'm new to victron and inherently a cheapskate (doesnt go hand in hand with Victron and boats).. I use the excuse that I like to learn to do things.. but its just a cover up.. 1620863479284.png
So a recent installation went ahead in my boat. Multiplus 12/3000/120-16 a BMV700 a rasberry pi3b+ running venus OS 2.7.5 and a 2p4s Calb celled battery -326ah and 250a Daly Smart BMS - I also have 2x Enerdrive DC2DC 50a chargers with MPPT (solar not used yet). I have a victron VEbus MK3 and a home made USB ve direct cable using a well known Prolific chipset uart adapter...
All went well.. and so came the day of switching on.. all worked and operated ok.. great. Tied everything in to the Rpi.. and got readings.. awesome. Charging worked at a phenomenal 120a - even better..

So a day or so later i'm trying to work out why the SOC is declining by the hour.. there is a constant 2.5a ish discharge when 'floating' at 13.5v.. something had to be wrong.. the Multiplus, BMS, 2x DC2DC chargers and multimeter all agreed at the same voltage, the BMV700 was showing 0.15v down on this.. but it was insisted that all other devices were wrong and the BMV was correct.. so on I went troubleshooting.. convinced still the BMV was wrong..
Thanks to Nathan Galvin and Jeff Wiley as well as SY Destiny for the info, troubleshooting etc that they gave over the next few days.. however NOTHING could explain why the multiplus was not covering the DC loads in float.. and why the SOC was declining.. (obviously it was counting amps out)

After making more settings changes, I thought I had it solved.. but alas.. the discharge came back.. it just took longer to manifest itself.. so there I sat today, on the boat, resigned to pulling out the BMV and returning it for testing.. talking to the reseller who was asking me questions, also at a loss. We did a full power down of the system with just the BMV running to confirm that the current was zero.. which it was... however accidentally i flicked to the voltage display and noted it had gone up.. and it now was exactly the same as the multimeter and BMS (the only 2 things left that had power) instead of the 0.15v difference.. when powered back up it the difference re-appeared.. it wasnt the fuse.. i checked that.. some more testing and more loads, the voltage dipped further and the BMV was showing 10a load.. my clamp meter was only showing around 5a.. not that i trust the clamp side of it (cheaper dc clamp type) but shouldnt have been that far out.. charger was off at this point

So that was it.. BMV had to be faulty.. so I told the reseller i'd bring it in and they could test it.. no problem.. so started by pulling the ve direct cable out.. and noted the voltage went up.. hmm.. wierd. plugged it back in.. and down it went by 0.15v.. took it out again.. back up again.. it now matched the Multimeter and the BMS.. i checked the current.. that was lower too and now matched the BMS (-4.9a) and almost the clamp meter (-5.1a) I had a spare Uart cable so quickly crimped a connector on (bloody fiddly) and plugged it in.. same issue apart from one of the crimps was a bit dodgy and when wiggling the cable the voltage would go up and down (as did the current) but it still send info to the venus device.. I pulled the ground cable out.. and it kept sending info.. but at the right voltage.. I pulled the +ve cable out of the connector too just leaving the TX & RX cables.. in place and it read correctly.. was programmable and transmitted to the venus.. great.. (see note below)

So 3 days wasted chasing my tail and even though my gut feel of the BMV being wrong was right.. it was the self-made cable that was causing the pull down and I have NO idea why.. apart from its something to do with the USB power.. There is a reason the victron dont like home made cables.. and maybe this is why.. haha.. Its not the cost of the genuine cables (honest) its the challenge.. hahahaha..

My graphs in VRM are as smooth as anything and loads are being covered by the charger as they should!

So lesson learned.. and hopefully if someone else gets caught with this.. it will help them..
Feel free to poke fun now.. i'm thick skinned..

Once again a note of appreciation to those that helped me on my journey of discovery!

As a side note - if you really have to make your own cable for the PI.. then leave the +ve out of the connector... as I can now easily find reference too via a google search.. but couldn't find when I was looking for how to make them!


BMV Battery MonitorVenus OSVictronConnectRaspberry Pi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
Kevin Windrem avatar image
Kevin Windrem answered ·

I'm pretty sure the Victron VE.Direct USB adapter has an isolated VE.Direct port. The one you made probably isn't isolated. So ... you created a ground loop upsetting the BMV's idea of ground.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5teve avatar image
5teve answered ·

Hi Kevin - I think you are right.. as Further testing shows that even touching the USB plug onto the USB port sheild drops the voltage when the ground wire is connected at the BMV end... It works fine with just the RX and TX connected.. and reads correctly, but i'm concerned that i'm missing something by only having the 2 wires connected.. i'll probably stump up for the official cable in this instance as its such a critical part of the system.. but would be interested in peoples thoughts on just the 2 wire issues.. From what I can gather this issue only affects the BMV... not any other VE direct devices..


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hahahahahaha, indeed it made me laugh! And feel sorry a bit for the time spent (wasted? ;o) by others and yourselves.

Note that by leaving the V+ out of the connector, you're cable still isn't isolated. Which might work ok, or might not work ok; depending on a whole load of things; which is why the standard is to isolate such connections.

Have a good Sunday! Thanks for sharing, and enjoy your system!

Ps. for anyone else looking to self make cables, see here my full opinion on it. The conclusion is, please please don't; and if you do, never ask for help if things don't work.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Stuart avatar image
Stuart answered ·


You noted this is not an issue with other ve. direct devices.....

The BMV uses a different data line voltage to other ve. direct parts like the MPPT solar charge controller's for example. This may have been part of your problem.

However as noted by many other contributors your most likely issue was related to a ground loop. When using TTL and UART devices ground loops can be a real pain in the backside. A good example of this is factory automation and PLC controlers. All PLC controlers have isolated inputs via optocouplers to avoid these issues.

Standards such as RS232 and RS485 almost allways specify iether a common single end ground point and/or isolated inputs. When controling machines in different buildings for example you can even have dangerous voltages on data lines and shielded cable terminations.

It really is a minefield. Aside from the increase in speed ground loop problems were the reason that optical transmission was adopted as there is no electrical connection or interference issues with fibre optic cables. Issues like the above are great learning experiences. I learnt the hard way to at university when I recieved a rather nasty belt from a coaxial cable coming from another building.

I personally think its time victron adopted a standard communication protocol via optical link instead of a mixture of RS485, RS232 and CAN as they do now. The cost of the transceivers will be more than covered by the savings in manufacturing, design and programming.

Yes Victron parts are expensive and sometimes overpriced but that's the price you pay for some of the most reliable and best quality equipment in this field. One of my university lecturers used to say "buy cheap many times or premium once". That's an ethos that has allways stuck with me. A good job to as I spent a great deal of my career in the Navy as a submariner. A place where the cost is virtually irrelevant, its the ruggedness and reliability that matters.

Thanks for listening to my extended rambling everyone :D

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.