question

lnanne avatar image

Why was MPPT absorption time only 45 minutes?

Our settings: 100/50 smartsolar with 4 hr and 30 minute max absorb time and lead acid batteries.

With the above absorption time and each morning with the app showing minimum (starting?) battery volts of 11.9, the actual absorb time has been 3 hours which is what the manufacturer has suggested and the reason we set it at 4.5 (2/3 of 4.5=3).

Until today. Absorption only went for 45 minutes (1/6 of 4.5). However, we did drive for about an hour and at some point (after charging the engine battery) the alternator started to charge the coach battery as well.

The common problem we've had is when we have another charging system (like our converter) along with the solar controller, the solar controller only absorbs for 1/6 of the time. Is it resetting when this happens so it senses the battery is charged (because the volts are temporarily high from another charging source)? Why else would this stop at 1/6? Our battery monitor showed 18 amps still coming in right before this happened.

MPPT - Solar Charge Controllerabsorption
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

9 Answers
Leslieanne avatar image

Hi there,

Here is a way out there suggestion. I note (but may have misinterpreted) in your original post that the controller was behaving itself for some unspecified time ( days, weeks?) then on this particular day it did the short absorb. You are using 12V panels. When I used these with my victron mppt, sometimes when driving in hot weather under an overpass the controller would turn off....volts momentarily dropped below bat volts + 1. The controller would then restart and go back to bulk then quickly to absorb, and the absorb period would be short....sometimes seemed even shorter than the 1/6 rule. Have since gone to 45V OCV panels and the problem no longer occurs. So........if you drove under some heavy shade between 7.30 and 9.00 you could have "reset" your wake up voltage to something over 12.6....and theres your answer. Something to ponder anyway! Cheers, Leslie

5 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The controller does not start a "new day" when this happens, so if you are not watching at that instant you won't see it. Used to happen under the awnings of some service stations also. I run lithium bats, so this jumping back to bulk then absorb, even if short was annoying. Opposite problem from yours. Mine were in a low "float"... effectively not charging, and I did not want them to go back to another charge cycle.

Holy wow I think you may be really on to something here! :)

I would not have imagined going under an overpass would shut off the controller and we could not remember having done that but Google Earth showed that we indeed went under probably at least two of them (but definitely not a hot day!)! So if that's true, that would indeed explain what happened. We just did a test today of running the engine with the alternator charging the battery while the controller was in bulk and the controller acted as expected which is it was in absorption for the correct length of time based on the wake up volts (we videoed it so we'd know what it was exactly).

Just a note on our previous experience up to this point - we've had this controller about a week with maybe two days of good sun for testing when this happened so it's been a learning curve but this one stumped us! Thanks for reading and coming up with the best answer as to what happened so far!! Next time we drive we're totally testing this!

That's actually a very plausible theory. Even enough cloud in the absorb phase could trip it....I'm going to do some testing I think.

mvader (Victron Energy) avatar image

Hi all, today we released MPPT firmware version v1.41, which has various fixes that came out of your questions and discussions here.

All information about the new version is here:
https://community.victronenergy.com/articles/17669/mppt-firmware-version-v141-released.html

Thank you @lnanne, @StraightUp, @Mark, @Boekel, and various others for helping to raise and detail these issues.

Best regards, Matthijs

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Guy Stewart (Victron Community Manager) avatar image

Hi Lnanne,

It sounds like the additional charge source from the vehicle was boosting the voltage beyond the absorption voltage (and providing the required current to keep it there). This would have reduced the current provided by the MPPT to less than 2A, so it considered the batteries to be full. As according to the MPPT, they only required a negligible current to stay at the absorption voltage, so it ended the absorption period early.


This behaviour is described on page 2 of the MPPT manual:


1.9.2. Absorption
When the battery voltage reaches the absorption voltage setting, the controller switches to constant voltage mode.

When only shallow discharges occur the absorption time is kept short in order to prevent overcharging of the battery. After a deep discharge the absorption time is automatically increased to make sure that the battery is completely recharged.
Additionally, the absorption period is also ended when the charge current decreases to less than 2A.


1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

This doesn't fly as an explanation frankly. I have never seen a vehicle alternator, especially after voltage drop from the crossover cable, elevate voltage anywhere near typical absorption values. Most direct alternator links provide about 14v max, and hence usually stop charging house batteries well before absorption completes ( hence why so many DIY campervans sulfate themselves inside a year).

45 minutes still seems like too little abosrob time. Considering the recent reports of controllers overreading their output and floating early, I suspect this unit is doing the same. @lnanne the definitive answer is whether your battery monitor says you've replaced the Ah you used the night before, and whether it says still gobbling amps once on float. If the answer is "No" and "yes" in that order, the Victron isn't working.

lnanne avatar image

Thank you both for your responses. Two thoughts/questions after reading them...

1. I didn't note the SOC after we parked (in full sun around 11:00) but did note the trimetric showed it was at bulk/absorption volts of 14.8 and 18 amps coming which told me the battery was not full. As I recall the Victron showed it was in absorption which made sense and we were waiting for the amps (according to the trimetric) to drop to perhaps 6-8 (at the 14.8 volts) which would indicate it was full enough. But when we checked awhile later, the mppt had dropped to float and the history indicated it stayed in absorption for only 45 minutes. Questions: a.) Is it not correct to observe the amps coming in (18) at absorption volts to indicate the battery was not full and could take more absorption? I don't entirely trust SOC because there are too many factors that make it squishy. b.) Do you believe that the mppt dropped to 2 amps in 45 minutes and therefore stopped absorption? I don't. The mppt is always showing way more amps going to the battery than the trimetric because it doesn't have the load. Because of the load, I'm not sure it would ever reach the cut off of 2 amps per the mppt.


2. If it did reach the 2 amp cutoff, why didn't it stop absorption immediately? Or do you think it was coincidence it stopped at 45 minutes which is 1/6 of the max absorb time of 4.5 hours? Or are you saying that the 2 amps doesn't cause it to stop absorption immediately but goes to the 1/6th formula and doesn't re-evaluate the 2 amps rule once it reaches it for that day (i.e. if for some reason it did drop to 2 amps while the alternator was charging the battery - we didn't look at that while the alternator was running).

Thank you for taking the time to understand our observations and resulting questions!


10 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

What kind of battery are you using? 14,8V sounds like a quite well charged battery to me...

They're lead acid 6v golf cart batteries wired for 12v and 14.8 is the volts the manufacturer recommends to hold it at for absorption. The issue is how long to hold it at those volts and the manufacturer recommends 2-3 hrs which had been our experience as about right (battery stops taking significant amps).

Ah makes sense then :)

if they don't use too much water than you're doing it right :)

@lnanne

It's a bit tricky to answer your questions excelty, not knowing the full details of your rig, OR the full details of exactly how the magic Victron algorithm works. But I'll try:

1/ a) It IS correct to observe amps, but on the TRIMETRIC. That shows the net amps the battery is losing/gaining. If it's holding 14.8v and still accepting 18amps, the banks (assuming it's around the 3-500Ah size?) is NOT full. Even if there's a load reducing what extra could potentially go to the batteries, if that batteries are capable of absorbing anything over 1% of their rated Ah capacity, they aren't full. In fact, you should REALLY be using the replaced percent (rPC) funtion on your Trimetric, and determining 'full' based on replacing 105-110% of your previous discharge depending on batt type).

@lnanne

1. b) I dont buy that its' because of the alternator proving so much absorption current that the MPPT dropped under 2A. Vehicle alternators are FAR lower than 14.8v (14.0v, usually) , meaning they simply cannot hold house batteries at 14.8v for absorb. ONLY the MPPT can do that - once that battery V is ove the alternator V (14 ish), th MPPT does ALL the charging. Ergo, it's impossible for your alternator to have provided so many amps during Absorb, that your MPPT only had to provide <2A to keep the voltage at 14.8v, ad just tripped to float.

It's clear that in this case, charging from your alternator SOMEHOW has disrupted your Victrons magic algorithm calculation prior to absorb starting. Based on the other reports of short abosrb times, it seems vulnerable to this already. Just why it does this, I dont know.

@lnanne

2. Again - I really dont know. As above, I dont think the 2A cutoff can be responsible for this. More that I think you early alternator charge has somehow fussed with the % of Max Charge formula and incorrectly shortened it.


Agree with all your thoughts. The batteries are 4 6v lead acid 210 ah. 2 sets wired in series to make two parallel 12v batteries. So total of 420 AH but probably much less due to our previous controller under charging (hard coded to one hour absorption). Hence the Victron purchase and our careful monitoring!

@lnanne what time did you start driving and was it cloudy?

It was totally clear yesterday and we started driving around 9:00. The solar controller was in bulk by 7:30 that morning.

Noted. Well, there goes the 'boosted startup volt' theory.

mvader (Victron Energy) avatar image

Hi @lnanne,

Current dropping below 2A makes the solar charger switch to float immediately.

Is it possible that battery voltage was above 12.6 volts when the MPPT started up? That would explain the 45 minutes, which you already said is 1/6th of configured max absorption time. Having such voltage would be perfectly possible in case the battery was already being charged when the charge controller started that morning.

3 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

They said already startup voltage was 11.9v.


The information provided is that the MINIMUM voltage recorded overnight was 11.9v. This does not necessarily mean that the voltage as measured when the MPPT 'woke up' was 11.9v. An external charge source may have boosted it - as it was also stated that the engine was runnng. Also, the only way to tell (as far as i know since I don't think the start up voltage is visable to the user) would have been to sit there and continuously monitor both the PV voltage/charge status & the battery voltage.

@Mark very good point / theory. However as lnanne has said above - the controller was already in bulk by 730am, and they didnt start the alternator until 9. SO one must assume it should have calculated based off the 11.9v...but seemingly did not, for some unknown reason.

lnanne avatar image

Per the history screen it shows the low volts were around 11.9 ( pic hopefully attached under the "yesterday" column). However, we did drive yesterday and the alternator was charging the battery at one point as well. Wondering if it revaluated the volts at that point and reset the time to 1/6? On another note, notice in the screen shot that we set the absorption volts to 14.95 in order to get the volts per the trimetric and the separate RV's volt meter to read 14.8 which is the desired absorption volts.


18 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yep. Something definitely off. This looks like the grpahs @Solvan sent to me, particularly the fact that 52% of the power provided alone was in float. Even with some loads still running, that says the batteries were well and truly still hungry when the MPPT stopped absorb. Considering you started the alternator well after first sun, that 11.9 startup Voltage should have given a FAR longer absorption. I think you have a faulty unit :(

You STILL need to be careful with your interpretation of the min/max voltage log as it refers to voltage extremes over the ENTIRE day.

If there was a huge load turned on for a short period or if the battery was depleted & then charged (partially or fully) later the same day, then the battery voltage at the time of 'MPPT' wake up will be much higher & the logic will make sense.

I am not saying that this is definitely the case - but it cant be ruled out as I think it would be very rare for the programmed logic to be faulty / not followed.

Unfortunately this would mean manually monitoring things for a few mornings (from before sunrise), unless you have VRM or some ability to externally data log the PV & battery voltages vs time.

@lnanne See above. Do you run any big loads (1kW +).

Or more definitevely - did you visually confirm ~11.9 V on the trimetric before you went to bed?


We visually confirmed the 11.9 volts per Victron history at 7:30. We never saw 11.9 on the trimetric even with fridge OR furnace running. Generally the trimetric will show a 5 amp draw in the morning before sunrise with volts between 12.0 and 12.2. I wasn't entirely surprised at the 11.9 because if both fridge and furnace were running at some point in the night it could be a heavy load (up to 18 amps?). The lowest volts are always in the morning before sunrise not at night when we go to bed.

@lnanne


Yes, but as mark pointed out, although we know the Victron history said it reached 11.9 at some point leading up to 730am, we need to know when that was. Or more specifically, just what was the system voltage actually at, on that day with the short absorb, at the moment the Victron decided to turn on. Ie sunrise. Do you have any confirmed volt reading for this time? Because that is the definitive factor in absorb calculation, it would seem.

The low volts at startup would have had to be more than 12.6 in order to come up with 45 minutes of absorption right? I don't see how they could have risen from 12.1 to 12.7 even with no current load because we have an all electric fridge, satellite TV, furnace, lights etc that run from sundown to sun up. Other similar mornings it did 3 hours of absorb based on the volts. The only difference yesterday was driving with the alternator charging (after the controller turned on and was in bulk).

Show more comments

I'm an early riser and because I'm trying to learn what it's doing, I've been doing just that, watching it as it turns on and noting the time, volts etc. and monitoring it throughout the day. The 11.9 doesn't seem to change throughout the day which makes sense to us because once the sun comes up the volts only go higher. We only have 1000 watt inverter and the major draw is the fridge. We are plugged in currently with clouds and rain in the forecast so can't unplug and do some testing.

"52% of the power alone was in float". That screen is indicating time only, not 'power' as you read it. Nowhere does it say Wh, just the % of time spent there. (The calc isn't spot on). My system shows similar times daily but when Float is reached, perhaps 90% of the batt charging is done for the day.

Add a decent load to drag V below Float, and she'll return to Abs for a little while too to compensate. Clever? I think so.

Really, much of this 'when/why/how' speculation could be solved with just a short selection of the VRM portal graphs. Once experienced, the veil of misunderstanding is largely lifted if you care to take the time to study them a little,

Not available? I commiserate, but to make sense it's essential. Speculation is fairy dust. Too blunt?, my apologies.

"That screen is indicating time only, not 'power' as you read it. Nowhere does it say Wh, just the % of time spent there."

Incorrect. The Y axis on the graph is very clearly marked kWh. Ergo each bar section is proportional to Wh yeild in that stage. Some quick manual calcs confirm this. Float is doing far too much of the charging.

The VMR portal is an entirely superflous solution. This is basic charging info, easily accessible on many other controllers. To suggest users need be dependent on a plethora of additional gear, nework connections, and expense (a CCGX alone is twice the $ of a Smartsolar 100|50) to asses something as simple as absorption time is highly impractical.

Fundamentally, this is very simple. If the controller is dropping to float when the batteries are still capable of accepting significant current, they are, by definition, not full, and the controller is not doing its job. You don't need fancy online graphs to see this.

Too blunt? My apologies.

"Clicking on any day/bar in the graph will expand the information to show charge-status times - both as hrs/m; and also as a percentage of the 'charge' day. This graphic provides an at-a-glance representation of how much time your charger is spending in each of three modes: Bulk / Absorption / Float."

From here: https://www.victronenergy.com/live/victronconnect:mppt-solarchargers See section 3 HISTORY

The VRM portal you can see as superfluous if you will. I don't care. But it would help you understand where you're wrong.

The conclusion you've extracted from that screenshot is implausible anyway. It just doesn't happen like that. But carry on..

Hey both, Let me check if the energy charged in float (and other states) can indeed be read from the graph; I see how it can be read that way; but I’m not sure its how its been intended. I’ll revert.


I find it frustrating to not being able to explaine this easily. I have one more theory; but first need to guide the kids through breakfast and school etc


Be back later

Hi; I checked with R&D, and the left axis (kWh) in that screenshot refers to the height of the total block. So indicates the total charge of that entry in the 30 day history.

The division of the three vertical blocks on top of each other is based on time. Not on kWh.

52% of the power was not provided while in float.

I've noted it; to see how it can be visualised better. For now it just is what it is. Thanks Straightup; I had never looked at it that way; but see it now.

hey @all; I see everyone is excited about this; which is great; But for me its now so much text that I can't follow it anymore. For nyone else stumbling on this post; it will also be quite the challenge to follow the conversation.

I don't know how to fix it (other than taking out my moderator delete button; but I don't want to do that); just saying.


Indeed - then why is the bar labelled and scaled on a kWh axis, if not to indicate kWh? It's very misleading otherwise.

It's a popup, and the screenshot doesn't do it justice.

My sincere apologies if I've offended you.

Also the reason you have to set the MPPT's voltage so high (14.95) is because it reads V at its output terminals, which in turn connect the wires it pushes the charging current through - hence it's victim to voltage drop induced by the larger current. You need 14.95 at the controller end of the wire, to get 14.8 at the battery due to resistance losses.

The Trimetric uses separate sense wires and thus isn't victim to this. It measures true battery voltage and is the more accurate reading.

We guessed that as well. We also surmised that the reading of the amps going to the battery on the first screen (not shown) are higher than the trimetric even taking into account the loads due to the same reason. In other words as an example, we know our load is 4.5 amps without the fridge running and the trimetric shows a net of 18 but the Victron shows 26 or more going to the battery so we're "losing" around 3 amps between the solar controller and battery (we assume).

Well, in a closed circuit, you shouldn't 'lose' any amps. Voltage drop shouldnt affect this at all - all measuring devices should show the same sum current, ie Trimetric battery input plus any loads should equal what the Victron says it's putting in. As solvan has established, this isnt the case. That seems to be a Victron fault.

lnanne avatar image

Because I cannot show what the start up volts were at sunrise (didn't take a screenshot but noted that Victron history showed 11.9 right after) and my logic isn't generally being accepted as to why I believe it was between 11.9 and 12.2 and not anywhere near 12.6 which would have resulted in the 45 minutes absorption (our sundown to sunrise usage, trimetric showing 12.1 approximately right before sunrise and no other charge source at sunrise), I'm not sure further discussion will yield an answer. I will continue to monitor (once we have clear days) and try with the alternator after bulk starts and take screen shots to share if or when it happens again. Appreciate everyone trying to help.

4 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

To be accurate you will need to determine the voltage just BEFORE the MPPT 'wakes up' @ V batt +5v - once the MPPT 'wakes up' & the bulk phase kicks in it will immediately pump up the battery voltage somewhat. So what i'm saying is that evaluation of the voltage/photos even just after 'wake up' is not even enough to accurately evaluate whats going on. To be thorough I would recommend taking a short video starting from before the MPPT 'wakes up' & coupling it with the actual behavior later on in the same day.

PS. You don't need to prove anything to us, my recommendations are more for yourself to confirm without any doubt. If you are already 100% sure then just return the unit & get it tested - that said clear evidence would still assist with this.

@lnanne

May I ask where you're located?

We are from Washington State but are retired and travel in our RV most of the time. Currently in the Arizona desert!

Yep. So, not Aruba, in other words :)

Boekel avatar image

Just a thought...

Are you sure your batteries are still ok? if you start at 11.9v (really empty if not loaded) and are at 14.8v after a couple of hours charging, something seems off to me

10 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Boekel, I just had a look at the info provided & totally agree with you.

It was stated that the battery bank is 12v 420Ah = ~5.0kWh

~11.9v rest voltage for a lead acid is ~10% SOC.

Accordingly the battery bank has been depleted of ~4.5kWh from its total capacity.

Assuming ~95% charge efficiency it would require ~4.8kWh of charge to bring the SOC back to 100%.

Now even if we exclude the absorption phase & just focus on the bulk phase (controlled by voltage only), this phase alone should bring the battries back upto ~80% SOC. According this phase ALONE should require ~3.8kWh of energy to complete.

Now when we look at the Victron Connect data log, the TOTAL yeild for the entire day shown is only 1.4kWh, with the bulk phase only lasting ~4.5h & the battery in float for most of the day.

So in summary, I think the batteries are properly screwed!

The other thing that I also noticed is that the MAX PV voltage recorded is only ~20 to 22V. So with a 12v system it would take a fair amount of sun & time after sunrise each morning to achieve the required 'wake up' voltage of V batt +5v (~17v min to ~19v if the battery is not depleted). If you can rewire the solar panels into a series configuration it would make a significant improvement to this aspect.

Finally, regularly depleting lead acid batteries to ~10% SOC is doomed to fail VERY quickly (even with new batteries). You should design the system for ~50% DOC as the extreme max and ideally only take out ~20% max per day to provide a few days of autonomy.

Thanks Mark. I had a nice long response typed out but it just wouldn't accept the post even though it was within the limit. It'll probably accept this one though so I'll shorten my response to "understood" and we've got it covered!

@lnanne Yeah theres a bug in the comments scripting I beleive -you need to actually have about 70 characters spare, or it refuses (or dumps!) the post when you hit submit! I've found that out the hard way a few times :(

I disagree with @Mark and @Boekel here.

See below OCV chart for Fullriver DC400s - 11.9v = 30-35%, not 10%. And thats at 25C; I regularly see 11.9-12.0v at 40% in cooler weather. Yes, they're AGM, but point is SoC and OCV varies between different batts.



I admit, even if 11.9v = 30% SoC, @lnanne 's graphs still don't account for 70% recharge. BUT:

That 11.9 was a historical min voltage ie likely UNDER LOAD (as you actually already pointed out Mark...). 11.9v is NOT the resting OCV in the morning. What lnanne ACTUALLY said was 'generally a morning voltage of 12-12.2', and even then thats with a 5a load. Meaning the batteries are very likely far from 30% at all, rather much higher.

Additionally, they said that they added more charge by driving, which wouldn't appear on that Victron chart.

In other words, I very much doubt the batteries are "properly screwed". In fact the data indicates quite the opposite





ocvsoc.png (129.2 KiB)

Yes, very cold (near freezing) and definitely under load if the fridge and furnace are running to produce 11.9 (which we've never seen with the trimetric). Regardless, we're not thrilled that we are cutting it that close but the batteries are likely ruined from undercharging by our previous controller which took us awhile to realize. It held absorption to only an hour which was not enough to fully recharge. Our usage is about 125-140 AH overnight on 420 AH of battery bank. But as I said, we probably no longer have good batteries.

Perosnally I very much doubt that you batteries are stuffed, or that it has anything at all to do with the controller misbehaving. At those temps with that usage, 11.9 seems fine.

I wasn't aware the volts would be lower due to the overnight temps but it makes sense. The batteries are doing well enough as long as we can get a full charge each day. When there isn't sun, we run the generator but sadly it too doesn't charge the batteries properly as it's hardcoded to only go to 14.4. We can't believe the things we didn't know that ONCE AGAIN shortened our battery life!

Furthermore @Boekel and @Mark:

I don't see how this changes the problem with the MPPT. Specifically:

-If the batteries ARE 420AH, and lnanne really IS depleting them to 30% SoC (unlikely) then why is the controller not holding bulk and absorb long enough to fill this?

-If the batteries are LESS than 420 AH (Ie sulphated) then they're basically just smaller batteries, and it shouldn't make any difference. The MPPT should still hold absorb until current dwindles, and it's clearly not doing that.

For reasons explained above, I think scapegoating the batteries is a dead end, considering we have established the controller IS dropping out of absorb too early .


But for the sake of rigor: @lnanne - next time you do a discharge, would you mind checking the Trimetric for this info:
- % state of charg
- Voltage (after no load for 10 mins)
-The actual Ah used (hold 'select' 3s and enter sub menu)
-Model of battery

That should verify battery health somewhat.


I agree the state of our batteries isn't the issue. I think (hope) they were merely pointing out another problem we might have. It's been on our list next time we're fully charged to let the batteries rest and dig out the hydrometer to see how bad they are. We can't change our usage much (fridge and furnace when freezing overnight) so we're probably closer to 50% instead of the 30% (usage) or so we were expecting.

Mark avatar image

@StraightUp - FYI my assumption & calcs were fairly generic / high level for lead acid batteries.

The V vs SOC % I assumed was from a 'generic' V vs SOC table that I had saved a few years ago & had on hand - see attached;

Of course the EXACT manufactures data should be used if available.

But even if 11.9V = 25% SOC, going down this far day after day on a lead acid battery is a very deep discharge & not a good system design.

For an 'average' AGM you would be lucky to get ~500 cycles / ~1.4yrs if your doing this day after day (& that is if the battery is FULLY recharged each day).

And yes - to properly evaluate you need to include ALL LOADS (which would make the result worse) & CHARGE SOURCES (which would make the result better).

So;

To be 100% ACCURATE and eliminate any ASSUMPTIONS, then I recommend for a BMV to be used.

To ACCURATELY check the batteries capacity, conduct a LOAD TEST using a calibrated load equal to the C20 current, down to manufacturers V min spec & monitor time elapsed.


1550117455277.png (35.8 KiB)
2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Regarding the relevance to the question - the battery should reach ~80% SOC during the bulk phase alone & the bulk phase end condition is simply based on voltage only. Accordingly for a deep discharge most of the energy entering the battery will occur during the bulk phase.

I was attempting to demonstrate that even if you forget about/exclude any possible concerns with absorption phase, based on the LIMITED data provided (from the MPPT only - rather than a proper BMV) there seems to not be enough energy entering the battery during the bulk phase. This is typical behavior from a battery bank that is not performing at full capacity any more.

It was also just some general thoughts/advice on the current system design vs usage profile.

They do have a BMV. Or, rather a better one - a Trimetric.


In fact lnanne posted their average nightly useage figures above - about 140Ah.

Considering they said the batteries are already a bit detracted from previous undercharging, and they're operating in near freezing conditions, hitting the 12.0 - 12.2 mark nightly as they say makes sense to me for a roughly 50% cycle.