question

Tim Chapman avatar image

Current limit display won’t turn off on Digital Multi Control

I have a DCM connected to a Multiplus 12/3000/120. I also have a VE Bus BMS and an Octo GX. Recently I installed a VE Bus Smart Dongle and although the Multiplus seems to operate correctly when I turn the DCM switch to Off all the lights go out except for the numeric current limit display, this now stays illuminated in all three DCM switch positions. How can I restore the DCM to normal operations?

Digital Multi Control
2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have noticed that when I turn on the DCM the bulk light flashes twice before the unit operates as normal/

I have the same issue. I also have a VE Bus Smart Dongle.

2 Answers
1point3liter avatar image
1point3liter answered ·

The DCM Current LED's staying on appears to be intended functionality. I found quite a few videos on youtube where people either review them or show how they work and the LED display does not turn off in all the videos.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi,

There were improvements recently made in VictronConnect, and GX firmware for systems with VE.Bus BMS, DCM and VE.Bus Smart Dongle.

Please confirm the firmware and software version is the latest and then report back with those version numbers if still experiencing issues that are not explained here -

https://www.victronenergy.com/live/vebus_smart_dongle_manual

4 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I'm on the latest VE.Bus Smart Dongle firmware, v1.09.

I also just confirmed that the behavior exists with and without the VE.Bus Smart Dongle hooked up. Is this maybe standard behavior of the DCM device? If so, is it configurable?

One more thought, I read the manual and the only thing I can find related is in chapter five where you mention the LEDs auto dim. It's not clear on if this is in reference to the indicator lights or the current setting led's (or both).


"5.3 LED brightness For your comfort, the brightness of the LEDs is controlled automatically using a light sensor. When the ambient light level becomes lower the LEDs will be less bright which is more pleasant for the eye and reduces power consumption."


https://www.victronenergy.com/upload/documents/Manual-Digital-Multi-Control-GX-Panel-EN-NL-FR-DE-ES.pdf

My Multiplus is model 2609 with firmware 481. I suspected the DMC was faulty so I bought another one, the new one shows the same behaviour. I have spoken to the dealer in Auckland but so far we haven’t been able to resolve this.

I disconnected my GX device and this did not resolve the issue.

My VE Bus is as follows;

Multiplus1 - AC Detector - BMS - DMC

Multiplus2 - Octo GX

In addition, as I mention in the OP when I switch the DMC from Off to On the Bulk LED flashes twice before the Inverter LED comes on. I don't remember seeing this double blink before but it may be normal and I've never noticed it.