question

mvader (Victron Energy) avatar image

Venus OS Large: Node-RED and Signal K


BE AWARE: welcome to post a nice screenshot to show what can be done here. But please don’t ask question or post issues here. See support section in the Venus OS Large manual for that.



Hello all,

As some of you know, something new is in the works, called "Venus OS large". This post is intented to start getting a large audience for it, as well as to recruite more help in further developing it.

This story is a bit longer than I usually type, here we go:

Introduction

Venus OS Large is an extended build of Venus OS, it adds Node-RED and Signal K server.

Node-RED is a tool for connecting hardware devices, APIs and online services. It provides a browser-based editor that makes it easy to wire together flows. With it, one can for example program something relatively simple such as a relay to open or close based on a temperature measurement. As well as make far more complex algorithms, tying voltage, current, power or other readings and other data available from Venus OS or elsewhere together with outputs such as relays or control points of the Victron system. All without having to write real source code.

Also Node-RED features a fully customisable dashboard, viewable in a webbrowser - both locally and remotely, via the VRM Servers.

Signal K server is aimed for yachts, and multiplexes data from NMEA0183, NMEA 2000, Signal K and other sensor inputs. It makes all that data available for Apps, such as WilhelmSK, a highly customizable boat instrument display. The Sailing with Signal K blogpost on our website is a great read for more information and ideas.


Customisation & automation without needing to be a software developer

The value of above is that now you can self configure and customise your GX Device to do many of the things asked for here. And doing so without having to posses software developer skills. It will require patience, time and to be not too afraid of trying things.

Its really extremely powerful and I'm super excited about the possibilities.


Documentation & how to install

See https://www.victronenergy.com/live/venus-os:large.

Venus OS Large is available for the Cerbo GX, Venus GX, MultiPlus-II GX and EasySolar-II GX as well as the RaspberryPi3 and RaspberryPi 4.


Want to help?

There are a few ways to help. First of all by simply installing and using it; and reporting any issues, or just that you're happily using it and what you are using it for.

The other is by helping others here on the Modifications section on Community. There is and will be no official support for Venus OS Large. Instead, we are referring users to turn here, the Modifications Space on Victron Community. You can help by answering questions.

Next, there is developing and improving the documentation; The manual needs further development, also the nodes and available measurements will need detailing and documenting, examples, screenshots, videos, it will all help adoptation and getting the best out of this. And we'll need more help for all of that that.

Lastly I am looking for help in development and support. First of all to further develop and support the Victron integration into Node-RED, ie. the node-red-contrib-victron package. Which will require nodejs experience, Linux experience, and preferably also experience with Victron products; ideally you'd be following and taking part of the discussions here on Community, (remotely-) debugging issues as well as suggesting and implementing new functionality in the said package.

Besides the node-red package, also the integration of Node-RED and Signal K in Venus OS needs to be maintained. Which requires a different skillset: deep experience and knowledge of Linux, but also the Open Embedded build system.


Conclusion

I can type a whole lot more about this, but have to stop now. Have a good Sunday! And if you have examples, or questions or comments, welcome to put them below.


Ps. Node-Red example flow:

1610898388198.png


Venus OSNode-RED
1610898388198.png (65.4 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

24 Answers
Stefanie avatar image
Stefanie answered ·

Hi everyone,

I'm a big fan of VenusOS Large from the very first day and appreciate all the work the developers incl. Matthijs and Scott already have done so far. Never forget: they do it in there limited free spare time, where everyone else is sitting at home having a glass of wine or go sailing.


As an ordinary boater/sailor and NOT an expert of Linux or even a coder, VenusOS Large is coming really handy as it does not require in depth knowledge. There are plenty of easy to understand tutorials for Node-Red out there. Same for SignalK.

For me the best thing is that it can be installed also on my Cerbo GX, which saves me from installing and running it on another device like the Raspberry Pi (though I do just because I'm curious ;)

Here is some work in progress, building a Grafana dashboard fed by various InfluxDB database sources. The dashboard is showing sensor data coming from my sailboat as well as from sensors here at home.

It kinda goes like this:

Sailboat -> CAN Bus/NMEA2000/Sensors -> Cerbo GX -> SignalK->InfluxDB plugin -> Router -> Virtual Private Server hosting InfluxDB <-> Home Router <-> Grafana <-> RasPi with SignalK/Grafana <- Sensors <- Home

bildschirmfoto-2021-01-18-um-124653.png

bildschirmfoto-2021-01-18-um-124710.png

bildschirmfoto-2021-01-18-um-124738.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Mark avatar image
Mark answered ·

Hello everyone,

Just a short note about NodeRED integrated into the Victron Venus OS (large image FW) - This major update has been work in progress for a very long time and is a huge enhancement for more ‘advanced and enthusiastic’ users and users/systems that have unique or specific control desires/requirements – it is super powerful, extremely flexible, doesn’t require any prior/specialised programming skills (apart from passion and lots of spare time), has a large established support base, and really has no practical limits apart from your imagination…


Just as an example, this is the UI dashboard (accessible remotely via VRM) of a WIP automatically modulated AC dump load control system that I have developed in Venus OS NodeRED:1611055429008.png


1611055429008.png (292.1 KiB)
5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Marc - may I ask a question, how did you achieve this: "UI dashboard (accessible remotely via VRM)" - not the UI itself (as I am running Node-Red also in my HA system), but to make i accessible via VRM.

Thanks for kind reply

Best Mischa

Hi @mehlers, in the example shown I am using NodeRED embedded within Venus OS 'large image', in this case Victron has provided a proxy server to access nodeRED via VRM - see section 6 in the documentation: https://www.victronenergy.com/live/venus-os:large.

If you are using NodeRED outside of a Venus device, then you may need to setup a VPN service or similar to access it in a a secure manner. Maybe try taking a look in the generic NodeRED forum: https://discourse.nodered.org/.

Hi @Mark - Thanks for the quick reply. Always a good idea to read the docs..... :-) But: when I try to access via adding "proxy" as mentioned in the doc- I am always redirected to the installation page. Any additional steps necessary? Mischa

My guess is that you have left out the / at the end - that is also in the docs... :-)

Your guess was right.....

Lackan Cottage Farm avatar image
Lackan Cottage Farm answered ·

Am now running Venus 2.70~3-large-12 on a Cerbo. Connected are:
BMV-712, 3x Smartsolar MPPT, PV inverter on AC-out, Bornay Wind+ MPPT , Smartshunt, 2x parallel Multi 3000/24.
I am running Grafana, Influx on a Raspberry Pi4. I have experimented with Node Red - it won't start automatically but starts fine from command prompt and runs ok. I'm unsure how NR deals with devices and services that aren't on its list so sticking with Grafana for now but experimenting with Node Red.
screenshot-83.pngInterestingly the Gui binary we made to run on CCGX 2.62 with the additional wind service, works fine on this Cerbo with the 2.70 large 12 firmware.


screenshot-83.png (707.3 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mattsmith avatar image
mattsmith answered ·

I was concerned about having node-red local on the Cerbo, but now after months of testing can say it's brilliant..! Below is a dashboard I created, my unit is also leveraging the solar forecast from solcast and automatically turning on and off hotwater, opening blinds, air conditioners etc to manage the house with 'excess' power or shutting down to be conservative. Great work by the Victron team, thank you...!1651817903768.png


1651817903768.png (106.0 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Paul B avatar image
Paul B answered ·

Hi, in looking for the new venus- large os this doc pushes you off to another thats send you another and its definatly not in the last comments on this issue. Just a bit confusing for those looking thats all

(MVA: I shortened this a little; trying to keep this compact)

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Paul,

you can edit the document and put the download link in there.

Yes, hard to find. It is at the end of mvader's comments regarding the new version

The CURRENT link is:

https://www.dropbox.com/sh/i8ru22o4ydws1rx/AADpa8lj5s2APZ2JS78OGPjKa?dl=0&lst=

Other dropbox links in that thread don't appear to be valid.

(MVA UPATE: I changed that link to be a list view)

Paul B avatar image Paul B mvader (Victron Energy) ♦♦ ·

Thanks-So much better

Kevin Windrem avatar image
Kevin Windrem answered ·

For what it's worth, I updated my Venus Raspberry Pi 4 (2 GB RAM) to large12 today. All is well.

I have no plans to use Node-Red or Signal K and my system is pretty simple so it's not all that much of a test.

System:

  • Multiplus Compact 12/3000
  • BlueSolar 100/30
  • Smart Shunt
  • MK3 to USB
  • 2 Ve.Direct USB
  • CANable CANbus to USB adapter running Candlelight firmware
  • SeeLevel tank system N2K version
  • 2 BattleBorn GC2 batteries in parallel
  • 4 100 watt solar panels on roof connected in series
  • GlobalSat BU-353-S4 USB GPS Receiver
  • Passive USB hub for all connections
  • Installed in a Geo Pro travel trailer
  • Wireless to WiFi Ranger in the trailer then to the internet when available
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image
Kevin Windrem answered ·

There seems to be a bug with 2.70~3 large 12. I can't use VRM to do firmware updates on Ve.Direct devices. I get an error:

Error: 733

Error Message: Stopped with signal 11 - SIGSEGV

The only device listed is my See Level N2K tank repeater (CANbus).

Neither Signal K nor Node-Red functionality is turned on.

2.60 (not large) works fine.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Kevin, thanks - yes. Its a known issue; and I have a fix and need to build a new image with it.

its not the addition of signalk and nodered that broke this; its the fact that its using a newer version of the build system (open embedded) and with that to newer versions of compilers, libraries, various utils and binaries etc.


fix will be out soon!

Kevin Windrem avatar image Kevin Windrem mvader (Victron Energy) ♦♦ ·

Thanks for the quick response. Glad it is a known issue and you have a fix. No rush.

John macrae avatar image
John macrae answered ·

Happy to report the latest image works well with RPi4 (4Gb). NR and MQTT working so far with data received from my own BMS. Now I have to figure out how to get it to display :)


Thanks for all the work that got us this far :)

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Nikolay Nedeltchev avatar image
Nikolay Nedeltchev answered ·

Hello,

There is a bug in the latest .img file.

I've download and 'burned' the Large image from this link here.

https://www.dropbox.cvenus-image-large-raspberrypi2-20210113212245-v2.70~3-large-12.rootfs.wic.gz

the problem is that I can't start the node-red. I've got the messages

*** Starting node-red ***

Error loading settings file: /home/root/.node-red/settings.js

Error: Cannot find module 'debug'

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

vassilis-bourdakis avatar image
vassilis-bourdakis answered ·

quick Q to @mvader (Victron Energy):

about to update my working system rpi3B+ from 2.60(small) to 2.70-3large12.
when is the next ver coming?

iow, shall I do it today, or wait for a few days? :-)


Test system with rpi4 2GB works fine on large, so time to update (and test other things with the rpi4.


cheers


V.

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hi, can’t make any promise on that; sorry.

vassilis-bourdakis avatar image vassilis-bourdakis mvader (Victron Energy) ♦♦ ·

no worries at all!

I'm v.happy to even have all this work!

I'll install the 2.70 3-10 on now, no problems

BTW, is there any explanation on why each time I reboot my raspberry on board, the two USB devices (BMV700 and MPPT100/30) seem to be swapping their VRM instances?

BMV700 one time is 288 after the next reboot is 289

at the same time MPPT was first time 289 and then 288.

Is there a way to "FIX" their VRM instance number somehow?


cheers


V.

Yes, fixed soon!

vassilis-bourdakis avatar image vassilis-bourdakis mvader (Victron Energy) ♦♦ ·

thanks!

in the meantime started preparing another how to for the 7in raspberry touchscreen for this 2.70 ver.


V.

vassilis-bourdakis avatar image
vassilis-bourdakis answered ·

TOUCHSCREEN DOESNT FUNCTION ON 270~3-large12 on rpi3B+ with 7in official touchscreen:


hi, upgraded my working rpi3B+ with rpi official 7in touchscreen from 2.60 to 270~3-large12

OK, not upgraded, used a new sd card, and followed the v2.60 instructions to upgrade/setup the necessary bits for the touchscreen. To my knowledge there's no instruction set for 2.70, assumed the 2.60 will work and followed it to the iota:

https://www.youtube.com/watch?v=UXskvldEmiw&list=PLbFliBZXWa8Dos0zbCRUBhMZbkBxZ7K_a&index=35&ab_channel=HimmelbergerBus

came across the issue mentioned regarding the opkg upgrade here:

https://community.victronenergy.com/questions/77643/updatinginstalling-packages-on-venusgx-running-ven.html

edited /etc/opkg/venus.conf replacing zeus with rocko, then upgrade worked fine, no errors.

Next step was

opkg install qt4-embedded-plugin-mousedriver-tslib

which installed but came up with this log:

Installing libssp0 (7.3.0) on root
Downloading https://updates.victronenergy.com/feeds/venus/release/packages/rocko/cortexa7hf-neon-vfpv4/libssp0_7.3.0-r0_cortexa7hf-neon-vfpv4.ipk.
Installing tslib-conf (1.1) on root
Downloading https://updates.victronenergy.com/feeds/venus/release/packages/rocko/cortexa7hf-neon-vfpv4/tslib-conf_1.1-r0_cortexa7hf-neon-vfpv4.ipk.
Installing kernel-image-zimage-4.9.80 (4.9.80+git0+7f9c648dad) on root
Downloading https://updates.victronenergy.com/feeds/venus/release/packages/rocko/raspberrypi2/kernel-image-zimage-4.9.80_4.9.80+git0+7f9c648dad-r0_raspberrypi2.ipk.
To remove package debris, try `opkg remove kernel-image-zimage-4.9.80`.
To re-attempt the install, try `opkg install kernel-image-zimage-4.9.80`.
Configuring libssp0.
Configuring tslib-conf.
Collected errors:
 * check_data_file_clashes: Package kernel-image-zimage-4.9.80 wants to install file /boot/zImage
        But that file is already provided by package  * kernel-image-zimage-4.19.81-v7

which is not v.good I recon.

did another series of steps, did the calibration on screen got the values:

xres = 800, yres = 480
Took 1 samples...
Top left : X =   48 Y =   60
Took 5 samples...
Top right : X =  745 Y =   62
Took 1 samples...
Bot right : X =  737 Y =  429
Took 1 samples...
Bot left : X =   54 Y =  432
Took 1 samples...
Center : X =  399 Y =  242
-2.957874 1.014374 0.002682
-12.218375 0.000727 1.028286
Calibration constants: -193847 66478 175 -800743 47 67389 65536

and the /etc/pointercal now shows:

66478 175 -193847 47 67389 -800743 65536 800 480

removed the headless, rebooted, comes up nicely full screen BUT:

1. touchscreen doesn't work

2. there is no backlight scrollbar on the display & language screen

screen blanks normally and wakes up when accessing it from remote console, so it's fine in that respect.

compared to 2.60 pointercal, rather different, replaced the generated on 2.70 to the 2.60ver one, rebooted, no difference

66484 527 -349670 382 66058 -673710 65536 800 480


I can live with no backlight regulation for a few months before I use the boat again, but with no touch, it's difficult.

Also bluetooth, seemed to connect, then didn't again, not sure, doesn't seem to work!

any pointers or things to test welcomed!

cheers


V.


6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hey Vassilis, what you did, "edited /etc/opkg/venus.conf replacing zeus with rocko, then upgrade worked fine, no errors. " may seem to work, but really is not something you should do, and also not something anyone including myself should spend time on trying to figure out whats going on. Its too fundamentally wrong to do it that way.

For example, I see the system is trying to replace the kernel: really not good.

After posting this comment answering yours, I'll remove your message and mine; as this is distracting from the topic here, Signal K and Node-red.

For now, anything that needs opkg downloads will simply have to wait for v2.70 to become normally available including opkg feeds.

vassilis-bourdakis avatar image vassilis-bourdakis mvader (Victron Energy) ♦♦ ·

M,

apologies if I'm taking your valuable time on things like that, I thought it would be nice to sort out such an issue (if its something easy) happy to wait for the official, will just install it as is and connect with the remote console :-)


cheers


V.

I had no problems bringing up the RPI 7" touchscreen on 2.70~3Large12 on my Pi 4

In fact, most of the steps in the instructions were not required.

The ONLY thing I needed to do was add stuff for backlight and screen saver following instructions here:

https://community.victronenergy.com/questions/56217/venus-os-v26034-available-for-testing.html?childToView=56411#comment-56411

I have created a script to automate the process:

https://github.com/kwindrem/RpiDisplaySeutp

The script also restores the mods after a Venus update.

wow!

went the hard way :-) and failed...
OK, got the gist of your suggestions, reformated the SD, did the v.few editing and now touchscreen works (no backlight adjustment, but tbh don't care until the summer!)

Regarding your scripts I note that the one you link to has a spelling mistake if you want to edit it: Seutp instead of Setup.

Also checked the other (SetupHelper) as well (using it for my CANHAT) and instructions are slightly confusing regarding where you place/paths/folder names, etc. If you'd like to have a look at it would be great!

But anyway, got the system working now, with the CANHAT, checked at home in a test rig, so tomorrow goes to the boat.

Next task is manage to reduce the data leaving the boat from the dodgy wifi connection and or have a buffer to keep them when system is down (often 1 or 2 h, then up again)


thanks!

V.

Corrected the repo name.


As designed, SetupHelper should go in /data with the other script packages.

.The SetupHelper ReadMe was the wrong content. Fixed that now

Thanks.

If you used my script, which CAN interface did you use? I'd like to know so I can mark it as tested.

OK, actually I've taken parts of your script last month and modified it to setup my WAVESHARE 485-CAN HAT. I've added the section on Waveshare on the RaspberryPi CAN Interfaces wiki.

I guess you could say it's working, but it's now back on the boat and don't want to mess with it. Will check on next update if you want.

cheers

V.

vassilis-bourdakis avatar image
vassilis-bourdakis answered ·

hello all,

I'm trying to install a remote access tool for myrpi3B+ running VenusOS Large on the boat and I'm hitting this problem again which is I guess a venus wide one:
no apt-get, so cannot install tailscale
no raspberry binary to install ZeroTier.
Can anyone point me how do I get to install such apps? (or recommend another that does work with no static IP etc)

I understand VenusOS only has opgk manager, is it possible to install others, or do I have to go low and download sources and built from source? Haven't done that for almost 30yrs so expect I'll fail miserably...

and one comment on the Large distro: SignalK works absolutely fine but if you leave logging on, it floods the /data partition to 100% and you're slightly stuck. Should there be some way to keep log files from filling to 100% the partition? Only noticed when I tried to update a plugin in SignalK and it wouldn't let me.
I guess that's down to the user, just wondering if there's a way to prevent it from happening by default.

cheers

V.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hey @Vassilis Bourdakis could you ask this in a new question? This might grow into a long discussion - thank you

Hi @Vassilis Bourdakis,

If remote access via VRM doesn't give you sufficient access, have a look at:

https://github.com/victronenergy/venus/wiki/howto-configure-OpenVPN

Your VenusOS node would connect to a VPN server on the net to which you would also connect unless you're running that VPN server yourself and the remote VenusOS node can find it (fixed IP address or something like Dyn-DNS).

Jan


sportswagoneer avatar image
sportswagoneer answered ·

Really excited about running a signalK server on my yacht’s Cerbo GX! Will be interfacing with WilhelmSK on Apple TV, watches, pads etc.!
BUT: It’s not clear for me how the Cerbo will aquire the data from my NMEA2000 units. It’s connected to a B&G Zeus2 MFD over Ethernet. Will it acquire the data over this connection or should I connect it directly as a node in the NMEA2000 (Simnet in my case) network?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

palle avatar image
palle answered ·

Hi.

I have two Cerbo GX.

I have used 2.70-3 large-12 for a while. It worked perfekt.

For a cupple of days ago I updaded both to 2.70-5 large-18.

Now I have one who workes perfect and one who not work so god.

On that one who doesn´t work, I cant reach Node-Red. (no server runing) I can reache Signal K.

Another problem is that all settings go back to default when I reboot.

The other one works perfect.

If I go back to 2.70-3 large-12 I can reach Node Red, but my settings is still resetting at reboot.


Setup on the "perfect" one:

Cerbo GX

Smartshunt

SmartSolar 75/15

Phoenix inverter 12/1200

SmartBatterySense Black

USB GPS

TempSensor for GXDevice Meassure the engine temp)


Setup "not so perfect"

Cerbo GX

BMV-712

MultiPlus 12/2000/80 230 (with it´s own temp sensor on battery)

VE.Bus smart dongle (with external temp sensor on battery)

VE.Can to NMEA 2000-adapter

Temp sensor for GX (measure the temperature inside the boat)

USB GPS


Any idea?


13 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

If your settings are not saved through a reboot, it is likely the /data partition is corrupted.

If you have a *nix system, you could try to repair the partition with gparted.

Since there are no settings anyway, I'd reflash the card with a new image and see if that helps.


I´m using a Cerbo GX, not a RPI. Can i flash a Cerbo?

Oops, sorry. I don't know how you'd do a scratch install on Cerbo I defer to other experts.

Hi, you cannot reflash a Cerbo. At least not in an easy explainable way; its not part of any service procedure.

Hi.

Can anyone advise me where to write to get some help?

Or is it just to call my reseller?

Yes, I'd try your reseller.

First, I'd install the latest (not large) released software and see if the problem persists. If that clears it up, then you could try large again.

I’ll take a look @Palle. Which of your systems is it? Birch or the other one?

palle avatar image palle mvader (Victron Energy) ♦♦ ·

Birch is the one with problem. Now running on 2.66.

ok I see it already, your issue is that your data disk is full. That partition holds normal Venus OS settings, factory data and also log files. And for Venus OS large it also has npm cache, node-modules, signalk plugins, etc etc.

For those interested, some info below.

Meanwhile I'm looking into this a bit more and will post another message later tonight to let you know what I did to fix it. Its fixeable - don't worry.


All disks:

root@einstein:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root               282687    213041     50532  81% /
devtmpfs                465560         4    465556   0% /dev
tmpfs                   515224       300    514924   0% /run
tmpfs                   515224       344    514880   0% /var/volatile
/dev/mmcblk1p5         1182728   1166344         0 100% /data
/dev/sda1              3888192    264216   3623976   7% /run/media/sda1


So thats a 1GB data partition that you've filled up :).


All sorts of npm / signalk things in there:


root@einstein:~# du /data/ | sort -nr
1164540/data/
1119732/data/conf
1119672/data/conf/signalk
99336/data/conf/signalk/node_modules
42600/data/home
42576/data/home/root
32288/data/home/root/.npm
32276/data/home/root/.npm/_cacache
26144/data/home/root/.npm/_cacache/content-v2
23424/data/home/root/.npm/_cacache/content-v2/sha512
14164/data/conf/signalk/node_modules/@signalk
9900/data/conf/signalk/node_modules/@signalk/freeboard-sk
9836/data/conf/signalk/node_modules/@signalk/freeboard-sk/public
9748/data/conf/signalk/node_modules/mathjs
9580/data/conf/signalk/node_modules/kgauge
9504/data/conf/signalk/node_modules/z-schema
9488/data/conf/signalk/node_modules/kgauge/docs
7892/data/conf/signalk/node_modules/z-schema/node_modules
7888/data/conf/signalk/node_modules/z-schema/node_modules/core-js
6352/data/home/root/.node-gyp


I removed /data/home/root/.npm and /data/home/root/.node-gyp. Which I'm 99% sure are just caches of various things, and will be auto-downloaded again by npm, gyp and friends in case needed.

And then I rebooted the unit, all seems OK now.

Note that your data partition still seems to be rather full. You might need to clean up more.

For that, you could first simply try to remove some plugins. Though I don't know if removing a plugin also makes all dependencies go away by itself. To see free diskspace, you'll have to login with ssh or on the serial console, and use the df command.

For help on that, please either make a new question here, or go to the SignalK slack. Lets not continue in this Venus OS Large / Node-red / SignalK announcement thread.

Have a good evening!

ps. Scott Bender just confirmed me that if you remove SignalK plugins via the SK App Store, their dependencies will be removed as well. so thats good.

palle avatar image palle mvader (Victron Energy) ♦♦ ·

Thanks a lot for all help.

I don´t have so many plugins, but i have around 200 "signals" in my NMEA 2000 network. I think I need to claen upp a little bit. Thanks again.

palle avatar image palle mvader (Victron Energy) ♦♦ ·

I thought that it could be something whit the memmory. I compred both my units and this had half of the memory left, Don´t be affraid to delete settings and data. I use it just for fun ;-)

stager avatar image
stager answered ·

Yes, I'm stupid and I've never seen Windows.

So, pls, someone explain to me - how to create SD with Venus OS Large for Raspberry Pi 3 from scratch? Step-by-step. In Linux environment.

I smoked docs, but nothing...

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

under https://linuxhint.com/install_etcher_linux/ you find a very good description how to install Etcher on Linux.

BR

Good description? From the Hindu? By seriously?

I know two other ways to burn os image, out from the box, without installing trash. But the question was not about it.

stager avatar image
stager answered ·

The Signal K server function app.getSelfPath() always return "undefined".

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ulrikmailand avatar image
ulrikmailand answered ·

Hi great fan of the Venus OS large - use node red to control my heater though one of the relays in a Cerbo GX + starting the multiplus if SOC is lov.

Running 2.80 - 23. Everything works but the console of the Cerbo is incredibly slow after Large have been installed.

Is that to be expected?

Question two: Can you access the Cerbo through SSH or similar to clean the data disk or free up space if needed ?

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

There is also the issue with BLE discovery and WiFi running at the same time on Cerbo.

BLE discovery was added for the Ruuvi sensors and it slows WiFi significantly. I resorted to a separate WiFi dongle and not using the internal WiFi. If you don't need the BLE discovery, it can be turned off to restore WiFi to previous levels.

Haven't tested this with wifi (off here), but probably the case.

I currently have 7 Ruuvi sensors in my boat. The response from Remote console is the same as without BLE sensors. Sometimes a bit lagging and then quick again.

It's only WiFi that slows. Wired ethernet isn't affected.
Stefanie avatar image
Stefanie answered ·

Hi @Ulrikmailand,

it can be a little slow at times. It depends on what you're running (Signal K + Node-RED, plugins, number of flows etc.). Only run those services you really need. Delete Signal K plugins you don't need. Delete Node-RED flows you don't need.

Another thing to look at is available disk space. See also: https://www.victronenergy.com/live/ccgx:root_access#partitions_read-only_rootfs_and_available_disk_space

Yes, you can access the Cerbo GX via SSH. See the same link I posted above (Access Level Superuser, root password, enable sshd), login).


2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks fro your reply. Only running 2 flows in node red and Signal K is disabled.


would i be better of running 2.72 than the 2.80-23 version?

I would always run latest version for the sake of new features and less bugs.
mianfrar avatar image
mianfrar answered ·

Hello

I have installed the driver for bms in a cerbo with bmv and apparently there is an error even if it is solved from version 2.73 https://community.victronenergy.com/comments/124430/view.html so I have installed the version 2.73, I would like to install the large version and I see that there is a version based on 2.72, is it perfectly functional or better I wait for this problem to be solved with the bms?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

erichabg avatar image
erichabg answered ·

Hello,
Is here the best place to report problems with the Venus-OS-large?
(I know no official support available, but I think that appropriate feedback is desired from the developers?)

If yes here my config and the problem I found.

Cerbo GX FW v2.82-large-30
Multiplus 24/3000/70-16 Typ:2612 FW 494 (I not II !)
BMV-700 Typ: 0x203 FW v3.11
SmartSolar Charger MPPT 250/60 Typ: 0xA068 FW v1.59
BlueSolar Charger MPPT 75/15 FW v1.59 HQ152982IUA

Since I control my entire smarthome using Node-red, I now want to do the same with Victron products. Therefore I use the victronenergy/node-red-contrib-victron V1.4.17 on the Cerbo.

Problem A: I can control Venus Relay 2 of the Cerbo with the Victron-Node but not Venus Relay 1.
There is no error message within nodered but no state change of the Relay and the register.
But I can control both relays with direct modbus access - node via Unit ID 100 and Register 806/807.
So I would expect that Relay 1 works even within nodered as with Relay 2.
Also the relay of the BMV and also the MPPT 250 cannot be controled (neither with node-red nor with modbus).
In the Spec I see that this register is not writable, but then why is it offered to be switched in the node?

Problem B:
Although the MPPT 75/15 has worked standalone for years without any problems, it has now gone defective after a short time after it was connected to the Cerbo. Possibly in the eye light in which I had activated DVCC. It has lost his calibration data. No idea if this was a coincidence or not?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, I`m not a pro regarding NodeRed, but have you checked that relay 2 is in manual mode? I think that they need to be that if you use NodeRed.
7552joel avatar image
7552joel answered ·

Is anyone else having issues with v2.82-large-30 running on cerbo with node-red server disconnecting constantly?

When trying to deploy im getting failed to connect to server often. Its as if the service isnt running all the time.

Furthermore through VRM im getting this message every time when trying to get to node-red instance:

Error: remote installation does not seem to have a running Node Red service.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

vassilis-bourdakis avatar image
vassilis-bourdakis answered ·

quick Q to @mvader (Victron Energy) ,

are we to expect a new version of Large soon?

I'm on 2.80~33-large-24, boating season is about to start, so want to plan an upgrade. So do I go 2.82 now or wait for a week or two and go 2.85 :-)


cheers

V.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I think these are good news: https://community.victronenergy.com/questions/133592/venus-os-v2903-available-for-testing.html

Add Venus OS Large to the standard build... Having this in the standard build is rather good news. It
(a) removes the need for the large images to now and then be built manually. And
(b) you can now, once v2.90~3 is installed, in the menu, select the large image and update to that, see Settings -> Firmware -> Online updates -> Image type (normal vs large). And
(c) Venus OS Large can now be updated using the Online update system. However: there seems to be a bug in (b). More news about that later.

jbakuwel avatar image
jbakuwel answered ·

Hi @MattSmith

That looks great. I'm doing something similar here and adding in solar forecast was on my todo list. Thanks for putting me onto Solcast that sounds like just what I need. Having an example would give me a headstart; would you mind sharing a bit of tech info here how to use the Solcast API with NodeRed (I presume)?

cheers,
Jan

10 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Jan, I've never tried to share via the node-red website so I hope this works ok. Please let me know how you go. This will give you the download flow and the dashboard. Don't forget to change the solcast URL and token. https://flows.nodered.org/user/dtswk

Hello Matt,

Very kind of you and much appreciated! In reading your code, may I ask what payload you mean to feed in to the graph chart part in the second smaller flow? Where does it go in the bigger flow?

The larger flow sets up a bunch of global variables that feed the graph, but you can also use those to trigger other events. For example I am using the Victron nodes to see the state of the current system and if the battery is higher than 50% and the mppt power is more than 5000w and the forecast is great than 20KW then I turn on the hot water system. :-)
Thanks Matt,

Yes, I am also already up and running with a (less sophisticated but working) similar flow ;) I have been unable to get a chart going though so was just asking about what to feed into that. Many thanks.

Hi Matt,


Many thanks - that works a charm! Looking forward to have some fun time with this :-)


Jan



Hi Matt,

This is a great resource. Many thanks for sharing.

Thanks, Matt,

I got this working with my extremely limited knowledge of Node-RED.

@MattSmith

Could you please clarify what the 12hour forecast is in the context of your dashboard?

Forecast 120522.JPG

forecast-120522.jpg (38.2 KiB)
It's the current day.


Matt

Ah! so it may not be reflected on the graph if the screenshot (like mine) is taken in the evening. Very Good. Thank you.
jsrivet avatar image
jsrivet answered ·

Why permissions change after reboot. I am using 2.90-large-8 and I need to modify the USB port permissions for communication with node-red in the /dev file. but each restart the permissions revert to the beginning. I didn't need to modify the permissions before with 2.82-Large-30 but with the update Node-red says I don't have the permissions that's why I have to modify the permissions of my usb port in the /dev file.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.