question

wildebus avatar image

Multiplus doesn't see Cerbo GX Temp Sensor

I have a Multiplus (Easyplus) 12/1600 along with a Cerbo GX and other stuff.

Because I want to use the BMS Assistant on the MP, I had to use the Temperature Sensor input for the control signal (the MP 12/1600 has no other Aux input). This works well and I can control the Charging feature exactly as I want with this assistant.

I was fine with doing that as I could use a Temp Sensor that was connected to the Cerbo GX instead and enable DVCC and the STS feature. That seems to work fine for the SmartSolar MPPT and that picks up the temperature from the sensor correctly, but the MP shows the temp reading as either "NaN C" or "20 C".
I have two temp sensors on the GX and I have tried setting the Sensor in the STS selection to either one of them and it makes no difference to the MP - although the MPPT sees the change (and neither are 20 C either).

Any ideas why the MP is not picking up the Temp Sensor data from the Cerbo GX?

Multiplus-IIcerbo gxDVCC
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Mark avatar image
Mark answered ·

I agree that something seems off here with DVCC-STS and the MultiPlus - could you please confirm what FW revision your running in the MultiPlus?

Also try to reboot the Cerbo in case you haven't already after making the recent DVCC and temperature sensor changes.

On the other topic of the 2 wire BMS assistant, I can confirm that even if you have no Lithium battery settings programmed, as soon as you load that assistant it automatically disables temperature compensation (despite it being set) and forces absorption stage length in the background. Unfortunatly this behaviour is not documented and it generally makes that assistant unsuitable to use as a means to manually enable/disable the MultiPlus inverter or charger with non-Lithium batteries.

6 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.




Firmware is 430. This MP came directly from Victron Netherlands less than a month go so I assumed (bad I know!) that it was up to date and didn't check for any updates.
Rebooting makes no difference.

Interesting comment on when you load that assistant it disables Temp Compensation. If that is the case, then it all makes sense.... MP fixes the temp at 20C with no varience which will in effect disable the compensation even though it might be programmatically still in place. (I have not seen that settable in VE.Configure though, so have assumed there was a default value in place for non -Lithium batteries)

However ... I removed the assistant in VE.Configure, uploaded the new file, reset the MP and I still don't see a temperature showing (apart from the 20C mentioned), so I have my doubts if the Multiplus actually supports DVCC Temperature Data IN, but just OUT (on my MP 12/3000 setup, I was using the MP Temp Sensor to send to a 100/30 MPPT no problem via DVCC).

It is rather disappointing that there is no simple way to just enable/set Passthru in the same way that you can have the other functions (On, Off, Charger Only, Inverter Only).
I suppose I will have to reconnect the Temp Sensor to the MP directly as I don't see any other way to have the battery temp known by the Multiplus, but this is something I think needs to be fixed by Victron.



Since you have a MK3 to USB interface I recommend to update the MultiPlus FW to the latest release (currently FW v476 is the latest) as a first step if you are comfortable to do it yourself, otherwise contact your dealer. FW v430 is quite old now and from before STS was able to provide temperature data from the Venus device (although I didn't think the MultiPlus FW changed for this, it may have).

There was also a fix in Venus FW V2.60 for this very issue (see the change log on Victron Professional), I assume that you are already running V2.60 in the Cerbo?

I should have realised the firmware would have an update. I dont think I have ever powered up a Bluetooth enabled Victron product that hasn't prompted for an update immediately!

I just put the sensor back on the MP input and immediately I can share the MP temp with the MPPT via DVCC.

I'll do the update to the firmware (soon as I remember where I put the MK3 Dongle!) and see what happens. if 430 predated the STS working I can imagine that being a likely reason and the latest firmware should either fix that (or Victron need to add the fix - one or other).

I'll report back with the results - success or otherwise!

Cheers.

Hi Wildebus,

To clarify:

DVCC-STS was first introduced in Multi/Quattro FW v4.19 and Venus FW v2.20 (Oct 2018), but at that time it was only possible to use a battery monitor (BMV) as the data source for battery temperature.

Then in Venus FW v2.40 (Dec 2019) DVCC - STS functionality was expanded with the option of using any battery temperature sensor as the date source, such as a Multi/Quattro, compatible Venus device (Venus GX & now also Cerbo GX) or a compatible solar charger (that has a hard wired battery temperature sensor).

Finally in Venus FW v2.60 (Sep 2020) there was an update/bug fix related to DVCC - STS not always being used by Multi/Quatto units (which sounds like your issue, but I'm guessing that you are already running Venus FW v2.60? You did not confirm this yet...)

I am not aware of a further (after FW v4.19) Multi/Quattro FW update specifically in relation to DVCC - STS, but if there is an issue it's always best practice to ensure all devices are running the most recent FW as a first step.

Hi Mark.

I have been unsuccessful in finding my MK3 Dongle (very annoying!) so cannot upgrade MP Firmware.

I checked the Cerbo GX Firmware. It was actually on 2.58 with 2.60 ready to update (I tend to set to 'check only' usually rather than auto-update). Applied the update and progress made!

Initially changing the STS device from the MP Sensor to a sensor on the Cerbo made no difference to the Batt Temp reported by the MP, but as soon as I disconnected the MP Sensor, it switched to the STS Sensor.

So the key step of having the STS info shared between all devices is now working.

I had removed the BMS Assistant in VE.Configure, so I just added that back in and uploaded the file back. The Battery Temp shown in VRM for the MP Device is still the STS value, and hasn't reverted back to the "20 C" fixed value it showed before.

So looks like my initial issue has been resolved with your excellent advice :)


There is still the new issue which I was not aware of until you told me about it ... the BMS Assistant removing the Temp Compensation Voltage adjustment. I will try and check if that is present or not by messing around with the temp on a sensor and seeing how/if the voltage changes. I can't see that having changed from what you have told me, but may as well confirm while troubleshooting this.

I had a look at the various assistants available and could not find any packaged ones that would disable the charger feature and enable Passthru mode. Are there 3rd party/ user assistants available generally? I wonder if someone has written one to do this?

I did a quick check regarding if there is any temp compensation with the 2-signal BMS Assistant loaded and it does look like there is in fact.

I have two temp sensors on the Cerbo GX and I stuck one of them in front of a heat gun (used for heat shrinking, but that's by the bye) to give a good differential between the two, and then switched the STS setting in the Control Panel between the two and looked at the DC Voltage output of the Multiplus.


EDIT: Will repeat this test (high temp sensor may have gone to a point where the MP is trigged to turn off charge)

wildebus avatar image
wildebus answered ·

No ideas about why this is not working as it should?


Below is a bit of a combo screenshot showing:

The VRM data for MP (ID #276) (at this moment, the MP (#276) is showing 20C rather than the alternative "NaN C");
The selected temp input on input 4 on the Cerbo GX (ID #27);
A shot of the Control Panel showing what is selected and enabled within DVCC;
The settings for the MPPT via Victron Connect, showing the temperature of 13C, confirming it is picking up the Temp Sensor through the DVCC service ok and so that aspect is setup ok.

ep1600-tempissue.png



ep1600-tempissue.png (230.0 KiB)
2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Wildebus,

The 20°C in the VE.Bus Summary seems to show MultiPlus internal temperature. Mislabeled I think. It's the same for me.

Thanks for reply.

I am not sure if that 20C is actually anything - I am saying this as that value, unless it is "NaN C" is ALWAYS 20C - it never varies even by a degree. The MP temp must change when the charger is in use, or the inverter is running, but this number displayed never changes.

(it used to when I initially installed it before I repurposed the "Temp Sensor" input for the BMA Assistant). This is a new install, BTW. Less than a week old.

Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

What batteries do you have?

The MultiPlus (and the MPPT) only needs the temperature to make the temperature compensation during charging, but with lithium batteries you shouldn't use temperature compensation.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You may not need to use Temp Compensation with Lithium, but you do need to stop the charger below around 5C (just a note to accompany the comment about Lithium).

Anyway, that is a digression - I actually have Lead-Carbon batteries (these specific batteries recommend compensation of -4mV/C/Cell) so I do really want to have the Multiplus know the battery temp.

I am using the BMS Assistant not because I have Lithium, but I want to be able to turn the Charger off and have it work in Passthru mode sometimes (for my own reasons).

It doesn't change the point and problem that the Multiplus is not seeing the Temperature Sensor correctly - unless you are thinking the BMS Assistant disables the Temp Sensor function?


Update: That last point made me wonder if within the programming there was an assumption that if using the BMS Assistant you must be using Lithium - and so a Battery Temp reading was unimportant so not brought in? So I just ran VE.Configure, removed the Assistant and reloaded ... no difference. Still no Temp Data (or rather either no temp, or 20 C again)