question

Rudi Marais avatar image

VRM dashboard schematic visualisation

The new look VRM dashboards is great and the schematic visualisation with connected lines and "moving ants" saves me the effort of having to select "Remote Console" on my Android and then turning it into landscape view to have a quick overview of my system's overall performance. Well done Victron!

This worked well until about a day or 2 ago. I can no longer see the schematic visualisation which shows the connected lines and "walking ants". Also, I am no longer able to view my data in real time with the update every 2 seconds.

The VRM manual states the following:

1.4.1 Schematic visualisation

The information shown adapts itself to the system installed. For systems without an inverter/charger, separate blocks of information are shown, without connected lines and 'moving ants'

My dashboatd now ony displays the separate blocks of infotlrmation instead, even though my system contains an inverter. It used to display the schematic visualisation until a day or 2 ago. My system did not change in the meantime.

Are there any settings to correct this? The problem exists on both my Android phone as well as PC internet browser (Google Chrome) dashboards.

My dashboard currently looks like this:

I really hope that someone can assist me so that I can again enjoy the new VRM dashboard.

Thank you in advance.

Rudi

VRMdashboard display
1601732378070.png (275.2 KiB)
1601732525184.png (109.2 KiB)
1601764120121.png (114.2 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
machined avatar image
machined answered ·

I imagine that was a coding error that was fixed because mine has been showing the correct time since it updated and it's never said realtime. I was having an issue with it updating but I went into Settings, VRM Online Portal, set the Log In Interval to 1 minute. That will have it update every minute to the panel. I also recommend turning No Contact Reset Delay to 00:05. This will help if you have a wifi issue then the Cerbo will reset and reconnect. This has cured my updating issues. Still no realtime though. I have VRM two way communication on but that doesn't seem to affect it.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thank you for taking the time to comment @machined .

Your comments regarding the realtime being a possible coding error is not correct. The realtime updating on the dashboard operates totally independent of the data logging interval which you mentioned under settings.

Suggest you view detail of this new VRM portal feature (I have added the URL for you) which explains the newly added feature. It states: "The dashboard can show real time data, meaning that every two seconds data updates are sent straight from the installation to your browser - rather than pulled from the database at which the information is stored at the interval configured in Settings → VRM Portal → Interval (default 15 minutes). "

https://www.victronenergy.com/live/vrm_portal:dashboard

Anyway, my problem seems to have taken care of itself. Shortly after my post, it returned to the way it used to operate by displaying the system's schematic visualization. The only change I made was to update the CCGX firmware, but I doubt whether that was actually the cause of my issue. Just wish I could know who / what made the correction. :-(

1601804532030.png (87.6 KiB)
Teun Lassche avatar image
Teun Lassche answered ·

It looks like in your case there was no two way communication available, either by a problem in your network or because two way communication was turned off. It also might well be the case that updating the CCGX firmware did the trick in this case.


In general the realtime schematic works if:


- The firmware version is recent (2.60)

- Two way communication is turned on.

- The internet connection is stable


It's all documented in section 2.3 over here: https://www.victronenergy.com/live/vrm_portal:dashboard

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hello @Teun Lassche,


Many thanks for your reply. My 2-way communication was definitely on and there was an internet feed, otherwise I would surely not have been able to access the CCGX display via my android device. The CCGX firmware was v2.58 before the update and the schematic visualization used to work with this version, but then stopped. Any way, apart from the CCGX firmware update, I made no other changes from my end and the visualization then started to work again, so I guess the mystery took care of itself, which is what I am grateful about! :-)

At least some good came from this issue and the CCGX firmware update. I now have a more representative icon display for the MPPT on my CCGX remote console. The previous icon which displayed the MPPT looked different to my MPPTs. Something very small, but its always nice to have things sorted 100%

Many thanks for your support and reply!

Regards

Rudi

Updated icon on CCGX display


Previous icon for MPPT:

1601963045219.png (27.0 KiB)
1601962881299.png (50.2 KiB)
captkeebz avatar image
captkeebz answered ·

I've got the same display problem with boat system/venus gx. Diagram disappeared after working fine for years. Both laptop and mobile (android). Two-way is enabled running venus firmware 2.73 (current). I've deleted the browser caches and no good. :(

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I rebooted the Venus via the console and it's back, baybeee! Simple fix. Might be useful to others. Great stuff Victron team! Keep up the good work.
jibap avatar image
jibap answered ·

Same issue for me. Reboot didn't fix but i did :

  • disabled the two-way option
  • re-enabled the two-way option

and it worked !

EDIT : the issue is back... few minutes later : a refresh of the page fix this issue, but it is not persistent...

capture-decran-2022-02-26-114422.jpg


Victron team, Any idea ?


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.