question

Daniel avatar image
Daniel asked

Kernel Panic, System Restored, Still no data alarm

Hello,


this morning I looked at my VRM to see the status of my island system. But: since 4 a.m. I have no data Alarm. I am using a Raspberry Pi2 with firmware 2.60~34. I then walked up to my pi to see that only the red power LED is lighting up. No Power on USB and no Ethernet.


I then decided to connect a screen to my pi. It gives a kernel panic. After seeing that, I made a backup of its SD Card (just in case I need some files).


Downloaded a fresh version of VenusOS, put it on the SD card and Copied over the Settings (I believe) and the Pi started fine. All settings are back but still "No Data" alert.


if I go into the VRM settings in the Remote Console over LAN it says:

Last connection: ---

Error: Unknown


VRM Portal ID is the same as on the Website.


hope someone can help


VRMVenus OSRaspberry Pi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Daniel avatar image
Daniel answered ·


here are Pictures. Somehow i got a servererror when Upload with the Post


vrm1.png (29.2 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

teejmiller avatar image
teejmiller answered ·

When I recently restored a backup. I had to go into VRM and go into that "installation" then Settings, General and where it listed the VRM ID, I had to explicitly give permission for the new installation to connect using the existing VRM ID. I hope it is this simple for you!

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

When in vrm I can only delete, unlink and replace with another vrm id.

0 Likes 0 ·
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

I recommend to do a fresh install on that pi without copying the settings over. Just a normal plain fresh install; and then see what happens.

Once the Pi says that it is uploading properly again, you'll have to reset the authorisation token, as also indicated by @teejmiller.

The manual to troubleshoot vrm connectivity is this chapter in the CCGX manual: https://www.victronenergy.com/live/ccgx:start#trouble_shooting_data_logging .


But as said, start with a fresh install and then don't copy settings over.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

So I downloaded a new version of VenusOS and Flashed it on the SD card. Starting up all settings are gone. Interestingly the fresh install got the same VRM id and VRM said there is a VRM installation that sends invalid data. I then could reset for permissions.

Things I don't understand right now is, why did the fresh install get the same vrm id? I expected it to get a new id and I have to add the new installation and then replace the old.

0 Likes 0 ·

the vrm portal id is tied to your rpi hardware. Its the mac address of the ethernet interface.



0 Likes 0 ·