question

janjaap avatar image
janjaap asked

hard (without app) factory reset MPPT 75/15 smart solor charger

Hi,

I purchaged a MPPT 75/15 smartsolar charger (replacement of a 14 years old PWS charger) for a original 50 Watts panel (also 14 years ago), just to boost a bit of the efficiency compensating for the panels age and charger technology.

Hardware version V01.

Many connectivity issues using bluetooth from Android 10 and MacOS (seemed impossible to get connected from the android 10 device - followed all instructions related to the bluetooth specifics as per victron).

Finally using MacOS I managed to get connected. And once I have got a charging display with voltage and power (values as expected). Second time I started the app on the Mac, it forced me to update the firmware, no way around. I hit the update button and from then onwards all misery (note less than one meter away from the charger all the time).

Somehow the update failed and now it gives me firmware version: none -> please update to 1.46

Green and yellow led flashing rapidly.

There is no longer any way to connect (unpowered for 30 min as well, multiple times).


Also error D26 comes in the app (MacOs):

Updating failed, communication lost. The product might be unusable. Check connection and power supply.
Try again and check the product settings once updated.


Again, all bluetooth reset / reconnect as per Victron have been followed.


So obviously the firmware is corrupt and I'm now looking for a *hardware* reset option which I asume would load the original firmware and resets all.

Any software / app option is not what I'm looking for.

Where is it?

Thx, Jan Jaap

firmware updateBluetooth
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
yannick avatar image
yannick answered ·

There is no option to 'hardware reset' when the firmware is corrupted. One wat or another you have to flash New firmware. Either over bluetooth OR via the ve.direct to USB interface.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

janjaap avatar image
janjaap answered ·

@Yannick Thats what I was already thinking - I believe this is a technical design mistake not to include something like that.

However, I do have a trick to make a basic bluetooth connection work, at that point it always fails to flash the firmware. One thing I can still try is flashing with a firmware file - but I can nowhere find a firmware flash file. Elsewhere its stated to be included in the app (MacOs - via MacOs Appstore) - however, that does not seem to be the case. So before I return it to Kniest (which is located in Almere/NL, same city as Victron itself ;) ) - can someone provide me with the firmware file itself (hardware version V01) - Please

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hello @JanJaap You can find the files here.

https://professional.victronenergy.com/downloads/firmware/

A quick simple registration is all that is required. Current firmware version is 1.49

https://professional.victronenergy.com/downloads/firmware/file-download/?name=MPPTs-Smart-andBlueSolarwithonlyVE.Direct/SolarChargeControllerMPPT75-15SMARTv1.49_A053.dup

Typically the devices don't "brick" and just dont apply the update and has to re-done.

0 Likes 0 ·

@ejrossouw Well - tried to update the firmware with a firmware file (1.49) - same result - so I have to return the controller to Kniest - no other option - unless someone has a great idea.

0 Likes 0 ·
What is the current version now?


I suspect this may be issue with mine... it did a firmware update last week, and then stopped letting me connect via the app, and the yellow/green light are now flashing :(

0 Likes 0 ·