question

Oxy- avatar image

VictronConnect 5.11 doesn't work on Mac OS 10.11 anymore

Hello,

I have been using VictronConnect 5.08 (if I recall the number right) just fine on my old MacBook Pro. Today I went to App Store, saw there's an update, installed it and VictronConnect doesn't start anymore. App Store didn't give a warning that my Mac OS is too old.

After troubleshooting I found this exact error:

$ ./VictronConnect
Sorry, "VictronConnect" cannot be run on this version of macOS. Qt requires macOS 10.12.0 or later, you have macOS 10.11.6.

This is unexpected and bad, because though an old MacBook Pro laptop, it's used "in the field" just fine. Mac OS 10.12 cannot be installed on it due to Apple's constrained "logic" of throwing away old but good computers.

It looks like you have increased the used Qt version somewhere from 5.08 to 5.11. Maybe it was an accident and you could revert the previous version back for the users with older laptops?

Thank you.

VictronConnect
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
jperez (Victron Energy Staff) avatar image

Thanks for reporting this @Oxy-

In the VictronConnect version just released v5.12/v5.13, we also fixed the Apple macOS store issue: now the users with an older macOS version will be able again to install the older VictronConnect version (v5.8) that is compatible.


Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image

Hi, indeed, we updated the Qt framework. From 5.9 to 5.13. Which increases the minimum macOS version, but we completely overlooked that it does. We did spot the similar change in minimum version for Android and iOS, but not macOS.

We're working to make the last VictronConnect version that *does* work available for download, I'll report back here once available.

Also we'll work on changing how its listed in the Apple Store (increase minimum macOS version).

It won't be possible for us to make VictronConnect work on older versions of macOS. 10.12.0 is the minimum, there is nothing we can do about that. Its frustrating for too, 10.12.0 being only four years old.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Oxy- avatar image

In the mean time, I’ll see if I can force push Mac OS High Sierra (which I assume will be enough) to my old laptop by using this hack:

http://dosdude1.com/highsierra/

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Daniël Boekel (Victron Energy Staff) avatar image

Thanks for bringing this up, it's been communicated to the developers, and hopefully can be fixed soon.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

misullivan avatar image

I also alerted in a previous post something similar it’s the dependency on the QT libraries. It should have not let you update but the people who wrote the appp did not update the AppStore to say it’s not compatible with 10.11 anymore (still says 10.10 min version).. I’m hoping they’ll fix the app rather than change the setting as I toodont believe in throwing away perfectly good computers.. especially as we’re trying to be “green” here...!

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.