question

hour avatar image

SmartSolar quirks in iOS app & VictronConnect

Maybe something for developers to look at...

I'm testing a new LFP battery build and getting the BMV and SmartSolar configured.

  • I noticed the temperature reading on the SmartSolar on iOS app disappearing every few seconds and reappearing just as quick. This was obvious because the rows kept shifting as one was removed, then re-added.

  • I confirmed 100x over that both the BMV and SmartSolar were on the same network, the only network, and that battery voltage and temperature data was being transmitted from the BMV and received by the SmartSolar. I set the absorption voltage to 13.79.

  • BMV hit 13.79 and SmartSolar kept going in bulk. Several moments later BMV was showing 14.05v, confirmed by a hobby charger cell meter I have connected. Yet still the SmartSolar kept going. It kept going until IT read 13.8v, which defeats the purpose of receiving voltage information over the smart network. This could wreck someone's setup!

Last, I just left the network and deleted it so I could set it up again, not knowing what else to try.

Created a network from the SmartSolar which said it was waiting to have a BMV or SmartSense connected to the network. Okay, fine. Went to network settings on the BMV and only had the option to create a new one. Restarted both mac app and iOS app several times before the BMV finally gave me the option to join existing.

These units are located less than a foot apart, not enclosed in anything. Something is screwy, and the biggest issue is the inability to trust the SmartSolar to quit charging when it reaches the voltage provided by the BMV. Hell, if there's an issue with the data transmitted over the network then I can't rely on the temperature control of the BMV either and will wreck my battery in a couple weeks when we start dipping below freezing.

Confirmed SmartSolar is not doing anything with BMV voltage readings over the network, that it says it's receiving. With float set to 13.45, it re-enters bulk (which should happen at 13.35 per my settings) when the BMV is showing 13.45v still. It's basing this off of its own reading, not the provided value.


MPPT - Solar Charge ControllerBMV Battery MonitorVictronConnect
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Leslieanne avatar image

I am seeing a similar situation with a 100/20 smartsolar mppt, networked with a BMV 700 but sending voltage only. When the mppt reports changing to absorption ( set to 14.2 V ), and with about 18 amps flowing, the mppt indeed shows 14.2 V in Victron connect android app. But the BMV reports about 14.4 V. Initially I was concerned for my lithium battery, but of course this is not possible. Voltage at mppt output must always be above battery voltage if significant current flows.

Indeed, when I measured the voltage at mppt output it was 14.4. I did not measure at battery ( hard to reach ), but am confident it would have been around the correct 14.2 V or even less, having previously measured about a 0.4 voltage drop between a charger and the battery with 25 amps flowing over similar wiring. So all was working as it should, but the reporting of voltages in the app seemed to be "swapped around". The mppt was correctly showing battery voltage ( as it should when networked ), but the BMV seemed to be reporting the voltage at the mppt, rather than the battery voltage. Software bug????

When I removed the mppt from the network, the current dropped a bit, mppt continued to report 14.2, and BMV reported around 14 V....all as expected and the very reason one networks these things - to avoid switching to absorption too early.

These measurements were done on the app from in the car, and in a hurry at side of road, mppt and battery are in the caravan. I intended to check and measure things properly when we returned home before reporting here, but then saw this post.....

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sorry, forgot to mention all latest firmware. Never noticed this before the recent major update.

Hmm. I just started charging up at 15 amps / 206 watts again from a 35% discharged battery. Been running for two minutes or so and hit things with the digital multimeter

  • BMV shows 13.65v
  • Hobby charger shows sum of four cells at 13.64-13.66
  • Battery measured at terminals w/ DMM shows 13.65
  • Measured w/ DMM from any (+) in the system (sans smartsolar) to the shunt, either end, shows 13.65
  • SmartSolar output terminals show 13.88 w/ DMM
  • SmartSolar display shows 13.49

What on earth is it doing

It's like I'm damned if I do, damned if I don't. I just removed it from the Smart Network and it shot up to over 13.8v on its own reading and terminated charge, prematurely I might add. The reason we buy these things...

With it on the network, it overcharges the battery. POS

klim8skeptic avatar image

The preferred way to set up a network. Set up network form the SBS/BMV, then get the Mppt to join that network.

You don't mention what firmware the mppt/bt or bmv/bt are running.

5 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I omitted that part, but I had initially tried to create the network from the BMV, but the SmartSolar wouldn't reveal the option to join existing. So I deleted the BMV network and created from SmartSolar, then the BMV wouldn't reveal the option to join existing. After a few minutes and multiple force quit -> re-open app, coincidence or not, it was there. I will recreate from the BMV and wait a few minutes before trying to join from the SmartSolar if that's preferred.

Worth mentioning, what prompted this entire new network creation, was that the network values clearly weren't being received or respected by the SmartSolar, and that was the original network I've had for 6 months - created on the BMV.

Still seeing temperature row disappear on SmartSolar interface, usually in rapid succession and then good for a bit.

Have replicated the re-enter bulk setting ignoring BMV and going on SmartSolar voltage a few times now - and it's still charging up to over 14v according to BMV and cell monitor staying in Bulk when absorption is now set to 13.7

Latest - with 5.11 Victron connect

1.42

2.19

bl v1.10

&

4.0.1

2.19

bl v1.10

All screenshots taken in the same 10 second window

BMV voltage is confirmed (and extremely accurate) with a iCharger monitoring the four cell voltages.

All connections tight, minimal connections on any connection for testing phase. 10ga pure copper, well crimped lugs from smartsolar (B-) to BMV shunt on load side, and smartsolar (B+) to battery (+)

In the photo below you can see that the SmartSolar is showing its own reading of 13.79V. Temperature is displayed (and is always accurate to the BMV when row isn't flickering. Hasn't for the last hour). The SmartNetwork icon is visible, and I've left / joined / recreated / reset factory defaults a dozen times - that's not it. And yes the BMV is now hosting the network.


13.79, not bad ey? Yeah that's near what I have it set to now, for more and more testing, in the SmartSolar settings...


Kidding, it is bad. Because this is what the BMV is showing, and confirmed by cell monitor (and DMMs at terminals). The SmartSolar is just ignoring the transmitted data, or it's never truly receiving it. Just receiving temperature I guess?


I will record a video tomorrow. This has never worked right, on the outgoing pack this new one is replacing (scavenged Victron gear off of it) I always had to set my absorption lower because it really never listened to the BMV as far as I could tell. That involved guess work, playing it safe, and a lot of time spent pretty much calibrating it to my max charge current on the sunniest of days. If I ever had any doubt in my wiring, that's all new for this pack and the max allowed from for 75/15 - and a whopping 18 inches between BMV, SmartSolar, and battery during this testing. So impossibly short runs. Everything is pure copper, no CCA. All connections to everything that isn't a screw terminal (er.. the SmartSolar) is wildly oversized.

I ordered a Smart Battery Sense and will remove the BMV from the network. If it's not working properly then, I will try to get the SmartSolar warrantied. None of this stuff is more than 6 months old.


A couple of thing of note.

An SBS might not help at all. But if you must, get a blue one.

The sceenshots from the bmv show your batt is still accepting 14a, and the mppt is still in the bulk phase. Sort your bmv and battery out first. (at 13.79/13.97 a Li battery still accepting 14a is probably not fully charged, esp from a 15a charger)

Sure, I can run it at 30 amps even (via iCharger hobby charger - not 75/15) for a while longer. But I don't want to. 13.8 is my charged voltage for longevity and to better avoid overcharging given that this is will be charged by a solar array with a lot of variables.

The second the SmartSolar senses a valid 13.8 from the BMV or any other source, it needs to stop charging. That's full for me, the cells are happy and balanced, and I can pull more power than I'd ever need out of it from a 3.45Vpc charged 4S pack.

You just nailed it though, the MPPT is still in the bulk phase. It doesn't care any about the voltage it's receiving over the smart network from the BMV. If it's doing some sort of calculations between its own reading and the BMV it sure could have fooled me. Everything that it's doing is based off its own voltage while two other sources show the battery is going to places I don't want it to be. That renders the product useless.