question

shiva33 avatar image

Multiplus 5000/48 does not start VE.Bus error 4

Hello community,

funny error here.

Short description of the situation:

48V, 12kWh Aquion saltwater battery bank connected to a BlueSolar MPPT 150/100 and a MultiPlus 5000/48. That is our secondary pv system for rainy days.

The primary system is a 48V led-acid battery bank with 22kWh (charger is a Morningstar MPPT 60 and as inverters two 3500W QMAX pure sinus charger inverters in parallel).

I am trying since quite some month to get the secondary system with the Victron Energy parts to work. The charger does well, but the MultiPlus inverter is just not wanting to switch on.

As soon as I flip the ON switch, all LEDs shortly lighten up, then inverter and absorption/float blink alternating. For a tryout I left it blinking for almost an hour, no change. I made a short clip of the startup error:

According to the manual, that is a Ve.Bus Error Code 4. Which can be ignored when a system is being restarted or it means there is a communication error with the other devices.

Now there are no other devices. The inverter was bought new, so should be in stand alone mode. In case not, I used the DIP switches to reset it to factory settings. Programming with the DIP switches works, the LEDs confirm the procedure. Though, the inverter still does not start.

What I‘ve done/tried so far:

- disconnect all cables, but DC in and even remove all but one fuse and use different DC cabling (like you see in the video)

- connect the inverter to the primary led-acid battery bank (same error)

- resetting the inverter to factory settings with the DIP switches (no luck, but programing worked)

- tried to connect the MK3-USB adapter, but the device is not found (the MK3 adapter is working very good on the other MultiPlus inverters I have in use)

- tried another inverter on the saltwater batteries: works, no problem

I am living in Uruguay, South America. The device was bought in Germany and shipped in a container. Not an easy warranty situation.

Anybody a good idea what I could try next?

Do I overlook something?

Can one read out the device another way than with the VE.config software?

Regards,

Shiva

MultiPlus Quattro Inverter ChargerVE.Buserror codes
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Daniël Boekel (Victron Energy Staff) avatar image

Hi @shiva33

I'd start with updating the firmware to latest version, this also resets all settings.
Reading out can also be done with a GX device (like the Venus GX), I assume you have a GX device for communication between battery and inverter?

https://docs.victronenergy.com/victronconnect-vebus.html#procedure


Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

shiva33 avatar image

Hi @Daniël Boekel (Victron Energy Staff),

thank you for your reply.

At this point I do not have a GX device.
Though one of the next weeks hopefully a Raspberry Pi 3 b+ will arrive on which I plan to install Venus OS.

Does the MultiPlus connect to a GX device if it doesn't respond to a MK3-USB?
And if so, would the Raspberry Pi running under Venus OS be able to connect without the MK3-USB to the MultiPlus?

3 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I cannot help you on the RasPi, but you could ask here:

https://community.victronenergy.com/spaces/31/index.html

Remember that you need both an MK3-usb to connect to the inverter and a CANbus adapter to connect to the battery.

I'd use a Venus as this might not be much more expensive and it's a proven and complete package.
on connecting to the MK3-usb, have you tried while supplying AC input?

shiva33 avatar image shiva33 Daniël Boekel (Victron Energy Staff) ♦♦ ·

Yahoo! It worked!

Studying your first reply I downloaded the VictronConnect App.
Then connecting the MultiPlus to the MK3-USB and to the laptop. At first it was not recognized with the message "Can not connect to the device. Click for more information". On the next page was an option to force recognition which sucesfully found the right model and offered the option to Upgrade the firmware.
After the upgrade the MultiPlus switched to "Inverter on" and boom, that's it!

All good, it worked. After months and months, finally.

Solution was to use the MK3-USB connector with the VictronConnect app to upgrade the firmware!

Thanks @Daniël Boekel (Victron Energy Staff), your hints put me on the right track!

Glad to hear, thanks for the feed-back.

And please take care of your batteries, as far as I know they really have to be connected through CANbus as the charging voltage is actively being changed by the BMS as the battery charges.