question

Christian Bleeker avatar image

Power/amps not added when tystor soft 1210 charging

I have a tystor soft 1210 charger connected to a septer 1275 charging powerbank + starter battery on my boat. My engine generator also charges through the septor when running.

When my engine is running, I can monitor the power going into the battery, but not when charging from the tystor.

Also, when my battery bank is fully charged, and the tystor is active, the tystor acts as powersource (And keeps the batteries topped off), however, the BMW deducts the amps (even though voltage is maintained) from bank and SOC.

Can i fix this somehow, or just learn to live with it and manually set charge to 100% when cutting the tystor?

BMV Battery MonitorSOCcharger
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @Christian Bleeker

I think your charger is connected directly to the battery minus, and not through the BMV shunt.

connect it to the 'load/charger' side and you'll be able to see the current from the charger.

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

THANKS!!!!... That's what you get when a power-imbecile gets new toys :-)

Works like a charm now.

Great to hear, thanks for reporting back.


enjoy!