reuter avatar image
reuter asked

Multiplus 12/3000/230 not working with generator

I have 2 MultiPlus 12/3000/120 50/230. They are on different vehicles. One uses 11x50Ah gel batteries, second uses 4x110Ah flooded batteries. First one works fine 2 years, second more than year. Problems starts a mont ago. One (with gel batteries) not working on generator power. It tries several times switch to "mains", but stays on "inverting" mode. I tried 4kVA generator and 1kVA inverter-generator (charger only). I also using Digital multi control 200 and input current is limited accordingly. Works almost fine on grid power. If I connect grid power, or my 30kVA generator it switch to "mains" after 2...10 mins. I used MK3 to monitor system. I resetted several times all settings. Also upgraded firmware what I get from local seller.

Looks like some issues with synchronizing. Generator empty run voltage is 240...250V and frequency is 51...53Hz (different units) Multiplus can see input frequency and voltage, tries to keep frequency similar to input, but not switching over. Wide input voltage and frequency range are allowed. Grid frequency is 49,9...50,1 and voltage 225...235. Large generator running at 50,5...50,7Hz and 235V (no load).

second set runs fine, works fine on random generator and on grid power. Settings are same.

MultiPlus Quattro Inverter ChargerGenerator
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Martijn Coster (Victron Energy Staff) avatar image
Martijn Coster (Victron Energy Staff) answered ·

Hi @reuter

Please read this:[]=generator

best regards

Martijn Coster - Victron Energy

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

reuter avatar image reuter commented ·

I tried several things from this topic with no result. As I described both units worked fine up to May. Both vehicles have similar unit and similar installation. After resitting both units and setting up so similar way on is not working, second working fine with all generators

0 Likes 0 ·