purei avatar image
purei asked

Multiplus-II stops charging when 51V are reached

Hi everybody,

My problematic :

I've got an off grid installation. And, specially at winter, i need to charge my batteries with a generator. But, after all updates of my installation components, the converter switch to inverter only when the SOC (State Of Charge) reached 51V. Does anybody knows why ?

My installation :

Multiplus-II 48V/5000kva firmware 500

CerboGX V2.92

Lynx Busbar

MPPT SmartSolar 150/70 rev2 V3.13

4 Pylontech Batteries US2000C, V2.22 (With batteryView software)

My settings :

I followed pylontech recommendations for MP2 settings from here :

multiplus-chargertab.pngCharger tab

The cerboGX is correctly wired and configured. It have all the informations from the MPPT, the batteries and the multiplus.

Symptoms :

When the SOC is near 20/30% ans no sun to the horizon, i start the generator. MP2 switch to charger mode and the charging starts in bulk mode. Batteries voltage is near 49V at this moment. The charging is effective until the voltage reach 50V and MP2 switch to absorbtion. Charging continues and when the voltage reach near of 51V, MP2 switch to inverter mode and the charging stops. I can replug the generator, MP2 switch to bulk, then absorbtion, then inverter mode.

What i tried :

I tried to setup the AC IN conditional with :
- ACIN ON if SOC < 100%
- ACIN OFF if voltage reach 64V (It's a volunteer high value for testing)

I tried to use WEAK AC, UPS function, Dynamic Current limit, PowerAssist

I tried to reset the Cerbo and setting it from scratch

I tried to reset the MP2 and setting it from scratch

I tried to warm up batteries to 15°C/20°C to be sure that's not the problem.

The generator is perfectly functionnal

What i need :

Some new ideas :)

Does anybody knows if i can find the FULL logs of the MP2 ? Maybe i could find something in it. I don't know what for now but i can look deeper into it.

Multiplus-IIbattery chargingGeneratorPylontechSOC
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

snoobler avatar image snoobler commented ·

DVCC settings?

0 Likes 0 ·
purei avatar image purei snoobler commented ·

DVCC settingsdvcc-settings.png

0 Likes 0 ·
dvcc-settings.png (29.8 KiB)
seb71 avatar image seb71 commented ·

The charging is effective until the voltage reach 50V and MP2 switch to absorbtion.

Is this correct?

Because according to your settings, the switch from Bulk to Absorption should be when the battery voltage reaches 52V.

Are you using any Assistants in Multiplus?

0 Likes 0 ·
purei avatar image purei seb71 commented ·

Because according to your settings, the switch from Bulk to Absorption should be when the battery voltage reaches 52V.

That's exactly what i thought at the beginning. But in fact, it not seems to works like that. How could i confirm the correct functionality ?

No assistant because virtual switch is in use


0 Likes 0 ·
no-assistant.png (21.5 KiB)
nickdb avatar image nickdb ♦♦ purei commented ·

Using VRM chart out the BMS limits. Look at the CVL, CCL etc at the times you are having an issue. The BMS may be choosing not to charge.

Generally a managed battery decides what it wants and DVCC enforces the request across all chargers.

0 Likes 0 ·
Alexandra avatar image Alexandra ♦ nickdb ♦♦ commented ·

Also a picture of your virtual switch settings?

I would disable that for now and manually switch if necessary to rule out the virtual switch settings as an issue.

0 Likes 0 ·
purei avatar image purei Alexandra ♦ commented ·

vswitch-tab.pngI ll disable it for the next test and try again. I ll read the documentation for understanding the purpose of that feature.
Thanks for your help

0 Likes 0 ·
vswitch-tab.png (10.9 KiB)
purei avatar image purei nickdb ♦♦ commented ·

Thanks for this idea. Unfortunatly, theses values seems to be coherent. A correlation appears between CCL and temperature. Both increase together, good to know.


However, i found a difference between the voltage read by the BMS and by the VEBUS (i think it's the MP2). So it could explain why my absorbtion starts while the voltage is underneath the 52V setting in charger tab

v-bms-vs-vebus.pngSo, two questions :
- Why those values aren't the same ? Could it be a clue ?
- If the MP2 thinks it reached the absorption value (52V) is that a normal feature to stop charging ?

0 Likes 0 ·
dcl-cvl-ccl.png (29.7 KiB)
v-bms-vs-vebus.png (48.6 KiB)
Alexandra avatar image Alexandra ♦ purei commented ·
Comparing your voltages on your custom graph are you using a common axis for the value or one for each source?

The inverter is usually set to 52v absorption on the inverter itself according to the instructions. The battery still controls the charging in the system though. I have not seen a pylontec gonup to the 53v it requests. Usually it requests a 0 CCL before then.

0 Likes 0 ·
purei avatar image purei Alexandra ♦ commented ·

Yes, both graphs in my custom widget share the same axis.

The inverter is indeed set to 52v absorption, according to the pylontech instructions.
Is there an option in the MP2 to be certain it reads and uses the BMS values instead of its own ?
Do you know if i can access to the MP2 logs for understanding which value says to stop the charging process ?

0 Likes 0 ·
purei avatar image purei commented ·

I tried again some settings modifications. Battery monitor from general tab, WeakAC from grid Tab and dynamic current limiter with no succes.

But i download all theses tests in a CVS file if someone wants to find something relevant. (it's a .log file but can be opened with .XLS or .CSV reader) Generator_disconection.log

Just one last question, does anybody know if i can ask help from an official Victron expert by any way ? Phone, mail or other.

0 Likes 0 ·
0 Answers