question

Sputnik avatar image

Bug in SmartSolar MPPT 75/15 ?

I disconnected the SmartSolar from the solarpanel in my sailboat 16 NOV, but in the app it erroneously indicates that it is still producing solar power, please see the enclosed picture.
The MPPT is still connected to the batteries and therefore flashing the blue LED every 3 s. The batteries are connected to an IP 12/15, that is being powered by 230 V.
Is there a bug in the SmartSolar firmware?

Cheers/ Michael (Denmark)

MPPT - Solar Charge ControllerFirmware Update Issuebug report
img-5133.png (56.8 KiB)
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
WKirby avatar image

As long as the MPPT controller is connected to the battery, it is gong to consume a small amount of energy to run the microcontroller, LEDs, Bluetooth etc. It is not very much, probably less than 1 Watt, which would amount to a few Wh per day. This amount of energy, although in reverse, is quite accurately displayed on your historical graphs. In normal operation with a solar panel connected, these minuscule measurements will be obliterated actual production.
Is there any reason to disconnect the solar panel? If so, then perhaps disconnect the MPPT from the charger too to avoid draining the battery.

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Super! The app records the reverse energy as well - that explains it all.

Thank you very much for sharing your knowledge!