question

robbn avatar image
robbn asked

SmartShunt not showing proper solar charge current

I'm in a new Keystone Cougar RV that came equipped with a 400 watt solar collection system, and Victron 100/30 charge controller + smart shunt. I purchased and had the dealer install a new 270W LiFePO4 12V battery, and went through all the proper configuration steps with a Battle Born batteries support engineer. The components were all factory equipped, and wired by Keystone. Zero Current calibration was performed with all battery connections disengaged, and the solar charger set to 'disabled' in VictronConnect. The Inverter was powered off.

In the morning when the sun is low, the solar shows it is collecting about 100W of power. As the day progresses, the solar rises above 350W at ~40V yet the shunt still shows a difference of about 40Watts at 13.5V if I turn off the solar charger and watch the load level on the battery change. I observe a drop from -12W to -26W when the solar is showing 130W of power being collected. This leaves me wondering, "Where did those other 116 Watts go?" The battery cables are tight, and none of the wires are warm to the touch, so I don't think its heat loss. That much power expended as heat would have caused a fire.

https://www.keystonerv.com/solarflex-400i-overview

The battery in question is the GameChanger 3, which is configured as directed by Battle Born batteries, with 14.4V Absorption Voltage, 14.4V equalization and 13.6Float, but the Equalization is disabled in the app. Max charge current is 30A. On the shunt, the settings are 270Ah Capacity, 14.4V Charged Voltage, Floor 0, Tail 3.50%, Peukert 1.05, Efficiency factor 99%.

Yesterday I ran on battery all day, and before the battery reached low voltage for my refrigerator (at about 4%), the smartshunt displayed that I had expended 285Ah of power.

So the question is: How can I get the SmartShunt to properly display the power it is receiving from the charger again? If everything is configured correctly, and the calibration was done with no load, I would expect no more than a 10% loss of power from the solar charger.




SmartShunt
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Alexandra avatar image
Alexandra answered ·

@RobbN

Dont forget the shunt and mppt use power as well. As well as any other electronics and monitoring or other gear powered by the circuit. Plus the losses in wiring and high resistance connections.

Then you have the power factor of loads and losses due to noise in those circuits.

The third possibility is the battery is not as efficient as it says it is or what you have set it at. Or maybe a little of all of it.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

trevor-bird avatar image
trevor-bird answered ·

Hello @RobbN I know this may seem like an unhelpful question but it is worth absolutely checking where the MPPT controller is connected. Are you certain the negative side of the MPPT controller is going to the system side of the shunt and not the battery? It just seems the current from the solar controller is not going through the shunt.

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@RobbN Or some is being siphoned off by other loads before hitting the shunt.

1 Like 1 ·
Thank you for the suggestions. I should have noted that before the Lithium battery arrived, I was using a Marine battery the dealer had installed as standard procedure. When that battery was present, I could actually toggle the solar charger off/on and watch the load level on the shunt change by about 95% of what the solar reported it was producing. It was only after the dealership installed the new battery that the deviation occurred. They didn't set up the charge system parameters so I did that myself as soon as I got the camper home.


Assuming the dealership removed the battery and installed the new one with no changes to the wiring itself, my instinct is that they might not have turned off the solar charger, or had it in sunlight when the initial connection to the new battery was done.

Is there a simple way to simply reset the solar charger without a wrench? A reset button that I haven't found, perhaps? I've worked in I.T. for 25 years and the value of a cold reboot cannot be overstated.

0 Likes 0 ·

After many hours of research, and a few phone calls to Keystone Owner Services, I ended up calling an expert at Off Grid Power Systems in Ohio. While he didn't have to do so, he offered me some suggestions on troubleshooting.

As it turns out, the camper is wired from the factory with a wire coming off of the battery, up to a disconnect box, where several other wires are connected. The wires from the charge controller are connected there, and there's a 2nd ground wire coming off the battery that also goes to this disconnect block. He recommended that ONLY 1 ground wire be fed from the battery, and that should go to battery side of the shunt. That secondary wire should connect to the load side of the shunt at the ground to the frame. This won't affect my ability to disengage the battery and will eliminate the secondary route for the current to flow. All other wires from the MPPT appear to be routed correctly. I believe that once I can get this second ground wire rerouted, I will get accurate readings. If this is confirmed as the solution, I'll update this thread with the answer section.

Thanks again for the suggestions!

0 Likes 0 ·
robbn avatar image
robbn answered ·

The ground wire that had run from the battery disconnect block to the battery was bypassing the shunt. This wire was re-routed from the battery to the load site of the shunt and the solar controller was then able to register the proper current levels as the shunt was reporting correctly.

I informed Keystone Customer Care of the issue last week as it appeared to have been a factory setup. My local dealership informed me this morning that they've received a service alert (recall) on hundreds of Keystone RVs to correct this issue.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Great. Thanks for the update.
0 Likes 0 ·