question

mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v2.90~12 available for testing

Good evening!

A new version to test, per today. v2.90~12.

Compared to the previous public test version, v2.90~10, this has various fixes for issues introduced earlier in v2.90 as well as some additions.

Plan for v2.90 is still the same: there will be a few more betas, and testing time ofcourse, before this is released. But no other large changes; to try and keep the timeline to official release reasonable.

All the best and have a good evening,

Matthijs

Post about prior versions:


Change log (compared to v2.87)

v2.90~11 and v2.90~12:

Wakespeed:

  • Log wakespeed alternator data attributes to VRM


Various fixes of regressions made earlier in v2.90:

  • Fix ESS system feed-in switch which did not correctly switch on if there was a limit.
  • Fix "Stop on SOC" switch
  • Use user selectable temperature unit for battery alarm/relay settings, instead of Kelvin.
  • Fix communication issues with EV Charging Stations with firmware prior to v1.21. Issue was introduced in v2.86 and v2.90~3; and this same fix has also been released as v2.87.


Modbus TCP:

  • Add energy registers for energy counters in our inverter/chargers (Multi/Quattro)
  • Add registers for Wakespeed alternators


DVCC:

  • Add support for Cegasa eBick and eNerlit batteries. Force enables DVCC, and forces SVS and STS to be off. Documentation: https://www.victronenergy.com/live/battery_compatibility:cegasa
  • Remove forced settings for Dyness batteries; instead, Dyness batteries are treated like any non-especially recognised CAN-bms battery now.


RaspberryPi

  • Add support for raspberrypi4 board rev 1.4 and 1.5, and possible other models. Those two were tested, and work. Possibly the RaspberryPi Zero2w works now also; and the RaspberryPI4 Compute Module. But nobody here has one to test. Special thanks to @Bathnm for spending lots of hours on this to make it all work; as well as a handfull of other enthusiasts for helping to test and such. Details:
    • u-boot goes to v2022-01
    • kernel goes from 4.19 to 5.10
    • bcm2835-bootfiles go to 2022-331
  • NOTE: Reflashing the SD-Card is required: to go from a prior version, ie v2.90~10 or early like v2.86 or even earlier, to v2.90~12 or later, you'll need to reflash the SD-Card. This change has been done such that Pis already running will not auto-update themselves to v2.90~12 or later. As an alternative, you might be able to extract the new boot files from the new image, and copy them accross; nobody tested this as far as I know.


Other:

  • Fix IMT Irradiation sensor connection issue; after the sensor is turned off and back on; which happened specially on faster hardware such as MultiPlus-II GX, EasySolar-II GX and certain RaspberryPis.
  • Log GX relay functions to VRM
  • Log generator start/stop AutoStartEnabled to VRM.


Venus OS Large:

  • Fix access to USB dongles (by fixing group permissions)


v2.90~9 and v2.90~10:

  • Fix the GPS summary. Issue was introduced earlier during v2.90 development.
  • Fix the Scheduled charging %, it said `undefined`. Issued was introduced earlier during v2.90 development.
  • Fix Remote firmware update on VRM, it crashed while during the Device-list. Issue was introduced in v2.90~8.
  • Venus OS Large
    • Update node-red-contrib-victron from 1.4.17 to 1.4.18. For details see its change log.
  • Fix issues relating to Dyness 16-cell batteries, issue introduced per v2.90~3. Note that more changes related to Dyness batteries are coming.
  • NMEA2000-out: add support to AC chargers, such as the Phoenix Smart IP43 charger. Tested with both the 230V as well as 120-240V Phoenix Smart Chargers.
  • Prioritise ethernet over WiFi. Background here. This is done by increasing the metric for WiFi routes.


v2.90~8, ~7 and ~6:

  • add wakespeed support (monitoring). Requires wakespeed firmware which is not available yet! I’ll post the details of that once available. Should be within a few weeks.
  • Improve Bluetooth sensor menu & options (continuous scanning, see all inserted adapters, and more)
  • improve bluetooth radio on Cerbo GX stability: if it malfunctions due to over temperature, the chances of it restarting when cooled down are now higher. But rest stays and will always remain the same for current hardware version: for any serious use, insert a usb bluetooth adapter as per manual.
  • gx lte & gx gsm: Add modem username/password settings, required by some providers
  • various EV Charger improvements (menu, connection stability, VRM)
  • Fix the sign of the current and power for DC meters that are configured as source (except fuel cell and alternator, which were correct). broken since venus v2.80~18
  • Add missing "Inverter only" mode to mobile overview
  • Add support for VE.Bus BMS v2 firmware updates
  • Venus OS Large: fix Node-RED Dashboard button missing on VRM and fix image selection / check for update function in online update menu.


v2.90~5:

  • HTML5 app: fix white screen issue on MFDs that do not support localStorage, eg. Simrad NSX 3007, 3009 & 3012. Thank you Gustav for reporting.
  • Venus OS Large: fix node-RED dashboard button missing from VRM portal. Thank you houser and others for reporting.
  • VRM: fixes for the Generator control, ESS controls and EV Charging station controls
  • EV Charging Station: stability fixes (also included in v2.86)
  • Inverter/charger connections:
    • add new MultiPlus-II 48/15000/200-100.
    • Fix VE.Bus BMS error path issue
  • RV-C: Fix DC_SOURCE_STATUS_2 temperature field.


v2.90~3:

  • Prepare for remote configuration of Victron products connected using the VE.Can comms. port: up until now, Remote Configuration is only possible for products connected using VE.Direct, as well as our VE.Bus product range. And this change is the one making up for that missing piece. The corresponding VictronConnect version is also available as a beta, see here.
  • Add support for new Carlo Gavazzi EM530 and EM540 meter. Sub-Family X and PFC is supported, part numbers:
    • EM530DINAV53XS1X
    • EM530DINAV53XS1PFC
    • EM540DINAV23XS1X
    • EM540DINAV23XS1PFC
  • Add option to configure the UI to show all temperatures in Fahrenheit.
  • Fix main battery temperature missing, or wrong value shown, sometimes on the VRM Dashboard.
  • Add Venus OS Large to the standard build. To learn what Venus OS Large is about, read here.
    • Having this in the standard build is rather good news. It (a) removes the need for the large images to now and then be built manually. And (b) you can now, once v2.90~3 is installed, in the menu, select the large image and update to that, see Settings -> Firmware -> Online updates -> Image type (normal vs large). And (c) Venus OS Large can now be updated using the Online update system. However: there seems to be a bug in (b). More news about that later.
    • Note that node-red no longer runs as root.
  • Add various new VE.Bus models (Quattro-IIs and MultiPlus-IIs)
  • Prepare for (or possibly even finish, I'll confirm later) Generator control widget on the VRM Portal website. Note that this includes various underwater changes to clean some things up, which should not make any effect.
  • Add daily tracker history for Inverter RS and Multi RS, including transmission to VRM.
  • Add first implementation of RV-C support. Its mostly RV-C out, ie making information of the Victron system available on the RV-C network where RV systems can pick it up to show in their user interfaces. Detailed spec will be published later.


DVCC:

  • Force good settings for the FreedomWON eTower batteries: DVCC on, SVC and STS off.
  • Better handle BMS disconnection issues: in some cases the solar chargers would not start showing Error #67 when unplugging the BMS. Now they do.
  • Detect Dyness batteries, so they no longer show up under as a Pylon battery. Settings remain the same: DVCC force enabled on, SVS and STS force enabled off.
  • Inverter/chargers: show state as "Ext. control"; instead of Bulk or Absorption, when controlled by a BMS/DVCC. When controlled by a BMS the inverter/charger would never show float, which caused questions. Now it just shows externally controlled, simpler, and more accurate: there is no bulk -> absorption -> float charge algorithm when controlled by BMS.


Less relevant for most users:

  • GX LTE/GX GSM: prepare for allowing user configuration of PPP username and password, which some providers need. Note that this can't be used yet, gui change is pending.
  • Prepare for the new coming model of the VE.Bus BMS, aka VE.Bus BMS v2; including remote firmware updates of the BMS.
  • EV Charging station: add support for future models (AC22NS & AC22E) as well as some other preparations of features that can't be used yet until a future Venus OS beta version.
  • Prepare for Widgets, a feature coming in next version of VRM App for iOS and Android.
  • Update Linux kernel from 5.10.42 to 5.10.109, which updates to LTS for security issues and bug fixes, also adds support for Cerbo B1 and Ekrano, and adds ntfs support.
  • Update Open Embedded Dunfell branches: various fixes to low level systems and tools.
  • Various stability fixes to the xupd & xupc tools (which are part of remote firmware updates)
  • Transmit default gateway to VRM as well as CPU temperature; for debugging.
  • Add pre/post hooks to installation from USB stick: https://github.com/victronenergy/venus/issues/853
Venus OS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

13 Answers
Paul Test avatar image
Paul Test answered ·

RPI can’t find the update.

image.jpg
image.jpg


image.jpg (6.9 MiB)
image.jpg (7.5 MiB)
7 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You missed this part from the changelog: "NOTE: Reflashing the SD-Card is required" and "This change has been done such that Pis already running will not auto-update themselves to v2.90~12 or later".

0 Likes 0 ·
Thx have tomato of my eyes. :-)
0 Likes 0 ·

jeroen,

this mean that any older 2.90~* version cannot be updated to another pre 2.90~12?

I'm running 2.90~3 Large on a rpi3B+, reading your post, thought that I might as well, check what I can update to without having to reflash.

Well, seems it applies to all rpis not only 4s as it comes with error during checking.

Q: is this something we will have to endure often?

Q2: is there a way to upgrade online to a version which is not the latest?

upgrading is an afternoon job for me... (kevin's stuff, messing with config.txt, downloading/compiling ZerotierOne, editing and configuring SignalK, adding custom PGNs support in N2K signalk, etc, etc.)


cheers

V.

0 Likes 0 ·
bathnm avatar image bathnm vassilis-bourdakis ·
Hi @Vassilis Bourdakis I can comment on your first question, but not your second.


Is this something that will happen often, the answer is no. In this case the kernel upgrade has triggered a need to udpate files on the boot partition. This means that the root and boot partitions would become incompatible with each other, and thus the boot partitions needed updating and a complete re-image. The risk of automating an upgrade of the boot partition is that the entire machine becomes non bootable and a re-image would be required anyway,

0 Likes 0 ·
thanks a lot for the explanation. Up till recently due to using the Large version on a rpi I had to do full installs all the time so missed the change kernel and boot related issues.

cheers

V.

0 Likes 0 ·

Hi @Vassilis Bourdakis , The answer to the other question "Q2: is there a way to upgrade online to a version which is not the latest?", is no, not possible.


That for the Pis its necessary to do a reflash now and then is just a fact; its not something we can fix in any reasonable amount of time/risk.



0 Likes 0 ·
vassilis-bourdakis avatar image vassilis-bourdakis mvader (Victron Energy) ♦♦ ·
thank you @mvader (Victron Energy)

no worries, happy to have all that in the first place.

Will do a reinstall to the latest ver sometime at the end of the month before I start using the boat!

0 Likes 0 ·
harold avatar image
harold answered ·

Short question:
Use user selectable temperature unit for battery alarm/relay settings

Is this a new function? Where is it hidden?

Harold

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Harold , yes. see Settings -> Display & language -> Units.
0 Likes 0 ·
nickdb avatar image
nickdb answered ·

The new battery support doesn't actually appear in the main list yet so can only be accessed with the link above.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Correct, thats on purpose: v2.90 is not official yet; so also I want to keep publicly available documentation that relies on v2.90 to a minimum.
0 Likes 0 ·
thomasw-1 avatar image
thomasw-1 answered ·

Thanks for having fixed the limit feed-in switch! It works again as expected.

@mvader (Victron Energy): Apropos "Stop on SOC": I am desparately looking forward getting a function that limits the battery charging on a top level, but not when charging from grid, but especially from PV.
You certainly know that regular charging of LiFePo batteries to 100% reduces theír lifetime by more than 30%. In case anyone has a properly dimensioned battery, that battery maintenance would make sense especially during summer times to charge the battery e.g. only once per week to 100%.

I would also implement that function externally, however for that case I would require a correctly working function "Limit Charge Current" (see my previous posts on that topic).
Since the fix of an existing function is potentially easier than an implementation of a new function, I would be also glad, if "Limit Charge Current" would be fixed.

Thanks
Thomas


9 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Charging Lithium-ion to 100% effects their lifespan but it was my understanding that it doesn't affect LiFePO4 the same way.

The cycle life of LiFePO4 is so high that the cells will likely die of age before the cycle count is reached.

0 Likes 0 ·
See my answer below. It impacts LiFePo in particular
0 Likes 0 ·

You certainly know that regular charging of LiFePo batteries to 100% reduces theír lifetime by more than 30%

Is this anecdotal or is there actual data to support this, in a consumer ESS environment?

What works for EV's does not apply for home use, they have fundamentally different charge/discharge profiles.


0 Likes 0 ·

Please download and read this article about LiFePo batteries from Journal of The Electrochemical Society. It's nothing anecdotal. It's more about lack of knowledge ;-)

1654855158652.png

Beside that you might be able to find plenty more using Dr. google.

0 Likes 0 ·
1654855158652.png (106.2 KiB)
The problem with this is that it is mostly irrelevant for home use, it references EV type use cases which are different - they have much higher charge/discharge rates.

They also run cells to much higher voltages than consumer batteries which are designed for long life.

This is a myth that is leaking over into residential ESS use from EV's c/o the internet.

At the rate a home user will charge/discharge their battery, combined with the typical cell voltage in use, there is zero value to partially charging a home lifepo4 battery.

If anything you will shorten its life by preventing proper cell balancing.

You are trying to solve a problem you don't have.

As already indicated, the batteries are more likely to die of old age than cycling.



0 Likes 0 ·

You arguments base on wrong assumptions:

  • Charge and discharge currents with PV batteries can be at least as high as those with normal EV (>150A).
  • LiFePo cell voltages are the same in EV like in PV battery. Only the series arrangement is different.
  • A proper BMS assures proper balancing, when batteries are not fully charged. If this is not the case a full charge once per 7 to 10 days is more than enough assuring proper balancing.

It's with you believing in myths, at least I don't. I trust hard facts.

0 Likes 0 ·

screenshot-2022-06-10-at-122653.png

Here's a typical histogram of the time an ESS battery spends in different states. It is not the same as an EV, you aren't going to fast charge it and if the system is sized correctly you will never push the system as hard as an EV, or EV charger, might.

This example has a minimum cutoff, most others run lower and have a better distribution.

The battery will inherently spend it's life in a state that renders lower limits pointless (and this is in a region where there is no shortage of sunlight).

Also, all BMS don't work the same, some need a minimum threshold to balance properly.


0 Likes 0 ·

@nickdb, your argumentation bases on hypothesis. Please list a single academic analysis for your assumption!

Another generic, non EV-specific study published in March this year concludes analogue to the first one with "decreasing median cycle SoC to minimize battery degradation from cycling"! &
"In the scenarios considered, the charging time gradually increased from four to seven hours, while the average SoC de-creased by 20%. Such an adaptable scheduling results in reduced battery degradation and a longer lifetime, which may provide as much as 12.1% of savings in the battery storage system project."

This is why I want to reduce and/or limit the charging. This could be implemented by a native VenusOS functionality, but also by external control. For second option however, the DVCC charge limit would have to work like documented in ESS manual (which currently it unfortunately doesn't).

0 Likes 0 ·

I completely agree with you. The charge/discharge rate is so low versus the use in an EV. The most my Multiplus II will do is 70A into a 24V / 280Ah battery. That's only 0.25C. It'll probably do over 5000 cycles like this...

0 Likes 0 ·
dereppsteiner avatar image
dereppsteiner answered ·

Hello Matthijs,

will there be BT support for the mopatek pro LPG sensor in v2.90?

in v2.87 the Ruuvi sensors no longer work for me. they are not recognized. will this work again in v2.90?


https://github.com/victronenergy/venus/issues/946

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ruuvi sensors no longer working: please share more details. They should work in v2.90; they do in all systems that we test as well as monitor remotely.


Mopeka: I don't know yet when that will be included.

0 Likes 0 ·
bogi999 avatar image bogi999 mvader (Victron Energy) ♦♦ ·
Same Issue here.

Upgrading from 2.90-10 to 2.90-12 lost Bluetooth on CerboGX.

Downgrading to 2.90-10 wouldn't bring them back.

I made a downgrade to the latest Release 2.87, bluetooth came up again, but without the Ruuvis.

After a Reboot to 2.90-10 all fine again.

I also will be happy with Mopeka integration. ;-)

0 Likes 0 ·

Hi @bogi999 ,

thanks for your report.

Without external adapter, the Cerbo GX bluetooth radio module is known to be unreliable: are you using an external adapter, like explained in the Cerbo GX manual?


And in case you can reproduce, please provide a photo/screenshot of the Settings -> Sensors -> Bluetooth -> Bluetooth adapters menu. Like this one:

1655368063703.png


We haven't been able to reproduce any problems, hence the questions.



0 Likes 0 ·
1655368063703.png (13.2 KiB)
bogi999 avatar image bogi999 mvader (Victron Energy) ♦♦ ·
Hi @mvader (Victron Energy)


no, i use the internal bluetooth modul because of to few usb-ports.

I'll test it again, maybe saturday. If there will be the same results, i'll make some screenshots.

0 Likes 0 ·
Rob Duthie avatar image
Rob Duthie answered ·

Hi All

Being testing the raspi B4+ version 1.4 2GB all OK to date. touch screen, boot etc.

Just had to add in Kevin Windrem setup helper and Gui mods to boot the screen up etc, Relays all there etc.

The only thing missing is the analog ports under IO to sort out ?

The /sys/bus/iio/devices folder is missing?

On the raspi3B+ analog IO is OK.

Regards

Rob D

NZ

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You must be loading some overlay file in the boot process. I have a fresh RPI3B on 2.90~12 and do not have that directory. It is populated based on drivers that are loaded. Maybe take a look at the RPI3b file /u-boot/ config.txt and post the details here,.
0 Likes 0 ·
Hi Rob, I also saw a comment somewhere in github from you, which I removed. Please leave your comments in one place and not in many.


thanks!

0 Likes 0 ·
hardy-tuner avatar image
hardy-tuner answered ·

i tried today image 2.90-12 for RaspberryPi Zero2w, but doesn't work with image for pi2 or pi4 at first.

image pi 2 was working with pi3b+ and image pi4 was working with pi4 8gb like expected.

okay, i found the missuing points for zero2w in image pi 2, then it is booting:

- under /boot is no bcm2710-rpi-zero-2-w.dtb for zero 2w like for other boards, please add it

- in /boot/config.txt we need additional lines

[pi02]

device_tree=bcm2710-rpi-zero-2-w.dtb

dtoverlay=miniuart-bt,krnbt=on

core_freq=400

core_freq_min=400


btw: the thread "Victron OS on new Raspberry Pi Zero 2 W" which had a possible working image is away:

https://community.victronenergy.com/questions/106779/victron-os-on-new-raspberry-pi-zero-2-w.html


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@hardy tuner Your re correct that the images currently available do not boot a Pi Zero2W correctly. You have identified correctly that the PI2 image is the one to use, but that there are some things missing, more than just the lines you identified.


Further testing has happened and there is a defined build that'd does work, including the changes you identified as well as changes to the WIFI firmeware and a few other internal changes due to no ethernet being available.

I can not confirm when the new beta image supporting the Pi Zero2W will be available, but based on the fact the link you have referenced has been removed and the RPI supported models have been updated it should be soon.

0 Likes 0 ·
patricknl avatar image
patricknl answered ·

Any ideas when selecting a phase for a single meter will be available? For meters like the EM/ET112 and such...


"Fix the Scheduled charging %, it said `undefined`. Issued was introduced earlier during v2.90 development."


This works again, haven't had to use it due to the good weather and such though :).


For now (compared to the released .87 version) somehow my SMA inverter stays connected better. Can't tell if it's the SMA inverter playing up or Venus OS. Eitherway, haven't had to reset the TCP/UDP server on the inverter since the .90 install.



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hardy-tuner avatar image
hardy-tuner answered ·

They found some security issues in u-boot, maybe thats important and not fixed when using u-boot goes to v2022-01.

https://research.nccgroup.com/2022/06/03/technical-advisory-multiple-vulnerabilities-in-u-boot-cve-2022-30790-cve-2022-30552/

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Venus only allows booting from the SD-card. Bugs in the tcp/ip stack won't affect it.
0 Likes 0 ·
sturla avatar image
sturla answered ·

On my Cerbo running 2.90-12, I experience the "DC system" wattage is doubled from actual value in the display. The charge comes from two WS500 regulators.

img-0301.jpg



img-0301.jpg (94.1 KiB)
4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@Sturla Glad to see it is working. Could you please post a screen shot of the device list showing the two alternators. and another of the device screen themselves. Many Thanks.
0 Likes 0 ·

Only have this view available;

img-0302.jpg

Here the regulators are running the 2.5.0 beta version. In the device view, all relevant data appears. (The rpm data is not correct).

As the 2.5.0 beta caused fluctuating charging, I downgraded back to 2.4.3, which are much more stable from a charging perspective. With this version, there are less info available in the device view (like field %).

0 Likes 0 ·
img-0302.jpg (93.2 KiB)
Your RPM data may not be correct due to configuration of the pulley ratio in the $SCT configuration option. The RPM is either taken off the CAN or calculation based on the alternator stator input and fully ratio between alternator and crank.


Regarding the DC Load, noted the problem and will take a look.

0 Likes 0 ·

There is a fix already in play and will be in one of the upcoming beta's. It did not make 2.90~14

0 Likes 0 ·
offpist avatar image
offpist answered ·

Seems like WS500 communication only works when using 250kbps, not with 500 kbps?

REC-BMS, Cerbo, and WS500 is all setup with 500 kbps.

Cerbo sees the REC-BMS, and WS500 sees the REC BMS but Cerbo does not show WS500 data.


We have an different system setup with all 250kbps and this works fine.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@Offpist That is correct. The 500Kb port is a BMS Can port and will not understand the messages the WS is sending out. For those use case where battery is connect to the 500Kb BMS Can port a later release of likely WS firmeware will be needed. The WS500 can then be installed on the 250Kb VE.Can port and receive charging direction from the VenusOS, much as can connected MPPTs do.

0 Likes 0 ·
We did some tests on this as well now. And When BMS is on BMS-CAN port with 500 kbps and WS500 in VE-CAN port at 250kbps the Cerbo sees them both, but WS500 does not see the REC BMS. So, we had to move them all over to VE-CAN port at 250 kbps. Fine, but then if you want to connect the NMEA2000 cable you then have to use the second port in the WS500 and then we had to make an special cable for this. Unless someone have some suggestions to this..?
0 Likes 0 ·
dmsims avatar image
dmsims answered ·

I cannot see the link to download - does anyone know where ?

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Unless you are trying to upgrade an RPI, you should be able to do it within the GUI. Just need to ensure that you have Update Feed set to "Latest Release Candidate". If you are trying to upgrade an RPI by re-imaging teh SD Card then this can be found at

http://updates.victronenergy.com/feeds/venus/candidate/images/

1657785044805.png

0 Likes 0 ·
1657785044805.png (85.1 KiB)
Thanks, I am on v2.90~10 so have to re image!
0 Likes 0 ·
Philip avatar image
Philip answered ·

Just reporting : with 2.90 ~12 for me Raspberry Pi Zero 2W does boot and it works fine but not stable: crashes after few hours or did not start MPPT to work.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.