question

rainer-ludewig avatar image
rainer-ludewig asked

MultiPlus will nur durchleiten

Ein freundliches Hallo ins Forum,

gern möchte ich mich in die PV-Welt einarbeiten. Dazu habe ich mir letzten Herbst (früher gings wegen Suez nicht - sagen die Lieferanten) folgende Komponenten gekauft:

5x Solar-Panel: 330 Watt Solarmodul Jinko Cheetah HC 60M Mono

1x Laderegler: Victron SmartSolar MPPT 250/60 Tr

1x Akku: Pylontech US3000C 3,5kWh LiFePO4

1x Wechselrichter: Victron Multiplus-II 48/3000/35-32 230V

1x Systemüberwachung: Victron Cerbo GX

1x Energiemessung: EM24 (Dreiphasensensor) - RS485

Die Panels habe ich auf meinem neuen CarPort montiert, die Komponenten und den Akku sind in einer wärmeisolierten, beheizbaren Box untergebracht. Aus der Box führen ein ca. 25m lange Kabelrohre zu meiner Hausinstallation. In einem Rohr ist ein Erdkabel NYY-J 5x2,5 und im anderen zwei RJ45 und eineTelefonleitung 4x2x0,6.

solaranlage-carport.jpgKabel wie auf der Zeichnung verlegt. Der Cerbo hängt am Router im Hausnetz. Ich war begeistert wie schön man auf dem PC an alles ran kommt. Der Herbst und Winter war trübe und die Anlage hat sich zunächst nur selbst versorgt. Nun nachdem die ersten Sonnenstrahlen auf die Panels trafen, musste ich feststellen, dass nicht alles so funktionierte wie ich es mir vorgestellt hatte. Der MultiPlus II steht immer auf "Durchleiten" und vom PV-Ladegerät kommen 5-10W. Schalte ich den Multi von "Ein" auf "Wechselrichter" hab ich plötzlich ca.750W in der Anzeige. Der Schalter unten am Multi steht sicher auf I.

Mit dem Oszillografen kann ich die Datenpakete, die ab und zu über die RS485-Leitung kommen, sehen.
Im Einstellungsmenü des EM24 habe ich ModBus-Adresse = 1 und Baudrate = 9600 gefunden, was ok sein sollte.

Beim EM24 gehen die Kabel von den Vorsicherungen oben (wo auch N ist) hinein und unten geht es auf die drei Schienen der Verbraucher. RS485 ist über ein TP-Kabel eines RJ45/Cat7 (25m) mit dem Victron USB/RS485 (<20cm) verbunden. Masse geht über die Abschirmung. Auf der EM24-Seite ist ein 120Ohm Abschlusswiderstand verbaut auf der USB-Seite wird der interne Widerstand des Converters verwendet.

Ich habe den Verdacht, das der EM24 und der Cerbo nicht richtig kommunizieren. Ich habe den Anschluss des Kommunikationskabels nochmal überprüft und auch ein anderes Adernpaar vom RJ45/Cat7-Kabel benutzt. Es macht keinen Unterschied, ob der USB-Stecker des "RS485 zu USB"-Adapter im Cerbo steckt oder nicht. Im Remote-Menü erscheint immer der BU32101160011 als Energiemessgerät in der Rolle als Netzzähler, egal ob der Stecker drin ist oder nicht. Kann ich den Zähler aus dem Cerbo löschen um zu sehen, ob die Erkennung und somit die Datenkommunikation funktioniert?

Ich weiß jetzt nicht recht weiter und die Antworten vom Händler-Support sind recht einsilbig.

bild-2022-02-23-160721.png

Ich hoffe ein genialer User hat eine Idee!

Mit freundlichen Grüßen von der Havel in Berlin

Rainer

P.S. Hier die ESS Konfiguration:

23-02-22-konfiguration.jpg


Multiplus-IIem24
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

Ein paar mehr Bilder aus der Remote-Konsole wären nicht schlecht.
Auf dem einen Screenshot sieht es so aus als würde der EM24 nicht richtig erkannt.
Taucht dieser denn in der Geräteliste auf?

Ohne Kommunikation zum EnFluRi geht es System immer auf Durchleiten.
Für mich sieht es also im Moment sehr stark nach einem Kommunikationsproblem zwischen Cerbo und EM24 aus.

Wurde der RS485 Adaper von Victron genutzt oder ein anderer?
Leuchtet/Blinkt der Adapter?
Am EM24 ist unten rechts ein kleiner Drehschalter, dieser muss auf 1 oder 2 stehen, nicht auf dem Schloss.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

rainer-ludewig avatar image rainer-ludewig commented ·

Matthias, Danke für Deine Nachricht!

Im Remote unter Einstellungen Energiemessgeräte finde ich diesen Eintrag:

1645637479242.png

Der kleine Schalter steht sicher auf "1".

In der Geräteliste im VRM-Portal taucht der EM24 nicht auf:

1645637642719.png

Es wurde der Original-Adapter von Victron benutzt. Wenn ich mit dem Oszi Datenverkehr feststelle, blinkt es wild im USB-Adapter.

Auf der Geräteliste im Remote sieht es so aus:

1645637824148.png

Die 8°C kommen zustande weil ich wegen der Fehlersuche die Isolierbox offen habe.

Gruß aus Berlin

Rainer

0 Likes 0 ·
1645637479242.png (11.9 KiB)
1645637642719.png (19.5 KiB)
1645637824148.png (23.3 KiB)
Matthias Lange - DE avatar image Matthias Lange - DE ♦ rainer-ludewig commented ·

In den Einstellungen steht der in der Liste, weil er vermutlich mal erkannt wurde, aber wie vermutet, scheint es da ein Kommunikationsproblem zu geben.

Noch mal die Klemmen am EM24 prüfen, die sind sehr weit hinten und da passiert es gerne mal, das man da nicht richtig drin ist.

An welchem USB Anschluss am Cerbo ist der RS485 Adapter angeschlossen?
Der Anschluss direkt neben der HDMI Buchse ist nur für die Spannungsversorgung des GX Touch 50/70, nicht für Datenkommunikation.

0 Likes 0 ·
rainer-ludewig avatar image
rainer-ludewig answered ·


Vielen Dank für Deine Nachricht!

Du hast völlig recht, ich hatte zu Anfang den Cerbo und den FTDI mal probehalber im Netz und da hat er ihn erkannt.

Die Klemmen 41-43 liegen wirklich etwas ungünstig, ich habe extra Volldrahtenden an die TP-Kabel und den Widerstand angelötet, damit die Verbindung sicher ist. Ich werde das heute nachmittag nochmals testen. Der Test mit dem Oszi kann auch bedeutet haben, das der FTDI ein Anfrage-Paket geschickt hat. Hast Du erfahrung mit USB-Analyzern, kann man damit feststellen, ob der Datenverkehr OK ist? ... oder wie kann man das rauskriegen?

Die Anschlüsse am Cerbo sind wie folgt:

1645691487021.png


Nochmals vielen Dank.

LG aus Berlin

Rainer


1645691487021.png (94.2 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

holger-m avatar image
holger-m answered ·

der Converter RS485 to USB blinkt rot bei absenden von Anfragen aus dem Cerbo, wenn er welche bekommt muß er grün blinken wie eine Discokugel

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

netrange avatar image netrange commented ·
...bei mir lief es mit dem Abschlußwiderstand überhaupt nicht ... ich denke das im Converter bereits einer integriert ist ... Jetzt wo der Widerstand ausgeklemmt ist läuft es seit Monaten super ... rot grün ...
0 Likes 0 ·
Matthias Lange - DE avatar image Matthias Lange - DE ♦ netrange commented ·
Wir haben noch nie Abschlusswiderstände benutzt und damit auch noch keine Probleme gehabt, auch wenn wir das Kabel einige Meter verlängert haben.

Steht so ja auch in der Beschreibung von Victron, das normalerweise keine gebraucht werden wenn man die Kabel so nutzt, wie sie von Victron kommen, nur wenn man das Kabel verlängert kann es nötig sein.

Würde also auch vorschlagen mal den Widerstand raus zu nehmen.


0 Likes 0 ·
rainer-ludewig avatar image
rainer-ludewig answered ·

Liebe Community,

vielen Dank jetzt funktioniert es! Ich hab erst den Widerstand am EM24 rausgenommen, ohne Erfolg. Erst als ich den Widerstand am Adapter abgeklemmt hatte hat sofort alles funktioniert.

Meine RS485-Leitung ist ca. 25m lang, deshalb hab ich mich genau an die Dokumentation zum USB/RS485-Converter gehalten und die Abschlusswiderstände eingebaut. Wir haben damals an der TU-Berlin bei RS485 auch immer Abschlusswiderstände eingesetzt und auch bei großen Längen hat es funktioniert. Auch in der Beschreibung der EIA-485 werden solche Widerstände empfohlen. Ich kann mir nur vorstellen, dass die Stromversorgung in einem der Geräte (EM24 oder Cerbo) die 120Ohm (bzw. gesamt 60Ohm) nicht verkraftet hat.

Interessanterweise hat das grün / rote Farbenspiel auch mit Widerständen immer stattgefunden, aber offenbar war das Signal nicht mehr erkennbar.

Grüße aus Berlin

Rainer

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

netrange avatar image
netrange answered ·

Es gibt Situationen ... da hat Widerstand einfach keinen Sinn :) ... schön das es klappt :)

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.