question

Natebert avatar image

SmartSolar MPPTs dropping out of ESS into Standalone and back to ESS, why?

Hello,
I've got a question for the group about a new behavior I'm experiencing.

In summary: my MPPTs are dropping out of network mode and going into standalone mode and I don't know why.

Some background:
--------
I haven't had much of opportunity to operate on solar over the past few months as I've been under Seattle cloud cover. The last time I was on solar power was last November, and I've done a firmware upgrade on the MPPTs and a firmware update on the inverters, and a firmware update on the CCGX, etc. since.

The past couple days have been sunny so I turned off the grid 'mains' to check out the solar side of system in preparation for some upgrades later this month and I've noticed a behavior which I can't explain.

My batteries are around a confirmed 50% SoC (was 100% when I left grid and I drew them down with a space heater, water heater and fridge, prior to sunrise to approx 50% SoC.) I wanted to test my that my MPPTs are properly entering into bulk state. (and they are, mostly)


The sun has been up for about an hour to two and the two MPPTs are beginning to charge, but I'm seeing a situation where either one of the charge controllers drops out of ESS mode and goes into standalone mode (and drops out of slave status to standalone status) only for a second or two, and then goes back into ESS mode. During this time it's in standalone mode, it effectively stops charging.

Normal operation (full power coming from MPPTs):

Undesirable operation (MPPTs stop/throttle charging):

Normal operation (in ESS mode):
Undesirable operation (in Standalone mode):


The frequency of this is unpredictable, though regular. The system runs fine (both MPPTs charging) for a period of about minute, then one of the chargers will effectively stop charging as it goes into standalone mode again. Then it goes back to ESS. Only to repeat at some undetermined interval again.

I've completely power cycled the MPPTs, disconnecting from PV, and disconnecting from DC, waited a bit, then connected back to DC, then supplied power via PV.

I run a full Victron component build, CCGX, dual Quattros, Ve.Can Lynx Shunt, SmartLithium 12.8v, VE.BUS BMS, Victron Smart Battery Sense network, etc, and wonder if this could this be a bad Bluetooth connection between the MPPTs and the Smart Battery sense?

Basically, I can't explain why the system would it drop out of the network status ESS into standalone, (drop out of slave mode into standalone mode)?
Unless maybe I have a bad RJ45 UTB cable as well?

Here are some of my other settings.


Both MPPTs are connected via Ve.Direct to the CCGX and over Bluetooth to the Smart Battery Sense on the batteries.


If I observe the LEDs on each of the MPPTs, I see that they primarily stay in Bulk, though occasionally the blue Bulk LED flashes off, then back on.
But after a minute or so, seeming at the same interval that they drop out of ESS, they go into float, if only for a brief second, then back to bulk again.

You can see from the VRM output for today, that each MPPT controller is behaving nearly the same. I would expect to see these lines to be a curve of constant output, vs the spikes & dips.

Additionally, if I watch the volts at the shunt.
When under full charging power, the shunt is measuring 13.17v
When the system goes into 'standalone/float', the volts drop to 13.07v

As I had not experienced this behavior in my system prior to Nov. (before my updates) and I now wonder if I could now be experiencing the situation described here: https://community.victronenergy.com/questions/8178/why-doesnt-the-documentation-warn-that-multiple-mp.html?childToView=11257


Any help or advice or places to look would be appreciated.


Thanks,
Nate

MPPT - Solar Charge ControllerCCGX Color ControlESSSOCSmart Battery Sense
standalonemode.png (25.1 KiB)
standalonemode.png (25.1 KiB)
essmode.png (23.5 KiB)
dvccsvs.png (36.8 KiB)
mpptconnected.png (28.2 KiB)
vecanshunt.png (32.1 KiB)
inessmode.png (38.1 KiB)
outessmode.png (38.9 KiB)
inessmode.png (38.0 KiB)
outputjumping.png (98.4 KiB)
1 comment
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Additionally:
There are no ESS assitants in the Quattros:
From the CCGX:

From VeConfigure:


VRM portal shows the following battery voltage flapping across both MPPTs:

Each of the MPPTs are configured as such:

noess.png (12.0 KiB)
assistants.png (25.2 KiB)
solarbatcurrent.png (105.4 KiB)
mpptsettings.jpg (402.6 KiB)
2 Answers
Paul B avatar image

Have you fixed this Yet


I had this issue yesterday as well similar config with 2 x quattros and two smartsolars plus the smart battery and BMV712 etc they both flicked to ess then to float etc etc

it happened after I added some assistants so that I could use the solar power still when the batteries were full and we still had grid

To get it working how I wanted I have ended up using the ESS assistant and also disabling the LOM on AC2 in on the two inverters otherwise the generator would not sync (needed a password to do this) (for me I also set the country code to OTHER) so that the Generator worked correctly


then configured the ESS so it suited what I needed, since then the smartsolar MPPTs are working just great.

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Well, I have not used the Ve.Direct cables directly attached to my CCGX yet.
I'm still using my USB cables & Hub.

With the latest release candidate CCGX firmware along with a reset/reboot of my entire system I believe that I've addressed the fluctuation MPPT output problem, though I'm still seeing some communication interrupts.

What I've learned is that my Smart Battery Sense (bluetooth) Smart Ve network might be conflicting with my existing Ve.Can/Ve.Bus communications as it was explained that it is probably flapping is because I have DVCC enabled; which sends a max current and a voltage-sense update to the chargers, and then also a Smart Battery Sense which also sends the voltage-sense update as well.

I was asked to remove the Smart Battery Sense from the equation to see if that improves the communication issue. Tomorrow is the next solar day to observe and will report my findings here.

Paul B avatar image

I have not done this configuration however,

How have you connected the CCGX to the 3 x MPPT units. I presume you are connecting them by USB going through a USB hub then to the CCGX, Maybe the hub is giving you connection issues between devices and is not switching fast enough.


7 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Clarification. I have 2 MPPTs.
I am using a 12v powered hub to connect the CCGX to the 2 MPPTs.

https://www.amazon.com/Mountable-Port-Rugged-Industrial-USB/dp/B001H7AFO6

I'm also using a Smart Battery Sense device at the batteries to create a Bluetooth network between them. I thought that this is where Shared Votage Sense and DVCC can really help.

Maybe these 2 configurations are conflicting?


I'd first try to connect the MPPT's directly without a hub, next with ve.direct cables, try one / both, etc.
try without the smart battery sense. etc.

Hopefully a quick find / fix.

That usb hub looks good btw, hopefully that's not the source of the problem, would like to use it if it doesn't give problems ;)

Well, whats even stranger was that this configuration was working perfectly since inception last May, and then one of the firmware updates that I've done since last Oct/Nov have caused this. So I'm not sure if its my hardware and a new failure, or if its in one of the software updates. I'd really like to know if we could dig into logs someplace to see what/why this is happening...


@Boekel
I just ordered a pair of 10m VE.Direct cables to replace my USB hub arrangement (next day) and will test this.

But be aware, if I had to do it over again with Ve.Direct to USB cables, I would have gotten a powered USB hub with ports arranged a little differently as the ends of the VE.Direct-> USB cables are WIDE and will interfere with each other on standard spaced USB ports.

In the picture you can see that the 2 cables are interfering with the other 2 ports, rendering them useless.

So, to me, a hub such as the one below would offer MUCH more room for the wide cable ends: https://www.amazon.com/Mountable-USB-3-0-hub-

Industrial/dp/B004C3W25M/ref=pd_lpo_vtph_147_tr_t_2?_encoding=UTF8&psc=1&refRID=BPCZW36Y0A6KDS1RP9AF

30 meters? That might be a clue...

I hope it works, but I think (think, not know) it might be a bit too much...

Yah, That was a typo that for some reason I can't edit that post in Firefox anymore. It just sits there when I submit my changes and doesn't do anything. But I was able to edit it in Chrome.

My USB cable is actually 16', with the short Ve.Direct->USB cables to the MPPTs.

(Victron doesn't don't make a 30m cable and I actually ordered 10m cables (30ft) and they showed up today!)

I'll get the cables ran and test it out hopefully later today.

To provide a status update.

Still using the USB hub and Ve.Direct -> USB cables, my MPPT's output seems to have stabilized.

I am unclear as to what exactly may have actually corrected the issue as I was becoming frustrated and made multiple 'changes' at once prior to testing, but in the end I have satisfactory results. (see graphic below)

During my testing/troubleshooting;
I had disabled DVCC and 'reset' the inverters.
Then I re-enabled DVCC and 'reset' the inverters.
I then upgraded to 'latest-release-candidate' CCGX firmware.
Correspondingly, I updated the MPPT's firmware with the latest VRM app.
I also had power cycled the entire system.
(shut down PV, shutdown Grid, shutdown DC batteries, and brought back online.)

My initial results are a much improved MPPT power output through the solar day. I no longer see the MPPT output flapping between the two solar charge controllers.


The main 'grid' power was terminated at 10am. The power output for each of the MPPTs was much more consistent. The lack of logging in the 288 device was due to a MPPT firmware upgrade that failed and had to be re-initialized (but completed successfully).

I still see connection issues via the CCGX where each of the MPPTs drops its networking connection and goes into 'standalone' mode, but the output no longers goes to zero when it does.

Again, I am unclear on the actual solution to the problem.
I will continue to monitor as we begin the Sunny Season here in Northwestern America.


mpptupdate.png (50.1 KiB)