question

coreyzev avatar image
coreyzev asked

[SOLVED] RPi 3 Venus OS not seeing Smart Shunt VE.Direct over USB

Solution TLDR: Isolation was the issue. See my reply for more info.


I have a system w/:

  • RPi 3 running Venus OS v2.80
  • Multiplus II [2729] connected via MK3 VE.Bus to USB
  • SmartSolar MPPT VE.Can 150/85 rev2, connected via VE.Direct to USB
  • SmartShunt 500A connected via VE.Direct to USB
  • 48v Battery bucked to 12v for systems that need it


At first the SmartShunt was showing up in the Venus OS system just fine. I then installed the third party library to use a JBD BMS w/ Venus OS, and things started getting wonky. Suddenly, I couldn't see the smart shunt in Venus OS anymore.

I disabled, then removed the files for the bms library, still no smart shunt.

I confirmed the smart shunt was active, and I could see it via bluetooth. All connections were solid. I tried the cables in various USB ports, and as well as in both the SmartSolar. Everything works in every USB port w/ every cable on the SmartSolar, but nothing works w/ the SmartShunt.

I then completely formatted my SD card, reinstalled the v2.80 OS from scratch, and set everything up again. No SmartShunt, still confirmed it all worked w/ the SmartSolar.

Finally, I plugged the SmartShunt using the same VE.Direct to USB cable into my windows computer with VictronConnect, and after downloading the drivers, was able to see it over USB (confirming it was not via bluetooth, not that that feature is available for windows anyway, but just to make sure).

I have power cycled my entire system, and disconnected the smart shunt from all devices for 10 minutes. Nothing works.

I am at a loss for what to do next. Please assist.


InstaEDIT 1: Yes.... ::sigh:: I am using a DIY cable, a Victron branded cable will be ordered asap, BUT I have confirmed it works in literally every other situation, except this one.

Is it true that the Victron cable has an isolator in it as well as the Prolific chip in it?


EDIT 2: The Pi is powered by the system it's monitoring. I have the 48v battery connected to the shunt and a lynx distributor. The distributor connects to the smartsolar, the multiplus, and a 48v -> 12v buck converter (a decent one). That is connected to my fused distribution panel. And then there's another 12v -> 5v buck converter between the distro panel and the RPi. Everything is grounded together, more or less. The Pi works fine generally, and has no issues monitoring any other devices.

BMV Battery MonitorSmartShuntRaspberry PiVE.Direct
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

During the 2nd reinstall, I installed VenusOS Large, but can reboot into 2.80 normal if needed. The following is on Large v2.80~41-large-25.

First I ran a loopback test w/ the cable on my PC in PuTTY, works as expected.

Connected the cable and tailed /var/log/messages:

Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.242505] usb 1-1.3: new full-speed USB device number 7 using dwc_otg
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.375506] usb 1-1.3: New USB device found, idVendor=067b, idProduct=2303, bcdDevice= 3.00
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.383928] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.391284] usb 1-1.3: Product: USB-Serial Controller
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.396387] usb 1-1.3: Manufacturer: Prolific Technology Inc.
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.426622] usbcore: registered new interface driver pl2303
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.432325] usbserial: USB Serial support registered for pl2303
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.438676] pl2303 1-1.3:1.0: pl2303 converter detected
Feb  3 04:17:46 raspberrypi2 user.info kernel: [ 3475.447842] usb 1-1.3: pl2303 converter now attached to ttyUSB1

then nothing.

When I plug the same cable in the same port into the SmartSolar, it shows the exact same thing, except for the fact that it works still.


0 Likes 0 ·
3 Answers
coreyzev avatar image
coreyzev answered ·

So, self-answer. But I still have questions. It seems to be a power issue to the raspberry pi. I'm using a pretty cheap buck converter, and I'm still figuring out grounding. it all has a common ground. I was starting to get it figured out... I got it connected a few times intermittently:

screenshot-2022-02-03-011937.png

I had it grounded to the distribution panel as described above. The buck converters are not isolated and had common grounds. But in series.... it seems I have not enough of a clue of what I'm doing. Need to make sure I'm grounding this all correctly.

Reading this [link], but still confused.

So the question I still have, is why did this work w/ the SmartSolar to the RPi but not the Shunt. Is it because of where the shunt is in regards to everything else?

Again, this will likely be solved by the Victron cord if it has a ground isolator in it, yeah?


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kevgermany avatar image
kevgermany answered ·

@coreyzev moving to modifications, hope you get some help there.

Those cheap buck converters aren't very good, I had a few problems with lack of isolation. But sorry, no idea how to resolve.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

coreyzev avatar image
coreyzev answered ·

DISCLAIMER: As described in this comment by mvader themselves, issues where DIY cables are involved will not be supported by Victron staff. Many hours have been wasted troubleshooting and if you want help from Victron, start by using the official supported cable.


SOLUTION! Get an isolated USB Serial adapter!

The serial adapter that is listed in MOST of the DIY VE.Direct cable tutorials is not isolated. The Victron cable is isolated. This leads to issues when trying to communicate with something like a shunt because you get ground loops. So... to (probably) not fry your stuff AND to get info from your shunts, try the below.

The original cables still work w/ my SmartSolar (for now). We'll see if that becomes an issue when I start actually using it for charging.

How I connected my BMV or SmartShunt to my VenusOS device:

  1. Replace the bad buck converter with a less-bad one.
  2. Get an isolated USB to Serial adapter.
    • I purchased this one. It's an "isolated FT232RL USB to TTL".
    • Use the included jumper to do a loopback test to confirm it's working.
      • Google will teach you how to do this w/ PuTTY.
    • Remove the plastic casing so it doesnt interfere with other ports.
    • I heat-shrinked mine with clear heat shrink.
    • It doesnt matter which voltage you choose because you wont use it. Leave the jumper where it is.
  3. Connect the adapter GND, TX, & RX pins to the Victron component the same way that one is instructed in all the other DIY cable tutorials. (Do not connect the VCC 5v or 3.3v to the Victron component, or else).
  4. Plug the devices in.
  5. Shazam!! You should have a working connection between your shunt and your VenusOS device.

This worked for me, it may not work for you.

Good luck!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.