question

billknny avatar image
billknny asked

Cerbo WiFi Won't Auto Connect to WiFi

My Cerbo will not automatically connect to any wifi source. All connections have to be manually initiated through the menu. Rebooting the Cerbo or the WiFi router does not help. Other networks and phone hotspot all show exactly the same behavior. Connections can be manually initiated, but never automatically.

The installation is on a sailboat where the wifi environment is challenging. A connection rarely lasts more than a few hours, so having a lack of automatic reconnection is more than a bit of a pain.

Is there a setting I am missing?

cerbo gxwifi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
billknny avatar image
billknny answered ·

I will answer my own question here, and see if I can accept it myself...

The setting I was missing was "Enable access point". If you have the access point enabled, then the device will not automatically connect to another WIFI point.

I guess this was obvious to everybody else, but there might be other people out there with my level of networking sophistication so this is for all of us!

5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

green-monster avatar image green-monster commented ·
Thanks, so you need to disable the access point in the Cerbo GX to prevent it from not reconnecting to the local AP you want to use. But if you do that, then when you want to locally access the settings in the Cerebo, you need to be able to plug into it on its LAN port, because the Bluetooth remote console uses the Cerbo GX access point to change the settings. Very frustrating.
0 Likes 0 ·
ezraabel avatar image ezraabel commented ·

Thank you very much for resolving this for me.

wordle

0 Likes 0 ·
checkit avatar image checkit ezraabel commented ·
We have never disabled the access point on a Cerbo GX. It always automatically reconnects to the local Wifi router after rebooting. Surely Victron would have made it clear in the documentation that the access point must be disabled for automatic re-connection.
0 Likes 0 ·
seb71 avatar image seb71 checkit commented ·

Same here. I have the Cerbo GX AP enabled and if I unplug my WiFi router, after plugging it back (the power supply), the Cerbo GX re-connects back to my WiFi network. LAN/UTP cable is not connected to my Cerbo.


But Cerbos's AP uses CH1. If the WiFi router uses CH1, too and also has a weak signal at Cerbo's location, maybe in some cases the internal AP causes too much interference on that channel. Just guessing why disabling the internal AP might help in case of OP. So if that is the case, I would first change the WiFi channel (in the WiFi router), from channel 1 to channel 6 or 11.

1 Like 1 ·
checkit avatar image checkit seb71 commented ·
That sounds like a very plausible reason why some people have this problem and others don't. If we ever encounter this problem on new installs, I'll try your solution first before disabling the built-in AP.
0 Likes 0 ·
seb71 avatar image
seb71 answered ·

Best option would be to use a LAN/UTP cable between Cerbo and your router.

Another option would be to use an external Wi-Fi USB dongle, which might get you a better connection.


There is also the option to set Cerbo to reboot if there is no connection for a certain time, but you said that rebooting Cerbo does not help.


If you have the external display, there is a known issue with some older Cerbo units (the internal antenna wires must be re-positioned).


Also, which firmware are you using (for Cerbo)? Some are better with WiFi.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

billknny avatar image billknny commented ·

I can not routinely use a hardwired connection. Frequently I am connecting to either my phone's hotspot, or to a marina wifi connection.So no local router to plug into.

The wifi antennas have been reposition in the case as per the tech bulletin on the subject.

Let me repeat: There is also no problem with manual connections. tThose are made without issue. As far as I can tell, when known wifi networks are shown in the wifi list, no attempt is made to connect to them. Not even when comming up from a reboot.

Current installed Firmware is v2.80~21-large-23

0 Likes 0 ·