question

trevor-bird avatar image

Cerbo GX ethernet integration with Garmin 8417 MFD

We have a Cerbo Gx connected via the ethernet LAN port to a Garmin 8417 MFD. All latest software version. If the Cerbo is connected to a Wifi network the system works fine. If the Cerbo is not connected to the Wifi network the MFD prompts with a message that the MQTT server cannot be found. It also intermittently advises "An error occurred while rendering the application."

Are we doing something wrong?

img-0341-copy.jpgimg-0343-copy.jpg

cerbo gxsystem integrationmarine mfd app
img-0341-copy.jpg (530.3 KiB)
img-0343-copy.jpg (162.0 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Paul B avatar image
Paul B answered ·

On the cerbo are you on the latest release FW. as thats quite important. also if not MAYBE try the latest release candidate as the problem may have been fixed, There is a list of the fixes on the comunity under modifications have a look and read if that is a issue then if it is then TRY the update. but always go back the the latest release for stability, you can leave it on the beta release but there is NO victron support any issues on this .

https://community.victronenergy.com/questions/101754/venus-os-v28017-available-or-testing.html

1631942416424.png



1631942416424.png (15.1 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks Paul,

The firmware in both MFD and Cerbo GX are latest but I haven’t loaded the unsupported software into the Cerbo. We will be a long way form this installation soon and don’t really want unsupported firmware included in this installation. We will have permanent wifi soon so I am hoping the problem will be resolved but without that we would have to pull the Ethernet cable out and not provide the feature.

JohnC avatar image
JohnC answered ·

Hi @Trevor Bird

I can reproduce both those issues on my system. Which isn't a Garmin, just a Win10 lappy.

The MQTT thing always when I lose my WAN (or LAN), with either wifi or ethernet. (I use both, a failover thing).

The Rendering when I zoom the screen over a wide range. The app seems to get confused with some screen resolutions, perhaps while it's rearranging it's own layout. Recoverable with a screen refresh. I usually leave it up in a separate browser screen, and sometimes when I return to it this error shows.

Not your answer, but perhaps somewhere to look.

The MFD app is undergoing a rebuild currently, and maybe we'll see some changes on it's release?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

trevor-bird avatar image
trevor-bird answered ·

Many thanks John for confirming that the problem is not peculiar to our installation but rather a systemic issue. We will soon have it on its own wifi system but with the loss of the wifi it may confuse the owner in its current state. Perhaps something our friends at Victron may contemplate if refining the MFD software.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.