modifications Image


Modification Subjects that do not need a separate topic

Adding additional Lithium batteries and resetting the Ah value

I have a MultiPlus 24/3000/70-16 inverter and recently upgraded from Lead Acid to Lithium Batteries. Originally, I had 4 x 12v 200Ah batteries set up as a 2 x 24v 400Ah system. When switching to Lithium I used 2 x 24v 100Ah batteries which my installer programmed into the menu. A week ago, I added another 2 x 24v 100Ah batteries, and now realise that the settings need to be changed so that the inverter knows there are 400Ah available and not 200Ah. As a novice, I don't know how to access the menu to change those values. Can anyone help?

rod-evans asked
derrick thomas commented ·

2 Answers

Charging Voltage and Current Settings - Mixed Batteries

I have a Quattro 48/15000/200-100/100 Inverter; two SmartSolar MPPT RS 450|100 Charge Controllers and Cerbo GX which I was using with a Wakatek 48V 300AH LFP battery pack which does not have any communication cable. I have DVCC enabled with max charge voltage 55.8V / max charge current 75A per Wakatek supplier requirement. For each charge controller, VictronConnect was also used to set absorption voltage / float voltage /max charge current at 55.8V/55.5V/75A. VEConfigure was also used to make the same settings on the Quattro. Worked fine.

Now I have just added two parallel Felicitysolar 48V 200AH battery packs model numer LPBF48200-N in parallel to the existing Wakatek 48V 300AH battery pack. The installer has changed the DVCC settings to max charge voltage 55.8V / max charge current 136A. Based on my current solar panels capacity (6.55KW of CanadianSolar panels) I can't generate more than about 136A. (I will soon add another 3.3KW of solar panels). But the Felicitysolar battery pack datasheet calls for 57.6V absorption and 57.6V float settings.

My questions:

1. Are these settings correct / optimal?

2. Does the charge controller setting in VictronConnect for max charge current apply to each charge controller or to the batteries on the DC busbar? For example, if each of the two charge controllers is set at max charge current of 75A, does that represent a max charge current of 150A to the batteries or still a max charge current of 75A to the batteries on the busbar? Just want to be sure.

3. Is it okay to continue to operate the Wakatek battery pack along with the Felicitysolar battery packs?

rotevery asked
snoobler answered ·

1 Answer

Can I remove these? Lynx Distributor - Cable separators


Can I snap these small pieces that separate the cables? The ones circled in red. Just the piece that splits it in half, not the piece between +/-

What is their intended purpose? I need to fit a large cable and don't think it'll fit with this separator.

bodizzy asked
bodizzy commented ·

1 Answer

Feature request: VRM option to calculate energies based on sum of all phases

While my system regulates feed-in based on "sum of all phases" just fine, all energies shown in VRM seem to always be based on the single phase sums. Unfortunately this also makes many other graphs useless like the consumption diagrams.

Currently the only workaround I know would be to purchase and hook up an external EM24 meter.

This issue has been discussed in other threads already but I couldn't find any info if this is going to be implemented.

One way to approach this would be to enable alternative sources for the consumed and fed in energy to pass on to VRM from the GX - no need to mess with the actual regulation which seems to work perfectly fine with the built in sensors of the Multis.

This is how I would see it work:

All the electronic meters installed today have an IR interface where you can read out the energy sums.

There are inexpensive readers for this based on Tasmota which provide the energy sums and more data via Wifi and MQTT for example with a one reading per second cadence, see this screenshot from a recent Westnetz device type ZPA.


I looked into this already but could not find the vrm logging scripts anywhere on github.

kaischmitz asked
kaischmitz edited ·

0 Answers

how feltch data PF and other parameter from ET112 to build node red dashboard

Dear team

I attempted to build my Node-red dashboard using the System parameters, however, I was unable to locate the ET112 parameter alongside other options like PF and MD.

Please give the solution for build own node-red dashboard

Dilip Kumar TD asked
Alistair Warburton commented ·

0 Answers

FeatureRequest: EasySolar2 GX & MP2 GX 2x16 Display Customisation - Show Tanks & Temperature Sensors On Built-In 2x16 Screen (For Offline Use)

Hey Everyone,

I dont think what we need can be done, so asking on here to double check and maybe get some upvotes in the hope Victron add to their dev list.

Open to suggestions for possible DIY modifications, if that is possible, but would prefer to avoid modifications to Victron GX products under warranty.

Snip below is from ES2GX manual - GX Device Display - lists no possible options for customisation


I have 2 client systems, both are mobile systems in RV's utilising a EasySolar2 GX 48/3000 at their heart. Both Systems have a USB Hub with BT dongle for Ruuvi's and a GX Tank 140, which is used to connect 24v 4-20ma Tank senders.

The problem comes from them being mobile installations, as the 4G signal can be patchy and is occassionally unavailable for their chosen location.

When they are offline, they have no way to access the Tank information without resorting to remote console on LAN, which is not really suitable for all types of User.

Connecting to a wifi network that doesnt have internet, to get to the remote console on LAN, to then be able to look at the tanks seems a bit crazy, as the GX device has an inbuilt display to provide the essential information at a glance.

Primary use of this display, IMO, would be for when there is no internet, so would be handy to be able to see all of the relevant information to the system on it, not just a set of defaults.

Whilst the Tank's not being displayed is the primary complaint, it would be nice to be able to display the Ruuvi tag information on this screen also, but tank information is most important.

As the GX device is integrated and internally connected to the multi & MPPT I cannot even swap it out for a Cerbo & GX Touch, so am a bit stumped on how to proceed.

At present the only option I have to resolve both customers complaints is to purchase a tablet/ipad, mount locally in Kiosk mode, then use this to display the remote console.

This is only marginally better than using remote console on a phone, if this is how it has to be done then I would have to use GuiMods to customise the remote console to show the info on the home screen.

Any suggestions on how else this could be done would be very much appreciated, cheap tablets are almost always trouble!

If these features can be added to Venus OS then they would be useful to all systems containting a ES2GX, MP2GX or MaxiGX.



alternativepowerprojects asked
alternativepowerprojects commented ·

1 Answer

Cerbo GX falling off of network. Sort of....


I recently started setting up a Cerbo GX on my local network. The CGX is new to me, so as far as I could tell, things were going well for several days as I explored and configured the unit. Then the weirdness begins. Here's what's happening.

I can reach the unit via VRM, and all Internet/browser-based functionality seems to be working. The strange thing is that, even with VRM working, I cannot access the remote console locally, via the unit's IP address. Even after logging out of VRM. Next, I cannot ping the CGX. The failure of this basic network function is worrying. I know the unit's fixed IP address, and my router shows it as a client through multiple refreshes. Rebooting the router changes little, and doesn't help. All WiFi settings have been verified (Netmask, Gateway, DNS, etc).

Now, if I log into VRM and use it's browser-based instance of the remote console, I can go into the unit and reboot it. As soon as the CGX restarts, I begins responding to the ping -t command I started earlier and I now can reach it with the remote console. Full communication. Either the reboot refreshes something on my network (still checking) or the CGX has fallen asleep locally. At this time, I'm not yet sure how long before it loses itself again. That I will keep an eye on.

Is there anything that would normally prevent one of these things from responding to a ping request? I'm running Cerbo GX firmware v2.92, which I think is the latest version. I recently installed Louis van der Walt's Victron VenusOS driver for serial battery BMS units (v.0.14.3 ) for a JBD BMS and Kevin Windrem's SetupHelper (v4.31) and GUIMods (v7.9), but I don't think any of these has any bearing on network connectivity. Anyway, I think this communication loss situation happened at least once prior to the software additions, but I didn't see it for what it was at the time. I'd hate to have to default the unit.

Any pointers?


packrat1969 asked

0 Answers

VRM Shows wrong energy flow direction
  • vrm shows a wrong energy flow into the invertor direction. But, technically there is no invertor connected in the system. Instead, I was expecting the energy flow into the DC Power direction (system is in bulk charge mode with DC load connected through smartshunt 500v).

  • Also, i can hear a buzzing high pitch noise from smartShunt 500 which is clearly audible in a noise free environment. is this an issue with my piece?. i can see some of the users reported the same with smartShunt 500 model.

** all negative connections (PV Charger & DC Load) go from smartShunt terminal

Can anyone please shed some light on what is going on here


jimz asked
jimz answered ·

2 Answers

URGENT: Battling with USB on MultiPlus-II GX with Powered Hubs

Due to the non-availability of MultiPlus II, we have been using MultiPlus-II 5kVA GX and are having serious problems with the USB port for multiple USB / VE.Direct devices.

All installations I am referring to now have maximum 2 x MPPT (1 x USB to VE.Direct) and 1 x Energy Meter (1 x USB to RS485).

We are using high quality 30 USD D-Link DUB-H7 hubs with 12V power from an Orion 48-12 DC DC Converter. On a near daily basis, we are having to reboot the GX device because one of the two USB devices disappears.

It has been suggested to me by another installer that this is a nanopi problem. We would appreciate some assistance from Victron in this respect. PS. We did try USB powered hubs and we had the same issue.

We now have 5 installations with this issue and around 3 more going in each week. We have to find a solution.

Warwick Bruce Chapman asked
gazza edited ·

6 Answers

VRM Advanced - Cerbo GX system uptime

Would it be possible to add to VRM the ability to publish the uptime of a Cerbo GX system uptime? Also publish Cerbo GX restart into the event log?

I am troubleshooting an intermittent problem with my Cerbo GX WiFi where it occasionally stops and have the "restart GX after X" feature enabled. I would like to be able to more easily monitor when it restarts.


John Leslie asked

0 Answers

Grafana daily totals (Grid Tied Inverter)

Hi all

In process of setting up a Grafana dashboard to monitor my ESS system but can't seem to work out how to display the total yield (daily, month so far) of my grid tied PV inverter.

I have a ET112 meter on my solar and displaying current generation is working fine

Tried different query options on several fields but can't see to nail it

Anyone managed to who wouldn't mind sharing the secret?




simon-jukes asked

0 Answers

Two separate ESS 15kVA and 500VA


I currently have 3x MP ii in parallel, running well in ESS configuration no issues and very happy I chose Victron except after a year I realised the efficiency is not as expected and trying to improve.

I’ve seen multiple posts and read manuals but can’t satisfy my knowledge on what would be the best approach to this particular scenario.

For low demand times I want to implement a small 500VA multiplus and turn off the bigger inverters, connected to the same 40kWh battery

One approach I know would work would be to double all components: Modbus meter, smart shunt, GX device, this wouldn’t be worth the effort

What I’m hoping is to be able to tap in the Cerbo somehow to share the existing data available for the small inverter to keep the ESS grid set point at 0W.

I’ll have to use only the AC IN terminals on both inverter systems for this set up

It’s almost like I would need a transfer switch on the VE bus.

Any suggestions much appreciated

Thanks George

apple047 asked
apple047 commented ·

2 Answers

Low amp soft starter recommendations?


Like many others, I have a small fridge which is creating such a surge when the compressor kicks in that it hits the inverter (Phoenix 12/800) too hard.

The solution would be a soft-start module between the fridge and inverter. I am only finding these at around 16A current limitation. This would mean a peak wattage limit (~3500W) above what the fridge is creating anyway, and still higher than the peak the inverter can handle.

Is my reasoning correct?

Or, would a common 16A soft-start module do the trick anyway?

Or, can you recommend any low amp (by my maths, less than 6A) soft-start modules to keep the peak below inverter peak?

Thanks in advance!


hry asked
Nev answered ·

2 Answers

Phoenix 12|800 Inverter - surge / peak / spike protection or smoothing for refrigerator?


I have a setup running a Phoenix 12/800. It is all running very nicely with one issue:

We have a very small (43L) Ikea fridge/freezer which uses only about 30W continuous power when on. The problem is, when it cycles to ON (ie compressor kicks in), it demands such a peak that the inverter jumps into the red zone of the meter (bluetooth app) for about half a second before coming way back down to 30W. In this time the inverter is clearly struggling and the lights dim etc! While plugged in, the fridge cycles on/off once every 5-10 minutes. Naturally we have now disconnected the fridge.

  • Is there some utility to 'absorb' / 'smooth' this peak as not to stress the inverter so much? Will a surge protector do this, or just turn off?
  • Are there fridges with smoother / softer peaks, or is this a universal issue?

FYI: Battery bank is 3x 280Ah 12V, with 35mm2 wire connecting. Wire from battery bank to inverter is 25mm2, which i believe is the largest you can fit into the connectors on the inverter housing.

Update: some have recommended soft start modules, if anyone can recommend a specific unit I would be grateful!

Many thanks for any input!


hry asked
hry edited ·

2 Answers

Smartsolar not showing up in venus or vrm anymore

I have the Venus Pi, Smart Shunt 500 and the Smartsolar MPPT 100/30. All updated to the latest firmware and connected with the Ve. Connect USB cable.

When I plugged the solar into the Venus I could see it. Later on it has disappered. I think it happened after reBoot or firmware update. The MPPT has not the solarpanels connected yet, but is connected in the battery side.

The Smart Shunt is working correct

Any clue?

kurtinge asked
w8dev answered ·

3 Answers


Topic resources

We haven't added any resources for this specific topic yet
119 Posts
99 Users

Topic Experts