question

David avatar image
David asked

DC Feed-in in not working. DVCC / ESS

I cannot for the life of me get DC Feed-in working.

Gear:

Multiplus II 5000

2x 150/35

Batrium BMS to 45kwh Lion battery

A stack of AC solar on the AC Input side

EM24 grid meter

EM24 - to measure AC solar production.

Scenario:

Battery full 4.1v per cell or 57.4v

BMS sending CCL of 0

DC Feed-In enabled

Settings:

MPII and MPPT float / absorption set to 57.4, However it doesn’t seem to make any difference as I’ve set these higher without effect.

What Happens:

With DC Feed-in enabled the MPPTs correctly go flat out. However rather than the power being inverted by the MP II and going into the grid, it goes into the battery despite it being full.

If I disable DC Feed-in the MPPTs correctly ramp down (because the battery is full)

I cannot get a safe system with DC Feed-in enabled -

It will cook the battery.


From what I can gather, my BMS is sending the correct target voltage 54.7 and correct CCL of either 0 or 0.5 ( the balance current)

I see many other posts with DC Feed-in issues but none with any resolution to this specific issue.

Note: I don’t have any limits on feed-in set.


any help would be appreciated.


ESSDVCC
4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have recorded a video demonstrating this issue

https://www.dropbox.com/s/gbup8f4yy4vflwg/victronbatrium.mp4?dl=0

The battery is at 100% SOC - perfectly balanced at 4.1v per cell. BMS is in limited charge mode of 0.7amps.

With DCFeedin Enabled, the entire DC Solar goes into battery.

With DCFeedin Disabled, the MPPT's ramp down to zero as they should.

If I leave DC Feedin enabled, it seems to want to overcharge the battery.

0 Likes 0 ·

Why is the venus SoC at 99% and not at 100%? Have you tried to enable dc feed in, when the battery is at 100 SoC?

How is "Minimum Discharge SoC" in the ESS settings configured?

0 Likes 0 ·

Another example video - This time, with the battery close to top of charge, but not quite there.


With DCFeedin Off- the MPPTS are regulated to exactly what the BMS is requesting (20a) - however as soon as DC Feedin is enabled, the MPPTS ramp up, but the Multi fails to export the power, so the power goes into the batteries, against the BMS's current limits.

Video: https://1drv.ms/v/s!AjZQHTTRHDNghoc6PPg9TGk353QKaA?e=NfgfHW

0 Likes 0 ·
Further to my previous posts, I have done a stack of reading and a stack of setting experiments.


I have discovered that with DC Feed-in enabled, the CCL value from the BMS is ignored. Only the CVL seems to have any effect.

So as soon as DC Feed-in gets enabled, the current from the MPPTS ramps up and the battery takes it in if its voltage is under the CVL.

I cannot explain why the CCL value gets ignored when DC Feed-in is enabled.

If I set the CVL to a level lower or equal to the battery voltage, the MPPTs current gets inverted and feed into the grid.

However, the GX device should ALWAYS honour the CCL and the CVL will almost always be higher than the actual battery voltage.

Help!

0 Likes 0 ·
3 Answers
Mike Dorsett avatar image
Mike Dorsett answered ·

Do you have the correct grid standard selected in the multiplus configuration? By default these come with no standard selected which disables feed in.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes, correct grid code enabled. I also have uptodate ESS assistant running.

0 Likes 0 ·
steve-3 avatar image
steve-3 answered ·

Hi @David, I think I may have a solution for you allbeit not 100% perfect. I was having a similar issue after I installed my MPPT, and came across your post trying to work out how to stop the MPPT charging the battery after the battery was fully charged and the BMS was on CCL of 0A. So my set up is very similar to yours, 5kVA MP II, 250/60 MPPT, CCGX, Batrium BMS, 16 x 400Ah LiFePO4 prismatic cells, 5kW Fronius inverter on the AC input side of the MP II, 3.2kW PV on the MPPT with a current limit of 40A. In the ESS grid feed-in settings I had the DC feed in on, then after I read your post switched it off, and presto MPPT ramped down to 0 when battery was full. I wasn't interested in feeding the DC into the grid at that stage, but then thought well surely you must be able to do, it so made contact with my supplier in Brisbane, Batteryworks. After I had told him what was going on he suggested to try setting the Limit Managed Battery Charge Voltage setting in DVCC(apparently it's a new feature that came out a couple of months ago), which worked.

screenshot-2021-12-16-184614.png

So the trick is to set the max charge voltage at just below the BMS cell bypass voltage, if it's set too high the cell monitors stay in bypass for way too long and you'll burn them out in no time. My cells are fully charged at 3.5V, so 55.7 is the sweet spot. If I go 55.8 the Blockmons stay in bypass at about 1A and get warm very quickly, at 55.7 it's just under the cell bypass voltage and everything's sweet, and because the MPPT sees the 55.7 limit starts feeding the DC into the grid, the battery is idle and everything's happy. The not so perfect bit is the cells don't get balanced(although they nearly do), so once a week I turn off the DC feed-in and DVCC limit managed battery charge voltage and let the BMS do it's bypassing/cell balancing trick. Then once the BMS switches the charging off for the day, switch the DC feed-in and DVCC back on and it starts exporting to the grid. The run of nice weather we've been having in Perth recently I've been exporting about 18kWh a day, most of that after 3pm which we get 10c a unit for, should add up to a nice little credit on my next bill.

Hopefully this helps your situation.


2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @steve-3 - Thanks for the suggestion.


Today and tomorrow will be sunny so I can get my battery full, and I will give this exact scenario a go. However, by adjusting the voltages, I was able to get DC Feed-in working but at the expense of the CCL value being ignored. IMHO this is a vital safety issue that cannot be ignored - The BMS has no control over the charge current with DC Feed-in enabled. I have tried getting Victron to explain why they completely ignore CCL with DC Feed-in enabled - its such a monumental change in operation that is completely undocumented. My requests fell on deaf ears. Your Victron gear will charge that battery as fast as it can up to the limit voltage REGARDLESS of the BMS reducing CCL values. IMHO a dangerous situation. If a cell goes bad, or is slightly out of balance, things will go wrong.

0 Likes 0 ·
Thanks for this reply Steve, I'm struggling with the same problem. Changed the settings and lowered the voltage. Waiting for better (sunnier) wetter to test further.

Thank you for you post


0 Likes 0 ·
baxter avatar image
baxter answered ·

Is there any update on this? Is Victron willing to solve this safety issue??

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.