question

justmurph avatar image

Cannot update Multiplus 5k firmware in VE.Bus BMS System

I've tried to update the firmware on a Multiplus 24/5000 using both VE Flash and Victron Connect via a Mk3 dongle and the crux of the issue seems to be that you can't update the firmware with the VE.Bus BMS connected. However if you disconnect the BMS, the Multi turns off.....so you can't update the firmware anyway.

I tried deleting the BMS assistant so that it can turn on with out the BMS, however it just flashed an error code and still turned off when the BMS was disconnected.

How do I do this properly?

MultiPlus Quattro Inverter ChargerFirmware Update Issue
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

@JustMurph

I updated many systems with or without VE.Bus BMS.

You have to unplug the BMS and then you should be able to run the update.
Yes the Multi will stop inverting but it is sill "ON" as long as the switch is ON.
So just start VE.flash and do what the program tells you.

Save your settings before updating, the update will reset everything to default.

5 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

That most definitely does not work, in either VE Flash or Victron Connect. It results in an error where it says the MK3 did not respond.

I just reset the multi to factory settings and it flashes up error code 7......for which there is no description in the manual (absorption LED solid and float flashing in opposition to inverter). It works normally again when I reload my previous settings.

So I found that error 7 is that there is a BMS connected, but not configured.

However when I disconnect the BMS, the multi turns off, despite not being configured for the BMS.

Righto. So I got it to update, but I'm not sure why this fixed it.

I have a switch wired up to the remote on/off/charger inputs. When I switched it to charger only, then you could hear a relay switch and the unit turned on (with no lights) and would accept the update. It was in the "on" position before where it wouldn't work.

I have the same problem updating a Multiplus from firmware 418 product id 2659. Sometimes it would not turn on and VEFlash does not detect the Multiplus.

Now, we have GX Error 48.

jocson-error-update.png

justmurph avatar image justmurph harry-chavez ·

Are you using a remote on/off switch?